VEGAS Pro 16 Update 2 (build 307) - General Discussion

Nick Hope schrieb am 27.10.2018 um 08:30 Uhr

Although not yet officially announced*, VEGAS Pro 16 Update 2 (build 307) is available.

If you already have an earlier build of VEGAS Pro 16 installed, there is no need to uninstall it. Build 307 will overwrite your installation and retain your settings. Your computer will need to be online for activation after the update.

Download link. Another download link. At this moment, the download managers (...dlm.exe) are still fetching build 261.

 

*Update Oct 29th: now officially announced.

 

New Features

  • You can now set any preset of the Titles and Text media generator as the default for the Insert Subtitles from Files and Insert Subtitles from Regions functions
  • You can now create subtitles by importing SRT files with the Insert Subtitles from files feature
  • Video scopes can now be set to display the NITS scale for HDR work, including for 8-bit projects
  • VEGAS now warns you if no track has been armed for recording when you start recording and enables you to specify which existing track or tracks you want to record to, or to create a new track and record to that
  • Replacing media in the Main Storyboard timeline now updates the project timeline
  • The user now has the ability to "pin" another video event to a motion tracked event
  • Custom frame rates can now be set when encoding using AMD and VCE render templates in the MAGIX AVC/HEVC formats
  • The Main Timeline storyboard no longer automatically reacts to changes on the timeline. A Refresh Storyboard button has been added to the Project Media window when viewing a storyboard which enables you to manually match the storyboard to the timeline
  • A Red background for the Main Timeline storyboard alerts the user when the storyboard is out of sync with the project timeline and must be manually updated
  • A dialog box warns the user that the Main Timeline storyboard cannot be altered until it is updated to be in sync with the main timeline
  • A Red warning bar at the edge of storyboard thumbnails indicates when the timeline event is longer than the media it holds
  • You can now set in/out points in the storyboard for audio-only files
  • You can now set in/out points in the storyboard for still-image files
  • The Storyboard now properly recognizes L and J cuts and orders itself appropriately
  • Added support for time stretched/compressed events hover scrub in and out point trimming, and storyboard refresh
  • A new OFX plug-in enables you to add video stabilization to 360° video

Bugfixes

  • The Neat Video (and other temporal effects) now works properly when placed before Pan/Crop in an event FX chain
  • MTS files now render properly at 25p or lower framerates
  • The Internet HD 720p 29.97 fps (AMD VCE) template now yields the proper framerate
  • Reordering items in the storyboard no longer causes media in and out points to be reset
  • Audio recorded using Quicktime on a Macbook Air no longer get corrupted by so4compoundplug
  • The stabilization tool's Zoom parameter now properly persists through project save, close, and reload
  • The Render As dialog box no longer gets hidden off screen in a dual monitor set up which would cause the appearance of VEGAS freezing
  • Media in and out points are now properly honored when adding an unassociated storyboard bin to the timeline
  • The Insert Subtitles from File operation now properly recognizes commas in the subtitle text
  • The Add at Project Frame Rate operation now works properly when the media frame rate does not match the project frame rate
  • The audio meter context menu properly appears as expected again
  • The Scene Rotation plug-in has been optimized and should no longer cause occasional crashes at start up
  • The AutoSave function no longer triggers the creation of an unwanted duplicate storyboard which could occur in some cases
  • Crash has been resolved when using video stabilization and motion tracking with an AMD Phenom II card
  • Double-clicking Color Correction custom tab parameters now properly sets the parameters to their defaults
  • Overwriting files when rendering with AMD VCE templates now properly reports file size
  • Deleting storyboard placeholders no longer cause crashes as they did in certain instances
  • Replacing a generated placeholder with a clip no long crashes the application as was the case in certain scenarios
  • Moving generated media in the storyboard now follows expected behavior
  • External preview now works properly through Decklink cards in 32-bit projects
  • Fixed potential inconsistencies caused by replacing a generated placeholder with a video clip
  • Moving a generated media thumbnail to the end of the storyboard no longer causes an unwanted duplicate thumbnail
  • Sync Cursor to Media Timeline again works properly when user clicks on a keyframe in the FX automation section
  • Unwanted extra generated media thumbnails are no longer created in the storyboard when changing the order of thumbnails
  • Importing bins from one project into another no longer causes a crash
  • Importing media from one project into another now works properly
  • The BattleCompVintage VST and other plug-ins now work properly
  • 32-bit projects created in older versions of VEGAS now open properly as 32-bit in VEGAS Pro 16
  • Dragging a media generator to the Main Timeline Storyboard no longer causes a crash
  • The render destination folder is now used for temporary file creation during the render process to avoid inadvertently filling up the user's C: drive
  • Certain specific MOV files no longer cause a crash when stabilization is applied
  • Switching through presets no longer disables stabilization in any case
  • Event Pan/Crop animation now works properly on events that hold still images
  • Color samplers in the Parameters and Custom tabs of the Color Corrector OFX plug-in are now correct and consistent
  • Stabilization of video clips that contain zooms now works properly
  • The Auto Zoom option now works more exactly to eliminate black borders
  • Right Alt+z and Shift+Right Alt+z now properly give users of the Polish localized version ż and Ż
  • Color Curve channel behavior has been improved so that changing the channel on one changes only that one and no others, and new curves are always added with the default settings instead of the settings from the previous curve worked with
  • All files now retain Markers & Regions in Trimmer
  • Timeline performance problems caused by automatically updating the Main Timeline storyboard during a timeline edit have been resolved

Kommentare

Martin L schrieb am 27.10.2018 um 09:47 Uhr

Great news indeed!

I just wonder: Why not yet officially announced? Is this a Beta version?

The bug fix list doesn't mention any fix for the supercommon issue of VP16 not opening, freeezing or crashing at start-up, as mine does. (Actually the entire PC freezes and has to get a forced switch off and restart) Has that problem been fixed or is that for a future update? Or perhaps the official Update 2 (Build 307)?

Nick Hope schrieb am 27.10.2018 um 09:56 Uhr

I don't think it's a beta version. It's on the same Magix servers in the same naming format as previous releases. I think it just "got out there" before Magix got around to announcing it and updating the download managers. I don't believe it would have reached that public server unless it is "official". It installed and runs for me without anything obviously suspicious. If you choose to install it then pls let us know if those issues are fixed. Not everything makes the release notes, especially if it's not clearly definable.

Soundivad schrieb am 27.10.2018 um 10:09 Uhr

just installed the update

first two things i tried already got two crashes, one at loading my actual project, the second on the video stabilisation analysis at 53%.

The Video Stabilisation autozoom is still to agressive. If you adjust the zoom slider and leave the autozoom selection checked, on loading the project the slider is back to the initial autozoom level... if this is intendet the check box should be automatically disabled if you change the zoom slider manually.

Peter_P schrieb am 27.10.2018 um 11:52 Uhr

I keep getting freezes with this B307 working in High-DPI mode with 149% scaling. This scaling allows to use the FX interface, however the text is not as clear on my new 32" UHD monitor as with 175% scaling.

The freezes occur on my system even when only moving the FX interface window on the screen with just one UHDp30 event in the time line and can not be stopped with Ctrl-Alt-Del to activate the taskmanager. It does just not allow to start the task manager. On my last try I could not even restart the system with the reset button. I had to switch the power off and finally gave up with this version, that is linked in the top of this thread.

System : i7-8700k with 32GB RAM, AMD R7 running Win10pro 1709

RogerS schrieb am 27.10.2018 um 12:20 Uhr

Looks like some very worthwhile updates to make the new features work as promised. I don't see anything about rendering or GPU fixes, so I guess I have to wait longer before trying the demo of 16.

dream schrieb am 27.10.2018 um 12:41 Uhr

great but i have no problem with 261,but asked about .mkv import 😔 and some minor crashes

Marcin schrieb am 27.10.2018 um 17:01 Uhr

Incorrect combination of frames of accelerated clips remained after switching on the "Deinterlace" method in HD 1080-50i projects (1920 x 1080, 25,000 fps).

Martin L schrieb am 27.10.2018 um 17:57 Uhr

I keep getting freezes with this B307 working in High-DPI mode with 149% scaling. This scaling allows to use the FX interface, however the text is not as clear on my new 32" UHD monitor as with 175% scaling.

The freezes occur on my system even when only moving the FX interface window on the screen with just one UHDp30 event in the time line and can not be stopped with Ctrl-Alt-Del to activate the taskmanager. It does just not allow to start the task manager. On my last try I could not even restart the system with the reset button. I had to switch the power off and finally gave up with this version, that is linked in the top of this thread.

System : i7-8700k with 32GB RAM, AMD R7 running Win10pro 1709

So it seems the freeze issue at startup is not solved yet then. I haven't installed this update yet though. Will do on monday when I'm back in the office. I'll give it a try.

For me the strange thing is that this problem doesn't appear all the time. It happens in a series of perhaps 5-6 times. Then, after giving up on VP16 and waiting a week or so, when I try again it works and I have even been able to finish a small project for a client on it with no glitches. Then suddenly the freeze at startup occurs again over and over until I give up. Last time I gave up was actually yesterday, before the update #2 came this morning.

Peter_P schrieb am 27.10.2018 um 18:09 Uhr

So it seems the freeze issue at startup is not solved yet then.

To me it seem to be related to the High DPI mode. Runnig some tests with the So4 Reader in Non High-DPI mode did not yet cause Vp16 B307 to freeze.

However, I really would like to use Vegas pro as all my other applications in a crystal clear display of text, icons and pictures.

matthias-krutz schrieb am 27.10.2018 um 18:46 Uhr

So it seems the freeze issue at startup is not solved yet then.

If Vegas frozen at startup, it was always because there were parts of a Vegas process left over in the RAM. After I had removed them in the Task Manager, Vegas started without any problems.

It was not often, but one time with B307- in Non High-DPI mode.

Marty74 schrieb am 27.10.2018 um 20:09 Uhr

"You can now create subtitles by importing SRT files with the Insert Subtitles from files feature"

I love you Magix !!! THANK YOU ! 👍👍👍

j.cloninger schrieb am 27.10.2018 um 20:14 Uhr

So far so good. The File > Render As = HANG bug appears to be fixed! I've opened, worked on and exported five projects since updating without a hiccup... SWEET!

Marty74 schrieb am 27.10.2018 um 23:30 Uhr

Just noticed that there is no way to export the Video subtitle track imported in SRT format to .. SRT format (or in an another format that we could convert to SRT again (like with subtitleEdit).

it's great to be able to import it, but to be really of good use, both import and export must be allowed !

maybe i missed a way to do it ? if not i hope it will be available in a new update ;). but it's already nice !.

NCARalph schrieb am 28.10.2018 um 00:07 Uhr

There still seems to be a problem with Render As when selecting AAC or AC-3 audio. It won't let you select just the loop region. This does work for the video renderers and the MP3 Audio.

AVsupport schrieb am 28.10.2018 um 02:32 Uhr

I wished they'd change the icon for VP16..looking the same as 15 is quite inconvenient

AVsupport schrieb am 28.10.2018 um 02:58 Uhr

XAVC-S 4K on a 1080 timeline playback so4 enabled: example: standard interview with edits in between:

Once the timeline reaches 'speed' in uninterrupted playback, framerate stays consistent at 25fps. Where there's edits / new clip starts, framerate drops until the buffer fills up again. This is like there's no 'read ahead' to the next clip..This seems totally unnecessary and just bad code. anyone know of any meaningful tweaks to make this go away? [this is not new but still annoying]

Observation: GTX1060/6 utilization ~25% where full framerate is acheived [this is perhaps a little better than it was?] . However, GPU load drops significantly where there is edits/dropped frames indicating there's no data supplied..

Peter_P schrieb am 28.10.2018 um 07:58 Uhr

I wished they'd change the icon for VP16..looking the same as 15 is quite inconvenient

+1

 

Nick Hope schrieb am 28.10.2018 um 08:29 Uhr

There still seems to be a problem with Render As when selecting AAC or AC-3 audio. It won't let you select just the loop region. This does work for the video renderers and the MP3 Audio.

Confirmed. The render options are wrongly disabled for "AAC Audio" and "Dolby Digital AC-3 Studio" formats. Support request: [Ticket#2018102717002258]

Nick Hope schrieb am 28.10.2018 um 08:35 Uhr

XAVC-S 4K on a 1080 timeline playback so4 enabled: example: standard interview with edits in between:

Once the timeline reaches 'speed' in uninterrupted playback, framerate stays consistent at 25fps. Where there's edits / new clip starts, framerate drops until the buffer fills up again. This is like there's no 'read ahead' to the next clip..This seems totally unnecessary and just bad code. anyone know of any meaningful tweaks to make this go away? [this is not new but still annoying]

Observation: GTX1060/6 utilization ~25% where full framerate is acheived [this is perhaps a little better than it was?] . However, GPU load drops significantly where there is edits/dropped frames indicating there's no data supplied..

@AVsupport Regarding the sentence I've bolded, how does that compare to if you disable so4compoundplug so that compoundplug is used? (Note - Parallel discussion starts here)

Nick Hope schrieb am 28.10.2018 um 08:40 Uhr

Incorrect combination of frames of accelerated clips remained after switching on the "Deinterlace" method in HD 1080-50i projects (1920 x 1080, 25,000 fps).

@Marcin Please make a new post with further details about that issue, or use one of your existing posts if there is a relevant one.

croudy schrieb am 28.10.2018 um 11:35 Uhr

Crash has been resolved when using video stabilization and motion tracking with an AMD Phenom II card

Still there...

Nick Hope schrieb am 28.10.2018 um 11:59 Uhr

Crash has been resolved when using video stabilization and motion tracking with an AMD Phenom II card

Still there...

@croudy Please also report that on the thread about the issue.

bitman schrieb am 28.10.2018 um 16:13 Uhr

There is a GUI bug with High DPI scaling setting (build 307, but it could be also on the previous builds, I just noticed it now by experimenting) : I always used 125% upscale in windows on my ultra wide and all is fine, I increased it now to 150%, but my own 2 icons I made to call a script visually disappeared from the top toolbar. They are still operational if you click the gui location of those "invisible icons". I can get my icons back by setting the upscale in windows back to 125% or by disabling the high DPU setting.

Summary:

Icons appear OK: dpi scaling to 125% and high DPI setting on

Icons appear OK: dpi scaling to 150% and high DPI setting off

Icons invisible (NOK): dpi scaling to 150% and high DPI setting on

 

Zuletzt geändert von bitman am 28.10.2018, 16:17, insgesamt 2-mal geändert.

Current system: VP16 (suite) build 307, VP15 (suite) build 384, Magix video pro X, Corel VS ultimate 2018, a lot of NEWBLUE plugins, Titler Pro 6, Mercalli 4.0, respeedr, Vasco Da Gamma 11, VASST stuff, Production Assistent pro3,...

  • OS: Windows 10 Pro 64, version 1803
  • CPU: der8auer i7-8700K (advanced edition), default speed (no overclock), Cooler: Noctua NH-D15s
  • RAM: G.Skill Trident Z 3200C14 DDR4 64GB, XMP set to profile 1 in BIOS
  • Videocard: NVIDEA RTX 2080Ti (Founders edition)
  • Monitor: LG 38 inch ultra-wide (21x9) - yes upgraded from 34 to 38, I can see more tracks now! Resolution: 3840x1600
  • C-drive: Samsung NVMe SSD 2TB 960 pro
  • Data storage: WD gold 6TB + WD Yellow 4TB
  • MOBO: Gigabyte Z370 Aorus Gaming 7
  • PS: Corsair HX1200i, Case: Silverstone fortress 2, shuttlePROv2, Keyboard and mouse: Logitech G910 and G700s (and now Evoluent Vertical Mouse)

Before November 2018: NVIDEA Gibabyte GTX 1080ti

Before November 2017: windows 10 Pro 64, i7-4790k, mem: DDR3 16GB GTX TITAN X (Maxwell)

 

Peter_P schrieb am 28.10.2018 um 16:18 Uhr

There is a GUI bug with High DPI scaling setting (build 307, but it could be also on the previous builds, I just noticed it now by experimenting)

Yes this is an 'old' bug. You will also notice, that the FX windows/interface can still not be used wirh 150% nor 175% scaling in High DPI mode.