Bad Audio Render - I have missing words all over!!

kirk-dickinson wrote on 8/20/2020, 10:49 AM

I have the newest version of Vegas 18 Pro. I have rendered this job 6 times and every time there are missing words that seem to just be chopped off at random. I have a series of photos and videos with audio narration for each one. The audio was recorded continuous in one file, but on the timeline, I have split the track and adjusted to fit the visuals.

So I finally figured out what is going on. I rendered just the audio and put it back on the timeline so I could compare waveforms.

Vegas is doing something really stupid that I haven't seen ever. I have been using Vegas since Sonic Foundry version 3.0 and this is the craziest thing I have ever seen.

Vegas is rendering each audio segment slightly stretched by 4-5% then at the end of the segment parts of the audio get chopped off.

Comments

DougT wrote on 8/20/2020, 11:59 AM

Are your audio tracks formatted as MP3s? These can sometimes, not always, be problematic. Best to use WAV if possible. But if not, maybe re-render your MP3s as a WAV using some other software (audacity or windows) and replace. Not the best solution, but not all MP3s are created equal.

 

kirk-dickinson wrote on 8/20/2020, 12:28 PM

Are your audio tracks formatted as MP3s? These can sometimes, not always, be problematic. Best to use WAV if possible. But if not, maybe re-render your MP3s as a WAV using some other software (audacity or windows) and replace. Not the best solution, but not all MP3s are created equal.

 


The audio tracks were recorded though the Vegas interface. I checked and they are WAV. I have been doing several of these small jobs exactly the same way as this in 17 and just switched to 18. This really looks like a bug to me.

kirk-dickinson wrote on 8/20/2020, 12:31 PM

Even "Render to new track" hoses up the ends of the audio clips. This is a bug.

john_dennis wrote on 8/20/2020, 12:34 PM

@kirk-dickinson

Please show:

Project Properties

Media Properties

kirk-dickinson wrote on 8/20/2020, 12:41 PM

@kirk-dickinson

Please show:

Project Properties

Media Properties

Yours on left, mine on the right.

john_dennis wrote on 8/20/2020, 12:45 PM

@kirk-dickinson

Could you create a small sample project for others to test?

DougT wrote on 8/20/2020, 1:19 PM

Usually WAVs, especially if it is recorded by Vegas, do not present a problem. Any chance you could upload an original file to dropbox or other so we can download it?

kirk-dickinson wrote on 8/20/2020, 1:24 PM

@kirk-dickinson

Could you create a small sample project for others to test?


Not sure what you want. I created a short video with 20 5 second text boxes counting to 20, recorded a track counting in sequence and exported that it, and that works perfectly. What is not working is my real project.

kirk-dickinson wrote on 8/20/2020, 2:01 PM

OK, all my fault.

I lowered the pitch by -1 semitone on the narration but didn't check the "Preserve length" button. Sorry!

DougT wrote on 8/20/2020, 2:06 PM

Okay. Glad you figured it out. Thanks for posting the problem.