cant change gpu acceleration device

awfulTHEmovie wrote on 3/21/2019, 9:21 AM

hello, since several versions (i think it starts at V12 - but not sure) i cant change the gpu back, if i changed it once in the video preferences:

GPU acceleration of video processing:

i have 2 gpu in use. one of it isnt connected with a monitor (2) because i just use it for rendering in other applications (3d-software).

after installing vegas, automatically gpu1 is chosen, thats fine. i see video previews and everything works.

if i change to gpu2, no preview from the timeline is working. if i want to change the gpu back to 1, vegas denies this step and always switch back to gpu 2. this is crazy, because i cant preview and render anymore.

i use an actual win10pro with the actual vegas 16.0 build 361 (but this problem exists since version 12)

 

i tried several things:

- start vegas as admin

- use nvidia control to give vegas just 1 gpu

- set to none, then back to gpu1

- restart several times and change to gpu1

- install different build of vegas (update)

 

nothing of the steps works - i always end up with a selected gpu 2 and no preview.

i have to reinstal vegas completely to get the original setting back.

is there any way to avoid the reinstallation? i just have to get back my gpu1 again for previewing.

please help.

thanks

Comments

D7K wrote on 3/21/2019, 11:18 AM

Here's a link to Nick's post on one possible solution:

OR you can just remove #2, start Vegas select your GPU. Shutdown, reinsert card and go, it might work..

j-v wrote on 3/21/2019, 11:19 AM

And if you give this a try?

1. Close Vegas and go to your Device Manager in Windows and disable there both NVidia GPU's followed by a Windows restart.
2. Check in the Vegas/Options/Preferences/Video if one of those shows up.
If GPU 2 shows up, there must be something wrong with your installations.
If none shows up, close Vegas and give your GPU 1 again permission in the Windows Device Manager.

met vriendelijke groet
Jan

Camera : Pan X900, GoPro Hero7 Hero Black, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home, version 1903 build 18.362,295 CPU i7 7700HQ, 16 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 16,17 and VMS PL 16 are installed
Both Nvidia GPU's have driver version 431.86 Studio Driver, desktop the Studio DHC driver
TV      :LG 4K 55EG960V

Dutch video tutorials for beginners

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

awfulTHEmovie wrote on 3/22/2019, 4:15 AM

hui. thanks for the fast answers.

@D7K

maybe gpu reinserting will work, but i just want to find a fast&easy fix via settings. there must be an way without reinstalling and hardware-fingering.

i´ll try the reset-vegas-procedure before opening the case.

@j-v

sounds good. i´ll try this before resetting vegas ... i think it will damage the less :)

awfulTHEmovie wrote on 3/22/2019, 4:49 AM

ok.. i´m such a jerk :)

i just connect the monitors to the second gpu. because its no matter . they are the same ... problem solved.. ffff

awfulTHEmovie wrote on 3/22/2019, 4:52 AM

... but anyway ...

if i havent two identical gpus, its a problem.

why isnt it possible to choose the graphiccards in the settings?

is this just at my installation or other users experienced the same behaviour?

eikira wrote on 3/22/2019, 5:06 AM

... but anyway ...

if i havent two identical gpus, its a problem.

why isnt it possible to choose the graphiccards in the settings?

is this just at my installation or other users experienced the same behaviour?


As far as i know, in VP15 you had NOT the options for the Encoding/Renderer to chose which GPU should be utilized, that was the time i had 2 NOT identical GPUs but from NVidia. The Problem with Blackscreen remained the same for me. If i had chosen my GTX1070 as PREVIEW device in the Videooptions i needed of course to connect the Displays on that device. If i had chosen my GTX1080 for PREVIEW in the Videooptions of course i would have needed to connect my Displays on that device. Which makes sense, because you demanding a preview with gpu performance and the GPUs are not connected to each other to give you a passthrough from one to the other. Even with both GPUs being the same, you would need to set up an SLI pair and only one will act as the Master and would be able to output video signals, the other is just his working slave but in an SLI or CrossFire Setup you at least could combine the power of them.

The main issue here is, you wanted more or less one GPU being on idle and not drawing resources till its needed for encoding, right? Or even so that you still can work with one fully while the second encodes stuff without you being hindred doing other works and using the screens without any stuttering etc?

awfulTHEmovie wrote on 3/22/2019, 6:06 AM

hy @eikira,

my problem was, that i chose the first gpu from the dropdown list in vegas but it wasnt used for the preview. it always switched back to the second gpu.

i cant use the first in the list (but this was the connected one).

so i´m curious why there is a selection when its not working.

 

if i could adress all both gpus for encoding/decoding/whatever in vegas would be fine :)

but i´m not connecting them via sli. my performance in the 3d software dont work with sli.

eikira wrote on 3/22/2019, 6:12 AM

hy @eikira,

my problem was, that i chose one gpu from the dropdown list in vegas but it wasnt used for the preview. it alwys switched back to the second gpu. i cant use the first in the list (but this was the connected one).

 

so i´m curious why there is a selection when its not working.

Hmmm, ok. Have you tried to reset Vegas? Or at least reset the Preview Display back and forth to a different one (i am assuming you have more than 1 display), maybe there was also a stuck setting and could be triggered again with changing it from Preview Display 1 to 2 and back?

awfulTHEmovie wrote on 3/25/2019, 9:37 AM

hy,
i didnt try reset, because i just switch the monitorcable to the vegas-chosen gpu. its the solution with the less effort.