Comments

FTech wrote on 6/1/2016, 3:28 PM
Hi Velcro,

In CD Architect go to the menu and select OPTIONS>Preferences.

Make sure you place a check mark beside "Use CD/DVD drives in PnP mode". Close CD Architect and relaunch it.

Hopefully this will help you getting your DVD Burner recognized in Windows 10.

Keep in mind I don't have Window 10, I have Windows 7. I noticed from toggling that "Use CD/DVD drives in PnP mode" option off, the software fails to find my DVD Burner. If you don't see that option, make sure you have CD Architect version 5.2d.


FTech

CPU: Intel® Core™ i7-930 @ 2.8Ghz (non-overclocked) OS: Windows 7 64-bit RAM: 12 GB DDR3 Graphics Card: MSI GeForce GTX 970 Gaming 4G (driver v384.94) Sound Card: Sound Blaster Z (driver Jun 24, 2016) Storage: 2 x Seagate Baracuda 1TB (System Managed Swap File) Mobo: Rampage III Extreme (bios 1502) PSU: Corsair HX 850 watts DVD Burner: Asus DRW-24B1ST (firmware 1.03) Case: Coolmaster HAF922

Lore wrote on 11/28/2016, 6:46 AM

Hi everbody,

I experienced the same problem with a similar CD/DVD/Bluray Drive after upgrading from Windows 7 to Windows 10.

In my case it helped to change some settings in BIOS, i.e. switching the mode of CD-ROM device from AHCI to IDE (under the SATA settings). This should provide more backward-compatability...

Good luck !

Lore