Lou van Wijhe wrote on 1/22/2011, 6:31 AM
Have you tried re-rendering these 4 files in Vegas? One of them may be corrupt. Just my 2 Euros...


What DVDA version are you using?
Steve Grisetti wrote on 1/22/2011, 7:24 AM
I agree with Lou.

There are a number of advantages to running your video through Vegas first and outputting it as a DVD or BluRay-ready file to DVD Architect.

Using video directly from a camcorder into DVD Architect sometimes works -- but sometimes doesn't.
A-ROB wrote on 1/23/2011, 8:16 PM
I guess I wasn't clear about the AVC files, they were all rendered in Vegas 9 using the Sony AVC codec. They all import fine individually into any DVDA 5.0b project. Looking at the Optimise screen, DVDA shows all will be "passed" or NOT rerendered, so it is clear that DVDA recognizes them as good Blu-ray ready files. It's only when I add them all together that there is a problem. About 13-15GB of the way into import, DVDA hangs. I will try to re-render one of the files to see if that makes a diff, but I doubt it.
A-ROB wrote on 1/25/2011, 12:02 PM
I re-rendered one of the AVC files and had the same result.

I am now trying to render them all to Mpeg-2 files, but when I use the VBR DVDA template for Blu-ray, DVDA wants to recompress it. The only way I've found to get DVDA to NOT recompress is to use Mpeg-2 CBR.

Has anyone else been able to use Mpeg-2 files for a Blu-Ray with the VBR option?
A-ROB wrote on 2/12/2011, 2:04 PM
After 7 days, Sony finally answered my support question for this topic and directed me to the following 2GB cap fix for .dll files in DVDA:

Most of the way down the thread, a user tells which dll files to change in DVDA.

To my surprise, it worked. All my original DVDA assets are now importing fine. But now I have run into yet another bug, DVDA won't burn the BD! I get this nastly error message:

File name: STREAM/00002.m2ts
Status: TSWrapper.dll::CTSWrapper::ProcThreadMain::Video buffer underflows

Support has another article that directly addresses this bug:
Answer Link:

I have tried all suggestions in the article and nothing has worked. So I am dead in the water once again and Sony support has not answered in over 3 days.

I have been researching other authoring programs that are somewhat affordable--DVDit Pro HD and DVD Movie Factory to name a few. Encore is too expensive. Does anyone have any suggestions? A program with the feature set of DVDA but actually works for Blu-ray?
Steve Mann wrote on 2/12/2011, 7:53 PM
This may not help, but 20-years ago when we were burning CD's on '486 PC's (more coasters than CD's), 80% of our burns aborted with Buffer Underruns.

[I was the technical manager at a legal document firm]

A few years later when we had Pentium processors, the CD underrun problem had largely disappeared. Larger buffers on the CD burners helped as well though they cost several hundred dollars apiece.

When we started offering the data on DVD disks, the buffer underruns reappeared. Again, faster processors and larger buffers in the burners fixed that problem.

So, why am I not surprised to see buffer underruns on BD-R disks?

TOG62 wrote on 2/13/2011, 1:13 AM
Are you able to create the .ISO file. In that case you could maybe burn with ImgBurn or Nero.
Lou van Wijhe wrote on 2/13/2011, 3:13 AM
Video buffer underflow was something that occured at some point in the Vegas Pro 9 series and was later debugged. I also had it and now it's gone. Upgrading might solve your problem.

A-ROB wrote on 2/14/2011, 9:18 AM
Thanks for your thoughts guys.

I am creating Mpeg-2 Blu-rays just fine on my PC i7, 12GB ram, Vista 64bit. So the PC shouldn't be the problem. In addition, over the weekend I set DVDA to recompress all the AVC files and it created the .iso just fine--it took 23hrs! So the problem is that DVDA will not "pass" a fully compliant Blu-ray Sony AVC file. Again, in the "Optimize" screen, it shows all check marks on all the AVC files--no recompress necessary. But when I try to create the .iso, it works for 15 minutes and flashes the error message.

About the buffer underflow, Lou, we are talking DVDA so why would my use of Vegas Pro 9 have anything to do with it? I am useing VP9e. Do you think the AVC files made by VP9 are causing DVDA to hiccup? I would use a different AVC codec, but there doesn't seem to be one. The Main Concept AVC codec yields a MP4 file and takes twice as long to encode. The only thing I can think of doing now is buying Neoscene and making Cineform AVIs to send over to DVDA. Do you think DVDA will crash on rendering those?
Lou van Wijhe wrote on 2/16/2011, 5:18 AM
My buffer underflow problem disappeared at some point in the Vegas Pro 9 series. As you are already on 9.0e, it is puzzling why it happens to you and not to me. And I don't know where the problem lies; Vegas? DVDA?

I know how frustrating such a hard to tackle anomaly is. I hope you can get it sorted out.

A-ROB wrote on 2/22/2011, 8:58 AM
Just wanted to update everyone on my progress, or lack of progress on this. It's been about 9 days since Sony last responded to my trouble ticket.

I decided to try rerendering my videos to the Sony AVCHD codec in VP9 this time even though Sony's own Blu-ray template uses AVC and not AVCHD. I tested DVDA by importing the AVCHD and making the .iso on a blank project. It worked. No errors at all! I was excited; I had finally found a way to "pass" my AVC assets in DVDA! Not so fast...

For my test, I had used a 60i video. When I went to rerender my 24P videos, the Sony AVCHD codec would not allow me to change the settings to 24P. The only choices were 60i and 50i. So, once again, I am dead in the water.

The way I see it, I have a few other options. I could upgrade to VP10 since the release notes on VP 10.b say "Added 24p Blu-ray Disc rendering templates". That sounds promising, but with my luck won't be what I need.

Or, I could render all to .avi and let DVDA take 24hrs to render it all. As a note, I tried to test Neoscene .avi in DVDA and did not have any success. DVDA rendered a AVC disc that was dark and had serious interlacing artifacts.

If anyone has any other ideas, I am all ears...
hambonio wrote on 9/26/2016, 6:24 PM

More than 5 years later and this problem STILL exists for me even with the new DVD 7.0 (Magix)!  You describe my problems to a T!  Every time I get near the 13GBish mark on a disc, I cannot add any more AVC files or the system hangs.  This has been ongoing for a few years now on DVDA 5.2, 6.0, and now 7.0.  This happens on 3 different PCs.  Extremely frustrating, and was hoping they would fix this bug in the newest release.  The only workaround I have had before was combining some of my sections to one AVC file (and this is NOT how I want my discs to really work) and with fewer AVC files I can usually get it to work.  The only thing I can think of was early days of Win 7 I never had a problem.  Now on computers with updated Win 7 through Win 10 all have this problem.  

_litz wrote on 8/30/2017, 2:11 PM

Same problem is still occurring on the latest version. It's unusable.

Does NOT make me happy knowing I just spent $350 on a product that doesn't work.

R0cky wrote on 2/19/2019, 5:30 PM

A-Rob if you're still out there, the old forum article archive is no longer on line. Do you remember which dll's to edit for larger memory space? I've done this before with CFF explorer. Does anyone know?