Opening An Image Sequence of JPEG Files Fails In Vegas 18 Build 334

ItsMeRobert wrote on 9/21/2020, 2:36 PM

Hello,

I process film that has been converted to still image frames as JPEG files. I have just updated my Vegas 18 to build 334. Now I can no longer open an image sequence. I follow these steps;

1. Bring up the open dialog
2. Select a directory with the sequence of JPEGs.
3. Select the first JPEG in the folder.
4. Select the "Open sequence" check box.
5. Click "Open" button.
6. The "Properties" dialog opens.
7. I select a frame rate of "23.976"
8. Click "OK"
9. Nothing happens. The images are not added to the time line. After a short time, this message is displayed: "Warning: An error occurred accessing project media.  Some streams in the media file could not be opened."

I have tried to open a sequence that I previously used in my previous build of Vegas 18 and it fails too.

I can open an existing Vegas 18 project that has an image sequence. That open without a problem and the sequence displays on the timeline.

Also, after I dismiss the error message, it keeps randomly displaying the error message every few minutes. So I am not sure what keeps generating the error message.

Is there something I can do to fix this problem or do I need to revert back to the previous build?

Thanks.

Comments

Musicvid wrote on 9/21/2020, 2:40 PM

How are the files in your sequence named?

ItsMeRobert wrote on 9/21/2020, 4:59 PM

One is 3000 files (about 3 minutes long). Another is 27000, about 20 minutes long. I have done much longer sequences. I have used sequences like this probably 1000s of times. The length should not be a problem, unless a new bug has been introduced... well some kind of bug has been introduced in this build as it worked fine yesterday with the previous build doing the same thing. I am not 100% sure the problem is directly related to sequences. The stream error message keeps popping up every couple minutes.

DougT wrote on 9/21/2020, 6:06 PM

Check the folder of the JPEGs and make sure there are no other types of files. also can you give an example of the one of the file names in the files that fail.

ItsMeRobert wrote on 9/21/2020, 9:04 PM

I can open the project I made with the previous version of Vegas that has the sequence. I actually have several saved projects of different sequences of images and they all open. If I try to make a new project and open one of the sequences again, it fails to open.

The directory only contains jpg images.

The names are like this: Big_Business.2048x1536_00001.jpg, Big_Business.2048x1536_00002.jpg, Big_Business.2048x1536_00003.jpg etc.

The error about the "some streams in the media file could not be opened." keeps appearing. I am thinking that something else is wrong that is causing this error and in turn, is preventing me from creating a new sequence. I think the question is, what would cause this error to keep displaying over and over?

fr0sty wrote on 9/21/2020, 9:18 PM

Does it do this with other image formats, or just jpg?

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Radeon VII

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

Musicvid wrote on 9/21/2020, 9:59 PM

See if it does the same thing with a .png sequence.

DougT wrote on 9/21/2020, 10:29 PM

Can you import a single frame as a JPEG? and can you upload a sample frame (not here but dropbox or something) that we can test. Your naming convention works so it could be a file format error.

ItsMeRobert wrote on 9/22/2020, 5:54 AM

I uploaded one image, which happens to be black.

This is clearly a new bug in build 334. The previous version of Vegas 18 that I was running did not have this problem.

- If I do not select "Open sequence", I can open a single JPG without any error displaying.

- I have tested a bunch of sequences that I previously worked on and they have the same error when I try to open them.

- If I open a project that has already has the sequence loaded, it works.

- I still have Vegas 17 installed and it can open up these same sequences without any errors.

I also notice that normally, when you have a blank project and you open a sequence, after you click OK on the property dialog, you are prompted with this message: "Do you want so set your project video settings to match this media?". In Vegas 18 build 334, this dialog never appears. It just hangs.

I found out something else that is important. When I do not change the frame rate in the properties dialog, leaving it at "29.970 (NTSC)" and click OK, the sequence will open normally without any errors. If I change the frame rate to "23.976 (IVTC Film)", then this error occurs.

The frame rate selection seems to be the key. If I leave the frame rate to the default 29.970, it works. If I change it to 23.976, then the stream error keeps displaying.

I have also found that if I leave the frame rate as 29.970, the video plays properly in the preview window. If after I open the sequence as 29.970, I then change the properties on the timeline and change the frame rate to 23.976, then the preview window goes black and it will not preview what is selected on the timeline. It doesn't matter if the I am in playback mode or not. The preview window is black. After a few minutes the error starts displaying again too when I click on the application.

This is clear a problem in the product and not with the source JPG images.

Can anyone else reproduce this? How do we get Magix to fix it?

Thanks.

JJKizak wrote on 9/22/2020, 6:48 AM

I think one of the changes was to default to png.

JJK

ItsMeRobert wrote on 9/22/2020, 6:59 AM

Hi JJK,

Why would that matter? I can open the JPGs fine when I leave the frame rate as 29.970. If I change the frame rate to 23.976, then the stream error occurs and I cannot use the project.

Are you saying that when they changed the default to PNG, they broke something else?

Unfortunately the application that outputs my frames only outputs JPG. I cannot instead use PNG files. With that said, Vegas should still work fine with JPG with a 23.976 frame rate.

Robert

VEGASPascal wrote on 9/22/2020, 7:37 AM

We try to reproduce this and write a bug report.

DougT wrote on 9/22/2020, 8:01 AM

Okay, I didn't pick up in the original post that it works at 29.97, but not 23.976. I thought it just wouldn't import. That is a whole different issue. And we can assume that your project is already set at 23.976 before importing sequence?

ItsMeRobert wrote on 9/22/2020, 8:46 AM

Thanks Doug. No problem. But you just brought up an idea I didn't try before. Normally I start with a new project, open the file, pick the frame rate and then say "yes" when Vegas asks to adjust the project to match the media. Vegas will change the video size and frame rate to match my imported media. As a test, I first changed my empty project to 23.976 frame rate and then opened the sequence. The sequence opened normally without any problem and plays correctly.

So I tested the inverse. I tried to change the properties of the sequence to 29.97 in a 23.976 project and the same issue occurs. The media goes off line and will not play. Previously Vegas let you mix media like this and would automatically adjust the frame rate to match the project settings. That appears to be what has been broken. The frame rate must match the project or the media will not work.

While I usually do not need to mix media with different frame rates in a project, there have been times where I have had to have mixed files, and convert them to a single frame rate in one file. That means for now I can work around the issue, but it will need to be fixed.

Hopefully Magix can reproduce the issue and fix it. Thanks for your help.

 

 

DougT wrote on 9/22/2020, 8:51 AM

You can still have mixed media, but I guess it assumes that if you are importing a still sequence, you would only import it at the project settings. Glad we found the issue and maybe it can be addressed.

ItsMeRobert wrote on 9/22/2020, 11:58 AM

FYI: I have also found that the work around of first setting the project frame rate still has a problem.

If you set the project frame rate to 23.976, then open up the sequence, everything seems OK and you can work on the project. If you switch away to another application and then switch back, the "stream" error appears again and the media goes off line. You cannot see anything in the preview window. The only way to fix this is to close the project and reopen the project, then it works again... until you switch to another application or do something to cause Vegas to lose focus then regain focus. Then again you have to close and re-open the project.

Musicvid wrote on 9/22/2020, 12:49 PM

Try turning off "Close Media Files When Not the Active Application" in Preferences.

VEGASDerek wrote on 9/22/2020, 1:05 PM

We have identified the problem and we will try to have a fix in place for the next update.

ItsMeRobert wrote on 9/22/2020, 1:23 PM

VegasDerek - Thanks for the update. That is good news.

Musicvid - Thanks, that does help.