Sony Pitch Shift Render Issue

drbam wrote on 9/16/2009, 9:19 PM
The following happens with Vegas 7 & 8 and Acid Pro 6.

Tried to render a 24/44.1 stereo file (approx 12 min in length) with Sony pitch shift inserted as a track efx – no other efx used. Pitch shift is set to raise a full octave (+12) - preserve duration is unchecked. The results are random dropouts beginning at about 4:20 into the rendered track with a total of about 35 dropouts total. It does not matter whether “accuracy" is set to 2 or 3 (best) or whether “apply anti-alias filter” is checked or not. Results are the same.

However, if I insert the pitch shift in the master bus instead of the track, the render seems fine.

I create a lot of ambient, tribal music consisting of extremely long tracks (20 min is not at all unusual) and I often want to apply some radical pitch shifting (full octave up or down) as an effect but have not done so in the past because it pushed my old computer too hard. Previously I would simply apply the pitch shift destructively on a file in Sound Forge, which always worked fine. Now that I have a quad system, the power limitation does not exist and so I’ve just now encountered this issue.

Can somebody explain what is happening here? Obviously it appears that I can’t trust that Sony’s pitch shift is going to yield reliable renders when inserted as a track efx so to be safe my work flow will continue to be what it was when I was using a P4 computer – at least when it comes to pitch shifting. Obviously not a happy thought . . .

I would appreciate any insight or comments about this.



pwppch wrote on 9/17/2009, 12:07 PM
Do you have track buffering enabled?

drbam wrote on 9/17/2009, 8:41 PM
Thanks Peter - The studio is shut down for the evening but I'll check tomorrow. I'm curious as to how track buffering might be related?

Thanks again!
drbam wrote on 9/18/2009, 9:32 AM
Yes, in Vegas 7 track buffering is enabled .25. Is this not the default?
jbolley wrote on 9/18/2009, 10:23 AM
might not be what you're looking for but have you tried pitch shifting the clip instead of the track? Select the clip and press + or -.

drbam wrote on 9/18/2009, 12:57 PM
Thanks Jesse. Yes pitch shifting on the event renders properly (Peter suggested this on my post on the Acid forum).