Vegas 19 update not installing properly

johnnyrr wrote on 10/18/2021, 11:10 AM

I was prompted by Vegas Pro 19 to update my software this morning. But, after downloading the update package, then trying to install it, I get an error stating that I need to "uninstall the previous version of Vegas Pro 19" before I can install the updated version.

I have updated Vegas Pro 19 many times before and I've never had this issue. It's always updated flawlessly without having to uninstall previous versions. Also, even if I uninstall Vegas Pro 19, I'm not sure how I'd install the latest version because I only use Vegas Pro prompts to update it... and it's not obvious where the downloaded update package is to re-install it anyway??

Can anyone offer any suggestions on how to fix this issue. I currently have VP 19, build 381. Thanks.

Comments

jetdv wrote on 10/18/2021, 11:23 AM

Download from here and then run the installer?

https://www.vegascreativesoftware.info/us/forum/vegas-pro-19-update-1-build-381-vegas-effects-3-update-1--131678/

Make sure VEGAS is not running first.

johnnyrr wrote on 10/18/2021, 11:33 AM

Download from here and then run the installer?

https://www.vegascreativesoftware.info/us/forum/vegas-pro-19-update-1-build-381-vegas-effects-3-update-1--131678/

Make sure VEGAS is not running first.

Thanks for the reply jetdv... it looks like I already have the latest version (build 381), so I'm not sure why Vegas prompted me to update my software today? Maybe this is why the update was failing (trying to replace it with the same version)??

psg8064 wrote on 10/18/2021, 12:38 PM

I am having the same problem (Vegas crashes on update to 381), so I tried to use the above link to get the update. The link doesn't seem to work, as it remains on the page. Is there another link I can use to update my copy of Vegas Pro?

gary-rebholz wrote on 10/18/2021, 12:46 PM

Some faulty update notices where sent out due to a change the team that controls update notifications made. Hopefully they have fixed that problem by the time you read this. Bld 381 is the latest. If you have that, there is no need to update.

johnnyrr wrote on 10/18/2021, 3:09 PM

Some faulty update notices where sent out due to a change the team that controls update notifications made. Hopefully they have fixed that problem by the time you read this. Bld 381 is the latest. If you have that, there is no need to update.

Thanks for taking the time to clarify the problem, Gary.

I tried updating 3 times this morning... which took about 30 minutes each time (two separate large, slow file downloads with each attempt to update). So, two "quick tries" with the same failure mode, then once again after a reboot of my computer. That's when I threw my hands up the in air and posted here.

Hopefully, the update isn't pervasive among the VP19 community. I have the subscription model too, so maybe it only went out to people with a subscription?

vkmast wrote on 10/18/2021, 4:04 PM

@psg8064 a browser (Chrome) may not download without the workaround of copying the link text and pasting it to the browser. Try that or use another browser.

johnnyrr wrote on 10/18/2021, 6:03 PM

@psg8064 a browser (Chrome) may not download without the workaround of copying the link text and pasting it to the browser. Try that or use another browser.


@vkmast, it's a false update notification... there is no update available, per Gary Rebholz. See above.

vkmast wrote on 10/19/2021, 3:27 AM

@johnnyrr I wasn't referring to the update notification. @psg8064 said he was not able to download using the link mentioned in the 1st comment.

Jeremiah wrote on 10/31/2021, 10:43 PM

I am running Build 381, but still get an update prompt for the Vegas Deep Learning Models. The installation of which has failed multiple times ("uninstall the previous version of Vegas Pro 19" error).

I would think the erroneous update notification Gary mentioned would have been fixed by now, but perhaps I am confusing two issues.

RogerS wrote on 10/31/2021, 10:50 PM

I am running Build 381, but still get an update prompt for the Vegas Deep Learning Models. The installation of which has failed multiple times ("uninstall the previous version of Vegas Pro 19" error).

I would think the erroneous update notification Gary mentioned would have been fixed by now, but perhaps I am confusing two issues.

Likely the same issue and I'd just ignore until an actual update is posted in the news section on this forum.

Dr Zen wrote on 10/31/2021, 11:11 PM

This topic has been mentioned in 3 separate threads now. The only way to get rid of the false update window, is to do a deep removal of VP19 and then re-install. I posted all the steps that worked on my computer here:
https://www.vegascreativesoftware.info/us/forum/vegas-pro-19-update-1-build-381-general-discussion--131991/?page=5#ca826226

michael-harrison wrote on 11/1/2021, 10:52 AM

@gary-rebholz any sign of the update system getting fixed? It's been 2 weeks and still happening. I really don't want to uninstall and reinstall

System 1:

Processor        Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz, 3192 Mhz, 6 Core(s), 12 Logical Processor(s)

BaseBoard Product        ROG STRIX Z390-E GAMING

Installed Physical Memory (RAM)        48.0 GB

Adapter Description        NVIDIA GeForce GTX 1660

Driver Version        Studio <the latest stable>

Resolution        1920 x 1080 x 60 hertz

Video Memory 6G GDDR5

 

System 2:

Lenovo Yoga 720

Core i7-7700 2.8Ghz quad core, 8 logical

16G ram

Intel HD 630 gpu

Nvidia GTX 1050 gpu

m2016 wrote on 11/1/2021, 12:20 PM

There is no need to reinstall; it would not help. We now deployed an interim update in the autoupdate server to handle this issue with the "Vegas Deep Learning Models" until fixed in the client software. So the update messages that want you to download the Vegas Update you already installed should stop now.

michael-harrison wrote on 11/2/2021, 8:57 AM

@m2016 can confirm. Started vp19 just now and didn't get an update msg. many thanks

System 1:

Processor        Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz, 3192 Mhz, 6 Core(s), 12 Logical Processor(s)

BaseBoard Product        ROG STRIX Z390-E GAMING

Installed Physical Memory (RAM)        48.0 GB

Adapter Description        NVIDIA GeForce GTX 1660

Driver Version        Studio <the latest stable>

Resolution        1920 x 1080 x 60 hertz

Video Memory 6G GDDR5

 

System 2:

Lenovo Yoga 720

Core i7-7700 2.8Ghz quad core, 8 logical

16G ram

Intel HD 630 gpu

Nvidia GTX 1050 gpu

John-Weber wrote on 11/25/2021, 5:09 PM

Have 19 build 381. getting an update notice so allowed that to happen (update to build 424). tried this probably 7 or 8 times using different/alternate methods. each time it looks like the update went ok. when the program starts, I do get the register pop up and that too seems ok, but the program then fails to start. Went back to build 381 and all is working again. But continue to get the update message on start....

vkmast wrote on 11/25/2021, 5:21 PM

The VEGAS team advises that "If you are having this problem with the latest build, please create a support ticket and please include your VEGAS Pro 19 serial number with it"..Advice here.

@John-Weber