[VP16_248 & 307 update] General Timeline Playback performance

AVsupport wrote on 8/26/2018, 7:57 PM

Early tests seem to indicate that VP16 makes more use of nNvidia GTX1060 card during playback, which is encoureaging. However, I still do notice frame rate drops where one clip stops and the next one starts. Which is weird because the system recovers effortlessly after the transition. This might have to do with internal buffering? (some source clips being XAVC-S/50p on a 25p timeline)

Comments

ahshing wrote on 8/27/2018, 12:50 AM

Seems VP16 still got the so4.dll issue

fr0sty wrote on 8/27/2018, 1:18 AM

Care to elaborate? They had it mostly fixed in the last 15 update, and as far as I can tell, it's rock solid in 16. The only way I have been able to make it crash is when going to render large projects with mixed media types. Sometimes the render dialog crashes before it appears. That is a bug that was present in 15 as well, hopefully they squash it soon.

ahshing wrote on 8/27/2018, 1:24 AM

Unfortunately I still having this issue in the latest VP15 update, and same on the VP16.

Very slow to startup project, and very low preview performance, while the project is containing lots of a7III/a99II XAVCS files, all the issues go well after disabling so4.dll in the preference, really need a fix for that.

AVsupport wrote on 8/27/2018, 1:28 AM

@ahshing, would you care to put some system info into your profile? do you run your IGPU (I don't and don't have any issues..so far)

ahshing wrote on 8/27/2018, 3:59 AM

@ahshing, would you care to put some system info into your profile? do you run your IGPU (I don't and don't have any issues..so far)

XPS15 9550 (2016)

CPU: Intel i7 6700HQ

GPU: nvidia Geforce GTX970M

RAM: 16GB DDR4

SSD: Intel 600P 500G SSD for system, Sandisk 1TB SSD for storage

I did try to use Gigabyte Gaming box GTX1070 thru the Thunderbolt 3, seems disabling any GPU acceleration still faster on my machine (weird).

AVsupport wrote on 8/27/2018, 6:17 AM

@ahshing try to disable your IGPU (Intel® HD Graphics 530) in the bios if you can. Then try again with your GTX1070 I'd say? Then again, if this is a laptop, you might not always be able to..

ahshing wrote on 8/27/2018, 8:38 AM

@ahshing try to disable your IGPU (Intel® HD Graphics 530) in the bios if you can. Then try again with your GTX1070 I'd say? Then again, if this is a laptop, you might not always be able to..


Yes, there is no option to disabling the Intel HD graphic inside the UEFI, the weird thing is using CPU(no GPU acceleration) is the fastest way to preview/render, in both VP15/VP16.

OldSmoke wrote on 8/27/2018, 10:59 AM

@ahshing try to disable your IGPU (Intel® HD Graphics 530) in the bios if you can. Then try again with your GTX1070 I'd say? Then again, if this is a laptop, you might not always be able to..


Yes, there is no option to disabling the Intel HD graphic inside the UEFI, the weird thing is using CPU(no GPU acceleration) is the fastest way to preview/render, in both VP15/VP16.

That really depends on your hardware and is certainly not true on my system.

AVsupport wrote on 8/27/2018, 5:39 PM

looks like you're editing on a laptop @ahshing which makes that difficult to compare. [since you cannot disable it..]. I have to agree with @OldSmoke. Using IGPU on my desktop was slowing down my system, using more resources and causing instability (previous VP15, not checked with this version yet)

bob-h wrote on 8/28/2018, 2:32 AM

@ahshing try to disable your IGPU (Intel® HD Graphics 530) in the bios if you can. Then try again with your GTX1070 I'd say? Then again, if this is a laptop, you might not always be able to..


Yes, there is no option to disabling the Intel HD graphic inside the UEFI, the weird thing is using CPU(no GPU acceleration) is the fastest way to preview/render, in both VP15/VP16.

Not that you should have to, but can't you just disconnect your gtx1070 when using vegas?

The HD530 graphics although a joke compared to gtx1070 delivers noticeable performance boost compared to cpu alone. It seems like your 2 graphics cards cancel out the graphic acceleration abilities of both when it comes to using vegas & further it creates the slowdown, which is likely vegas trying to use gpu, failing, then using cpu for each and every frame.

AVsupport wrote on 11/7/2018, 9:45 PM

[307 update]

Having about 150 clips (2 hrs+) worth of XAVC-S 4K clips on the timeline:

Upon opening of the project I do notice ~ 2.5-3 minutes worth of high CPU load, obviously doing some background task. This eventually drops down to 10%. With that settled, I playback timeline clips, without any effects. On the clips end/start transition (hard cut) , I get dropped frames (as before). Frame rate recovers as the clip is playing back. 'Video decode' on nVidia 1060/6 is 0%. GPU Load is 5%.

This situation is the same when So4 Reader is disabled, So4 HW decoding disabled, either, or, and both.

Looks like not enough 'Read Ahead', and missing Hardware GPU acceleration. As @bob-h was suggesting, it looks like my GTX is not being touched..just burning up CPU sadly ;-((..

bitman wrote on 11/8/2018, 12:54 PM

Here is the timeline performance of playing 117 clips (36 minutes total) on the timeline (all 4K clips from RX10iii, no edits used) using i7 (see my signature), Intel GPU is disabled in BIOS, and I always disable VEGAS automatic saving. My new 2080ti does not seem to get a lot of work either.

I do not see frame drops visually, but is there a way to measure frame drops?

@AVsupport you may want to upgrade your CPU in your Z370, the hyperthreading seems to make a difference (6 vs 12 cores) even though the 6 extra are only being virtual ones

Last changed by bitman on 11/8/2018, 1:09 PM, changed a total of 5 times.

Current system: VP16 (suite) build 307, VP15 (suite) build 384, Magix video pro X, Corel VS ultimate 2018, a lot of NEWBLUE plugins, Titler Pro 6, Mercalli 4.0, respeedr, Vasco Da Gamma 11, VASST stuff, Production Assistent pro3,...

  • OS: Windows 10 Pro 64, version 1803
  • CPU: der8auer i7-8700K (advanced edition), default speed (no overclock), Cooler: Noctua NH-D15s
  • RAM: G.Skill Trident Z 3200C14 DDR4 64GB, XMP set to profile 1 in BIOS
  • Videocard: NVIDEA RTX 2080Ti (Founders edition)
  • Monitor: LG 38 inch ultra-wide (21x9) - yes upgraded from 34 to 38, I can see more tracks now! Resolution: 3840x1600
  • C-drive: Samsung NVMe SSD 2TB 960 pro
  • Data storage: WD gold 6TB + WD Yellow 4TB
  • MOBO: Gigabyte Z370 Aorus Gaming 7
  • PS: Corsair HX1200i, Case: Silverstone fortress 2, shuttlePROv2, Keyboard and mouse: Logitech G910 and G700s (and now Evoluent Vertical Mouse)

Before November 2018: NVIDEA Gibabyte GTX 1080ti

Before November 2017: windows 10 Pro 64, i7-4790k, mem: DDR3 16GB GTX TITAN X (Maxwell)

 

AVsupport wrote on 11/8/2018, 2:45 PM

Thanks @bitman , yes iGPU is disabled in Bios also; I think the point I am trying to make is that

a) there seems to be no nVidia timeline acceleration

b) there seems to be buggy 'read-ahead' ; once the next clips are played the system catches up.

FYI, you can check your frame rates on the bottom of the preview window on playback:

bitman wrote on 11/9/2018, 2:41 AM

@AVsupport

Thanks for the framerate info, I was looking for it all over my screen except the one place where it really is!

I do see now a brief framedrop of 3 to 4 frames on that counter of the 4K 25P (PAL) on every end/start transition (hard cut) of every new clip on the timeline. This is not really visible on screen video.

I redid the experiment with a timeline full of FULL HD (50P) clips from RX10iii, and this time there was no framedrop. Framerate counter was just jittering between 49 and 50 all the time regardless of transitions.

Current system: VP16 (suite) build 307, VP15 (suite) build 384, Magix video pro X, Corel VS ultimate 2018, a lot of NEWBLUE plugins, Titler Pro 6, Mercalli 4.0, respeedr, Vasco Da Gamma 11, VASST stuff, Production Assistent pro3,...

  • OS: Windows 10 Pro 64, version 1803
  • CPU: der8auer i7-8700K (advanced edition), default speed (no overclock), Cooler: Noctua NH-D15s
  • RAM: G.Skill Trident Z 3200C14 DDR4 64GB, XMP set to profile 1 in BIOS
  • Videocard: NVIDEA RTX 2080Ti (Founders edition)
  • Monitor: LG 38 inch ultra-wide (21x9) - yes upgraded from 34 to 38, I can see more tracks now! Resolution: 3840x1600
  • C-drive: Samsung NVMe SSD 2TB 960 pro
  • Data storage: WD gold 6TB + WD Yellow 4TB
  • MOBO: Gigabyte Z370 Aorus Gaming 7
  • PS: Corsair HX1200i, Case: Silverstone fortress 2, shuttlePROv2, Keyboard and mouse: Logitech G910 and G700s (and now Evoluent Vertical Mouse)

Before November 2018: NVIDEA Gibabyte GTX 1080ti

Before November 2017: windows 10 Pro 64, i7-4790k, mem: DDR3 16GB GTX TITAN X (Maxwell)

 

AVsupport wrote on 11/9/2018, 2:51 AM

cheers @bitman for confirming, and thanks for the CPU tip also; mind you, I wasn't gonna reinvest after I only built this thing a few months ago thinking it's actually faster than the software it runs ;-)

My baseline playback is not really smooth (and should be) in 4K. Given this is only the start of the edit. Once I add grade etc, it'll only get worse from there. It's quite important imo to see the footage in decent quality (this is not a laptop requiring proxies), to see if there's choppy stuff or not..but this way you can't tell..

Timeline playback needs Love. And Attention.

Is there any Tweakers out there that know how to fix the internal prefs to make this go away??

bitman wrote on 11/9/2018, 3:00 AM

You can decrease the framedrop a bit (I just did the experiment on my system, and it works!) by moving your source video clips to an SSD instead of the usual terabyte drive. Obviously it is not that practical given the size/price of SSD vs HD. I will keep my source material on the HD and take the framedrop hit.

Last changed by bitman on 11/9/2018, 3:01 AM, changed a total of 1 times.

Current system: VP16 (suite) build 307, VP15 (suite) build 384, Magix video pro X, Corel VS ultimate 2018, a lot of NEWBLUE plugins, Titler Pro 6, Mercalli 4.0, respeedr, Vasco Da Gamma 11, VASST stuff, Production Assistent pro3,...

  • OS: Windows 10 Pro 64, version 1803
  • CPU: der8auer i7-8700K (advanced edition), default speed (no overclock), Cooler: Noctua NH-D15s
  • RAM: G.Skill Trident Z 3200C14 DDR4 64GB, XMP set to profile 1 in BIOS
  • Videocard: NVIDEA RTX 2080Ti (Founders edition)
  • Monitor: LG 38 inch ultra-wide (21x9) - yes upgraded from 34 to 38, I can see more tracks now! Resolution: 3840x1600
  • C-drive: Samsung NVMe SSD 2TB 960 pro
  • Data storage: WD gold 6TB + WD Yellow 4TB
  • MOBO: Gigabyte Z370 Aorus Gaming 7
  • PS: Corsair HX1200i, Case: Silverstone fortress 2, shuttlePROv2, Keyboard and mouse: Logitech G910 and G700s (and now Evoluent Vertical Mouse)

Before November 2018: NVIDEA Gibabyte GTX 1080ti

Before November 2017: windows 10 Pro 64, i7-4790k, mem: DDR3 16GB GTX TITAN X (Maxwell)

 

AVsupport wrote on 11/9/2018, 3:07 AM

@bitman perhaps you've noticed the drive usage on my above image..<5% is hardly 'pushing the envelope' I'd say...system and programs run on M.2, HDD is 7200RPM that should suffice

bitman wrote on 11/9/2018, 12:33 PM

@AVsupport Just wanted to report back on the framedrop. Problem is (if you could call it a problem), that the 3 to 4 frames framedrop is gone now. I just did the same thing as before (import 117 clips, 36 minutes total on the timeline; all 4K clips from RX10iii, no edits used). I did not update or changed anything that I know off. I am baffled.

 

Current system: VP16 (suite) build 307, VP15 (suite) build 384, Magix video pro X, Corel VS ultimate 2018, a lot of NEWBLUE plugins, Titler Pro 6, Mercalli 4.0, respeedr, Vasco Da Gamma 11, VASST stuff, Production Assistent pro3,...

  • OS: Windows 10 Pro 64, version 1803
  • CPU: der8auer i7-8700K (advanced edition), default speed (no overclock), Cooler: Noctua NH-D15s
  • RAM: G.Skill Trident Z 3200C14 DDR4 64GB, XMP set to profile 1 in BIOS
  • Videocard: NVIDEA RTX 2080Ti (Founders edition)
  • Monitor: LG 38 inch ultra-wide (21x9) - yes upgraded from 34 to 38, I can see more tracks now! Resolution: 3840x1600
  • C-drive: Samsung NVMe SSD 2TB 960 pro
  • Data storage: WD gold 6TB + WD Yellow 4TB
  • MOBO: Gigabyte Z370 Aorus Gaming 7
  • PS: Corsair HX1200i, Case: Silverstone fortress 2, shuttlePROv2, Keyboard and mouse: Logitech G910 and G700s (and now Evoluent Vertical Mouse)

Before November 2018: NVIDEA Gibabyte GTX 1080ti

Before November 2017: windows 10 Pro 64, i7-4790k, mem: DDR3 16GB GTX TITAN X (Maxwell)

 

AVsupport wrote on 11/9/2018, 3:51 PM

@bitman , is that with source files on the HDD? Issue is easiest to see if you cut a little sequence of ~3 sec clips. I couldn't help myself noticing you've got a ton of RAM in your machine also..lucky man

Either way, in my ideal world, I would love to see 1/3 CPU 1/3 GPU load, thus giving me enough overhead to satisfactory apply effects and grades via either.

Is anyone else seeing this, @Nick Hope is this a 'known issue'?

Nick Hope wrote on 11/9/2018, 9:13 PM

There was an issue about slow loading and high memory usage of XAVC-S which I recently removed from the list as it no longer seemed to be true, or at least not clearly defined enough to be on the list.

There's no issue listed that addresses your issue. Am I right to think it can be summarized as "Frames are dropped at transitions when playing 4K XAVC-S with NVIDIA GPUs"?

AVsupport wrote on 11/10/2018, 1:46 AM

Yes @Nick Hope I think this would describe the issue accurately enough.

It seems like GPU is not being used for timeline plackback decoding, and there seems to be no functional ‘look ahead’ memory queue for clips which breaks the playback buffer where cuts occur on the timeline, thus leading to dropped frames and rebuffering (This was 4K XAVC-S source on a 1080 timeline)

bitman wrote on 11/10/2018, 3:07 AM

to @AVsupport :This was with the sourcefiles on HD.

Problem is I do not seem able to consistently reproduce the small framedrop between the clips on the timeline. My educated guess is that in case I do not see the frame drops the clips are cashed. It is not that easy to flush whatever Vegas keeps somewhere. I do have a very large swap file on my SSD and I have a lot of real memory too. This morning I was able to reproduce the frame drops again, but now the frame drops are gone again. I presume it is cashed somewhere.

to @Nick Hope I played around a bit with disabling So4 (I generally keep it active) to see if loading a large number of clips affects loading time, memory use, and frame drops. What I noticed is that with SO4 disabled it seems to load a lot faster if it is not cashed. If it is cashed, the 117 clips just drop on the timeline in blink of an eye even with So4 enabled (or 33 seconds if it is not cashed).

What I did noticed with So4 disabled it takes less memory with the 117 clips, when playing them on the timeline memory taken is around 8 to 9 MB, with So4 enabled it is around 12 to 13 MB. That is 50% more memory taken with So4, I would call that significant.

Current system: VP16 (suite) build 307, VP15 (suite) build 384, Magix video pro X, Corel VS ultimate 2018, a lot of NEWBLUE plugins, Titler Pro 6, Mercalli 4.0, respeedr, Vasco Da Gamma 11, VASST stuff, Production Assistent pro3,...

  • OS: Windows 10 Pro 64, version 1803
  • CPU: der8auer i7-8700K (advanced edition), default speed (no overclock), Cooler: Noctua NH-D15s
  • RAM: G.Skill Trident Z 3200C14 DDR4 64GB, XMP set to profile 1 in BIOS
  • Videocard: NVIDEA RTX 2080Ti (Founders edition)
  • Monitor: LG 38 inch ultra-wide (21x9) - yes upgraded from 34 to 38, I can see more tracks now! Resolution: 3840x1600
  • C-drive: Samsung NVMe SSD 2TB 960 pro
  • Data storage: WD gold 6TB + WD Yellow 4TB
  • MOBO: Gigabyte Z370 Aorus Gaming 7
  • PS: Corsair HX1200i, Case: Silverstone fortress 2, shuttlePROv2, Keyboard and mouse: Logitech G910 and G700s (and now Evoluent Vertical Mouse)

Before November 2018: NVIDEA Gibabyte GTX 1080ti

Before November 2017: windows 10 Pro 64, i7-4790k, mem: DDR3 16GB GTX TITAN X (Maxwell)

 

AVsupport wrote on 11/10/2018, 4:30 PM

what I'd done in my OP was:

  1. change So4 usage in prefs [this might trigger a forced re-read]
  2. restart VP
  3. measure time it takes for All [background] CPU tasks to complete and come to idle at ~10% load.

In my tests, So4/notSo4 was behaving comparably similar, including RAM usage (hovering at 8GB/50%)