VST plugin's settings are out of frame

DustBin wrote on 3/23/2020, 2:45 PM

I have this old Legacy Reverb VST plugin from Saltline. And old 32 bit plugin originally meant for big DAW software (where it works just fine). But as I port it into Vegas, everything goes wrong, and the settings panel falls out of frame (as pictured below).

Now as mentioned, it is an 32-bit DAW effect, and it's a bit old and dusty, but is sounds so good!
Is there any way to salvage this, Or must I declare defeat?

 

How it looks in vegas.

 

How it's supposed to look.

 

Setup: MSI GS65 Laptop, with Intel i7 8th Gen. Nvidia GTX 1060. 16GB ram. Win 10 Home x64.

 

If there is any other information I forgot to add, please let me know, I'm kinda new to forum writing.
Thanks.
-DustBin

Comments

j-v wrote on 3/23/2020, 2:54 PM

- Do you have installed the latest Net framework updates for Windows and
- do have the latest Studio drivers installed for your Nvidia GTX 1060 ?

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 1909 build 18363.720, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 1909 build 18363.720, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 16,17 and VMS PL 16 are installed, all latest builds
Both Nvidia GPU's have driver version 442.19 Studio Driver, desktop the Studio DHC driver
TV      :LG 4K 55EG960V

Dutch video tutorials for beginners

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Grazie wrote on 3/23/2020, 2:55 PM

@DustBin - Check your DOT Net Framework is recent.

Grazie wrote on 3/23/2020, 2:55 PM

@j-v - Argh, yah got me!

rraud wrote on 3/23/2020, 3:03 PM

Disable (or enable) with the "Use high DPI scaling" settings in "Options> Preferences> Display" There is another setting for that in the VP .exe (or shortcut) "Properties> Compatibility" settings.. or temporarily change Windows display DPI to write a preset.

DustBin wrote on 3/23/2020, 4:12 PM

Thank you all for brilliant responses, I have checked that I have latest .Net FW, currently updating Nvidia driver, and I'll take a look at rraud's suggestion afterwards, I'll keep you posted.

 

Again, Thanks a million.
-DustBin

DustBin wrote on 3/23/2020, 4:24 PM

I found the culprit, thanks to @rraud. Disabling the "Use high DPI scaling" fixed everything.

 

 

Thank you everyone!

-DustBin

wwjd wrote on 3/25/2020, 6:36 AM

I call this a bug, because it didnt happen in previous versions

wwjd wrote on 3/27/2020, 6:53 AM

can this go back to the old method so users don't have to tweak icons/EXEs on their end?