8bit rendering vs 32bit

wwjd wrote on 7/24/2013, 1:07 PM
went to render a project but when I put it into 32bit video mode, it locked up 24% of the way in. tried playing it back also and seemed to lock up at the same spot.

I'm sure it is a plugin or setting or whatever, but I have not run across this before... is there something obvious I dont know about to get it to work?

vp12

Comments

musicvid10 wrote on 7/24/2013, 1:13 PM
You're confused. 32 bit float is a project mode, has nothing to do with rendering, except that it must be converted back to the encoder bit depth.

Rendered bit depth is entirely a function of the encoder, most often 8 bit 4:2:0, occasionally 10 bit 4:2:2 (or even higher if you're doing 4K).
videoITguy wrote on 7/24/2013, 1:13 PM
Subject: Trouble with Project Properties -> Pixel Format
Posted by: Massimo Rossi
Date: 7/24/2013 5:09:41 AM

Hi everybody.

Just installed V12 build 670, but soon I got some troubles with project Properties->Video->Pixel Format:

- changing from 8 bit to 32 bit floating point video levels: Vegas ignores it. It does nothing, even if I close the dialog box...

- changing from 8 bit to 32 bit floating point full range: OK, and at this point I can change to 32 bit video levels, too, BUT if I close the dialog box I'm no more able to switch to 8 bit mode, in no way... Seems that the project remains stuck to 32 bit modes and it cannot go back to 8 bit. If I save the project, I don't know how to bring it back to old, fast, 8 bit mode...

Any suggestion ? Do you have the same problem ?

Thank you.

wwjd wrote on 7/24/2013, 10:41 PM
really? I thought 32 bit created less banding in the final render?
hmmmm me need to hit the books... er.. help files again :)
musicvid10 wrote on 7/25/2013, 8:54 AM
"really? I thought 32 bit created less banding in the final render?"
It does, but the Render is not 32 bit!

For most practical delivery uses in 2013, the output encoders are 8 bit. Your Project settings do not change the encoders. It's this simple:

Decode->Process->Encode

wwjd wrote on 7/25/2013, 10:44 AM
gotcha. But I do want to reduce banding, so 32bit setting is helpful for renders. I think.

except sometimes it mucks with layers and colors in a bad way.
I usually stay at 8bit, but it was weird 32 locked up my project.

and teh other guy's question? I have no idea why it would not allow switch back. I guess 32bit has some ghosts in the machines :)
Laurence wrote on 7/25/2013, 10:53 AM
Yes, you will get less banding in 32 bit mode...at a price of a render that will take at least four times as long and often crash. I still do it quite often. Not only for gradients in skies, but also for the subtle things it does with the flesh tones on a face.
videoITguy wrote on 7/25/2013, 10:57 AM
Laurence, the whole point being made here, is that you had better try your workflow in the latest build of VegasPro and see what happens.
WillemT wrote on 7/25/2013, 11:04 AM
@ wwjd.

and teh other guy's question

Have you tried to switch back to 8 bit from a project set to 32 bit (either option)? I see the same problem (we are talking build 670 here).

Willem.
OldSmoke wrote on 7/25/2013, 11:36 AM
Same here, I can reproduce the problem. Has anyone reported this to SCS already? BTW: GPU on or off doesn't make any difference.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

wwjd wrote on 7/25/2013, 11:51 AM
k, to add to this issue.... my original problem happened BEFORE I knew there was a 670 update released. so, I'll get that installed, make a backup of my proj veg, and try again and see if the 8<>32 switching is broken for me also now :)
videoITguy wrote on 7/25/2013, 11:59 AM
wwjd, undoubtedly you had a problem before the latest 670 build. That particular problem is probably specific project related and media event determined OR FX applied determined in combination with GPU.
What we are suggesting to you is that 670 build will make your workflow that you are getting used to so problematic that you cannot continue with this process. Don't install 670.
WillemT wrote on 7/25/2013, 12:35 PM
Exactly what videoITguy says.

The sad part is that one of the many fixes could just have solved your current problem, but the newly introduced 8<->32 bit problem will keep you from knowing.

Willem.
wwjd wrote on 7/25/2013, 1:24 PM
cool, thanks guys. as a hobbyist, I'm not doing anything critical so it's not a big deal to me to stay 8bit - I just like tinkering. I already install 670, so I'll avoid the 32bit I don't need anyway. :)
videoITguy wrote on 7/25/2013, 2:58 PM
wwjd, you can be an experimenter and that's ok - but heads-up here - this is pro deal breaker-
Subject: RE: Trouble with Project Properties -> Pixel Format
Reply by: Marco.
Date: 7/25/2013 12:50:48 PM

It's not a matter of rendering. You'd need float point processing for many kinds of compositing.
Message last edited on 7/25/2013 12:52:25 PM, by Marco..
Robert Johnston wrote on 7/25/2013, 3:56 PM
Try changing the Stereoscopic setting from OFF to one of the other settings as well as changing 8 <> 32 (full), then click the Apply button. Finally, change the Stereoscopic setting back to OFF, and click Apply.

I can't get 32 floating point (video levels) to work. Maybe this would suffice: add the Sony Levels fx to the Video Ouptut Fx with the "Computer RGB to Studio RGB" preset, and use 32 floating (full).
farss wrote on 7/25/2013, 4:47 PM
Musicvid10 said:
[I]"You're confused. 32 bit float is a project mode, has nothing to do with rendering, except that it must be converted back to the encoder bit depth."[/I]

I don't know what others take the word "render" to mean however based on a discussion some years ago I've since taken it to mean everything between the decode and encode part of the process. From that the Vegas project settings affect the render pipeline. What comes out of that render pipeline as uncompressed frames at project bit depth is then passed to the encoder.

I do realise that many include encoding as part of the render process (I used to) but then we're kind of missing a word for just the part between decode and encode.

Bob.
wwjd wrote on 7/25/2013, 8:17 PM
yep - mine gets stuck in 32bit mode also in the 670 update - didnt try it before that.
actually, I guess I did in my initial post - twas before the update.... ima check that VEG now....

checked. my project is still 8bit. guess I will leave it there or make a backup first
musicvid10 wrote on 7/25/2013, 9:01 PM
Apparently there is some ambiguity on the use of the term "render," and I understand that. But we have to draw the line between the processing engine and the encoder somewhere; the two are not interchangeable.

In Vegas-speak, 32-bit float is a project setting, and the render controls the output. The output bit depth is entirely a function of the encoder and its chosen settings; one will not see a 32 bit depth render (output) in Vegas, nor does such an encoder exist afaik.

To answer the question, yes, 32 bit float processing produces less banding, even better in a 10 bit render than 8 bit. (Maybe that's the missing word.)

;?)



vtxrocketeer wrote on 7/25/2013, 9:59 PM
After verifying that my Build 670 also gets 'stuck' in 32 bit mode, unable to go 'back' to 8 bit, I uninstalled and rolled back to Build 563. That works fine as expected.

This is too bad: I edit in 8 bit for speed, then color grade and composite in 32 bit. Often I switch between the two to tidy up a project. Build 670 completely prevents me from doing that. I hope SCS fixes this soon.
OldSmoke wrote on 7/25/2013, 10:16 PM
So.. I ask again. Has anyone reported this bug to SCS already? If we don't report it the proper way it wont get done and it seems to me that this is a reasonable big issue. If no one has reported it yet, I will do so.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

Seth wrote on 7/25/2013, 10:22 PM
Technically, the render functioning at 32 bit floating point, and the encoding is only at the bit depth of the encoder, actually.
musicvid10 wrote on 7/25/2013, 10:27 PM
Uhhh, if you click "Render As" in Vegas, what screen shows up?

Not the Project screen.
Above all, we need to agree on a common language. And that language has been provided for us as users, in part, to make our communications easier.

If you want to discuss the merits of the terminology used in Vegas, do so with its developers. 'nuff please.



wwjd wrote on 7/26/2013, 10:23 AM
I didn't report it. I don't do enough important editing to bother reporting the 5 crashes I have per session :)
willqen wrote on 7/26/2013, 5:30 PM
I'm running build 670. just updated from build 563.

I've run thru the settings you guys reported but I don't SEEM to have the same problem at all.

I think ....

I'm sure a problem exists. No doubt, or you guys wouldn't be experiencing it.

I can flip into & out of: 32bit float "video", 32bit "full range" and 8bit.
Also switched the studio to computer rgb checkbox back and forth as well in all 3 settings just to see if Vegas would accept the change. No problem.

Only time I had a problem with the bit depth setting (which only messed with playback) was when I mixed different file types. Specifically an HDV clip with an AVCHD clip (DNXHD inside a .mov qiucktime wrapper) on the timeline. Playback was much smoother in 8bit. As you would expect.

Also Vegas wouldn't let me switch out of 32bit when my media properties (from media on the timeline) are listed as "DNXHD 32bit float" in the media properties page. This didn't occur any other time. Only with that one clip. (I didn't really have the time to try & hunt down another that was exactly the same).

Other than when using that one clip I can flip bit depth back & forth all I want with no apparent problems.

Incidentally I did notice that I had to hit "apply" on project properties or Vegas wouldn't seem to want to take any change of the bit depth. unusual.

Hope it helps ...

Will