An Exception has occurred (access violation)

kirkdickinson wrote on 12/13/2008, 4:06 PM
I have been using Vegas since 3.0 and I don't remember getting an exception before.

I am trying to open a project. It gets 7 of out of 21 opening, then kicks this error:

An Error occurred during the current operation.
An Exception has occurred.

Sony Vegas Pro 8.0
Version 8.0c (Build 260)
Exception 0xC0000005 (access violation) WRITE:0x59B0000 IP:0x24A02BE1
In Module 'mcdddec.dll' at Address 0x24A00000 + 0x2BE1
Thread: AsyncPreroll ID=0x6F8 Stack=0x5BAF000-0x5BB0000
EAX=ffff3820 CS=001b EIP=24a02be1 EFLGS=00010282
EBX=1264bf60 SS=0023 ESP=05bafe4c EBP=00000000
ECX=fffffdf4 DS=0023 ESI=059b0000 FS=003b
EDX=ffffffff ES=0023 EDI=00000006 GS=0000
Bytes at CS:EIP:
24A02BE1: 66 89 0E 83 C6 02 4F 75 f.....Ou
24A02BE9: 9A 8B 7C 24 10 8B 44 24 ..|.D$
Stack Dump:
05BAFE4C: 1265F8F4 12600000 + 5F8F4
05BAFE50: 059AF880 056B0000 + 2FF880
05BAFE54: 0005D180 00030000 + 2D180
05BAFE58: 12640C48 12600000 + 40C48
05BAFE5C: 00000006
05BAFE60: 24A01868 24A00000 + 1868 (mcdddec.dll)
05BAFE64: 00000560
05BAFE6C: 000007E0
05BAFE70: 10F60020 10F60000 + 20
05BAFE74: 0002F880
05BAFE78: 0000BB80
05BAFE7C: 059AF880 056B0000 + 2FF880
05BAFE80: 00000540
05BAFE84: 0005D180 00030000 + 2D180
05BAFE88: 23206DF6 23200000 + 6DF6 (mcmpegin.dll)
> 05BAFEBC: 23205977 23200000 + 5977 (mcmpegin.dll)
> 05BAFEDC: 7C802600 7C800000 + 2600 (kernel32.dll)
> 05BAFEE4: 33BBA3D7 33BB0000 + A3D7 (mcplug.dll)
> 05BAFEEC: 33BBA440 33BB0000 + A440 (mcplug.dll)
> 05BAFF0C: 0068A86B 00400000 + 28A86B (vegas80.exe)
05BAFF10: 05F95B84 05BB0000 + 3E5B84
05BAFF14: 00000000
05BAFF18: 00000000
05BAFF1C: 05980000 056B0000 + 2D0000
> 05BAFF48: 0068F653 00400000 + 28F653 (vegas80.exe)
05BAFF4C: 00000008
> 05BAFF50: 00AEBE48 00400000 + 6EBE48 (vegas80.exe)
> 05BAFF54: 00AEBE60 00400000 + 6EBE60 (vegas80.exe)
05BAFF58: 00000002
05BAFF5C: 00000000
05BAFF60: 00000000
05BAFF64: 00000000
> 05BAFF80: 00AEC5E0 00400000 + 6EC5E0 (vegas80.exe)
05BAFF84: 00000020
05BAFF88: 00000000
05BAFF8C: 00000001
05BAFF90: 80004001
> 05BAFFA8: 00848D22 00400000 + 448D22 (vegas80.exe)
- - -
05BAFFF0: 00000000
05BAFFF4: 0068F410 00400000 + 28F410 (vegas80.exe)
05BAFFF8: 01B93B40 01AA0000 + F3B40
05BAFFFC: 00000000


kirkdickinson wrote on 12/13/2008, 4:24 PM
I renamed the file mcdddec.dll to mcdddec.dll.bak and then tried to open my project. It opened with an error message that I didn't write down, something about the video stream being different. It opened and nothing looks wrong with it.

What does mcdddec.dll do and why do I need it?


johnmeyer wrote on 12/13/2008, 5:00 PM
It could be bad or corrupt media. You could test this by renaming the folder containing the media. Then try opening the project, but tell Vegas to ignore all missing media. Does it open OK? If so, repeat the above, but this time tell Vegas that you want to specify a new location for the missing media. It will then ask if you want to use that same folder for other missing media.

Answer NO.

You then re-specify for each missing media. Hopefully, you will then get a crash immediately after opening one specific video or audio file. This should then let you either eliminate that from the project, or recapture or repair it.
Steve Mann wrote on 12/14/2008, 10:27 PM
You only need the first four lines of the error - the rest is only meaningful to the original programmer.

Have you recently uninstalled any Sony Media programs? Mcdddec.dll is a set of 'subroutines' shared by many of SMS applications. I would delete mcdddec.dll then reinstall Vegas and try again. If Vegas needs mcdddec.dll it will reinstall it. If it is a leftover DLL from a prior install, then it won't be there after reinstalling Vegas.
Tim M wrote on 1/16/2009, 10:15 PM
I've been having the same problem. If it is a problem with corrupt media, how do I prevent that from happening? My project has more than 150 clips. I don't have time to re-reference every single clip each time this happens.
Tim M wrote on 4/2/2009, 8:11 PM
My experience leads me to believe it's not corrupt media. I spent almost 6 hours importing my clips into a new project, 5 clips at a time. I would then open and play each clip in the trimmer, after which I would save the project. I got as far as 130 clips and started getting the exception & crash. I tried going to earlier versions with fewer clips and the problem persisted. Mind you, these earlier versions didn't originally crash. It's infuriating. SCS has been completely worthless. They offered me a free upgrade to Vegas 9, but never said when they expected it to be released.
I'm about to lose almost $1,000 because of this worthless software. I've tried running it on 3 different machines and the problem persists. I never know when it's going to crash or why. Sony doesn't seem to understand their own software, and I don't know why they would expect their customers to put up with this crap, especially in this economy. They only want to blame me, my media or my hardware. God forbid there should be a problem with their product!
I'm seriously considering a switch to FCP, but my budget is frozen, so I don't know how I can afford FCP or the Mac to run it. Guess I'm stuck with Vegas for now. Sony doesn't seem anxious to keep their customers. They don't have to try, either. We can't afford real NLE's and so Vegas is the only choice.
Robert W wrote on 4/3/2009, 1:04 AM
Hi Tim and Kirk. Sorry to hear you are having trouble with the Vegas software. You are both right, you should not be having these problems, and you will both find that there are people here that will not respect your frustrations with the software. My advice would be to ignore them.

In regards to your problems, what format are the clips both you guys are using?

I have an idea why Kirk's solution may have worked. 'mcdddec.dll' is a Mainconcept Mpeg codec. if you renamed that, Vegas may have used another MPEG capable codec to open the file. However you may find that your Mainconcept Mpeg encoding option has disappeared from you rendering dialog.

As for why it happened, this is a shot in the dark, but did either of you run Vegas Movie Studio (or whatever it is called) on that machine previously? Or alternatively, have you installed any varieties of DVD-architect. I am just wondering if it is something to do with licence registration of the software, and perhaps some anti-cracking code in kicking in and causing the crash.
Tim M wrote on 4/3/2009, 3:48 AM

Thanks for a reasoned response to my venting.
1. I'm capturing HDV, and Vegas creates m2t files. I've also tried using my Firestore, which is also set to generate m2t files. I shoot 720/30p. I've tried 60p with the Firestore set to generate mov, but Vegas only found audio tracks, no video.

2. I have never installed Vegas Studio on any of the machines where I've tried to run Vegas 8 Pro. This problem has occurred on 32 and 64 bit workstations (using Vegas 8.1).

3. I have not renamed any codecs.

4. I do have Architect 5 installed, so I'll try removing that and running Vegas again.

Thanks again for not giving me the standard Vegas Tech Support response.
craftech wrote on 4/3/2009, 4:13 AM
This problem came up on Edward Troxel's forum.

Might be worth a read.

Tim M wrote on 4/14/2009, 8:52 AM
SCS says the Troxel link is in regard to a Vegas Studio issue.
jabloomf1230 wrote on 4/14/2009, 9:46 AM

This is someone with the same error, but no resolution. That thread may be of help to you in determining a workaround.