Artifacts on speed-changed video

jeremyk wrote on 10/13/2003, 2:11 PM
I speeded up a clip of orchestra players slightly (playback rate of 1.072) to match the audio of a different take. It looks pretty good, except that some horizontal lines, like the edge of a lighted music stand, appear to pulse up and down slowly. Checking "reduce interlace flicker" for the clip helps some but not completely, and seems to make the clip more blurry.

Any ideas would be welcome!


jeremyk wrote on 10/14/2003, 11:05 AM
Thought I'd try this again.

Let me put it another way. How can I make Vegas deinterlace the video before changing its speed? I think that would do the job here.
johnmeyer wrote on 10/14/2003, 11:14 AM
I don't think it is an interlace problem, per se. Usual things to try:

1. Right click on clip, select properties, and then click on Force Resample.
2. Try adding a VERY small amount of motion blur (its on the Video Bus track which you'll have to show in the View menu).

You can also try to add a supersampling level of 2 or 3, and also change the video rendering quality (found by clicking on the Custom button in the Render As dialog) from Good to Best. However, many posters have written that both of these really only affect still image media, and media generated by Vegas itself. It is certainly worth rendering 5-10 seconds with each of these settings and see if it helps. Let us know your results.
JohnnyRoy wrote on 10/14/2003, 12:06 PM
Supersampling might help here since the playback rate is being changed which means frames are being interpolated. Try it on a small section and see if it helps. I’ve used it to smooth out jagged (i.e., pixelated) lines and it does a nice job of smoothing.

jeremyk wrote on 10/14/2003, 12:48 PM
Thanks, Johns!

Supersampling does the job (though, BOY is it slow!). In this particular case, supersampling by 2 is not enough, but 3 or 4 look fine, and about the same. On the clip properties, "smart resample" seems to give the same results as "force resample" (I didn't compare render times, so maybe they're doing the same thing). Didn't need to apply "reduce interlace flicker" or motion blur.
johnmeyer wrote on 10/14/2003, 1:01 PM

I really appreciate your taking the time to report back the results.

I probably shouldn't post anymore about "force resample" because I think Vegas 4 now always forces the resample when playback rate is changed. I believe that Vegas 3 did not. The only catch is that in some situations, the interpolated intermediate frames created by resampling reduce overall sharpness.
JohnnyRoy wrote on 10/14/2003, 1:58 PM
Glad it worked. Yes, it does take a supersample rate of 3 or 4 to really smooth things out but it does look amazing. Its slow because its processing each frame 3 or 4 times respectively and should take 3 or 4 times longer than without it. (imagine using 8!) That’s why you don’t want to use more than you have to. I always sample on a little piece before I do a major supersample to see what I can get away with.

riredale wrote on 10/15/2003, 12:34 AM
This is a confusing area for me. I've used resampling many times because I am often trying to match the image of one take with the sound of another take, and of course no two takes are at exactly the same speed.

What I find is that Vegas will perform a "blending" of adjacent frames in order to manufacture an intermediate frame that never existed. Fine. But the very fact that those two frames are being blended means that blurring is taking place. The result is that an object resampled in this fashion will be sharp, blurry, sharp, blurry, and so on as it moves.

Look at the example given in the pdf help file. As I recall, they show a basketball in one place, followed in the next frame by the basketball in a different place. Resampling creates intermediate frames that show "junk" in that a perfect process would show a single basketball displaced between the positions of the ball in the two original frames; what the new frames show instead are "echoes" of the two ball positions. It's pretty easy to see this artifact at normal speed. Still, it's better than the alternative.
SonyEPM wrote on 10/15/2003, 10:04 AM
There's quite a few ways to handle slomo in Vegas, and no one way is "right" for all combinations of source/speed/desired look.

Most of the time the Vegas defaults produce really nice slomo but here's an alternative method you might want to play with for interlaced DV clips.

In project properties:

Set video project full resolution render quality to "best".

Set Deinterlace method to "interpolate fields".


Set the event playback rate to ".5" (for this test- you can set it to whatever you want)

Disable resample for the slo-mo event.

Render the slo-mo'd event as DV, progressive (AVI>custom>video>filed order= none).


Set project props> deinterlace method back to the previous setting you were using (usually blend) once the slomo render is completed.

johnmeyer wrote on 10/15/2003, 1:19 PM
Well, armed with SonyEPM's advice, I tried to come up with the "ultimate" slo-mo for one particular clip. I took about 2.5 seconds of DV video of a volleyball player spiking the ball over the net. The camera panned left to right prior to the spike, and then came to rest during the spike. It was taken from slightly behind the player so the ball moves left to right during the set, then away from the camera after the spike, and then finally straight up after the opponent digs the ball.

I slowed the video down to 25%. I first tried SonyEPM's settings exactly. I rendered the clip and then used Scenalyzer to play it through my DV camcorder to a monitor. The SonyEPM settings produce very sharp video. However, without the interpolated intermediate frames the motion is quite jerky. Of course, this is very fast motion.

I then turned resample back on, and the results were much better, but there was a pulsing flicker, almost like watching an old movie, especially during the portion of the scene where the camera was moving. To fix this, I first tried supersampling, with settings of 3 and then 4. This made a very subtle improvement in the smoothness of the motion, and mildly reduced a few artifacts, but the flicker was still there. I then tried motion blur, first with a setting of 1 and then 2. The setting of 2 got rid of the flicker. I then tried just the motion blur without the supersampling, but some of the flicker returned.

I then tried going back to interlaced rendering rather than progressive. The results seemed slightly smoother. I tried "reduce interlace flicker," but that seemed to slightly reduce sharpness, and I didn't see any noticeable decrease in artifacts.

So, after much experimentation, for this particular clip, when both the source and output are interlaced NTSC 29.97 DV video, these were the settings that produced the most pleasing result on video slowed to 25%:

Force resample
Reduce interlace flicker not checked

Project Properties
Full resolution rendering quality: best (although "good" seemed just about the same)
Deinterlace method: Interpolate Fields
Motion blur: Gaussian

Video bus envelopes
Supersampling: 3
Motion Blur: 2

Render As
NTSC DV template (no changes)

I did not play around with the motion blur type in the project properties

I then downloaded Dynapel's "Slow Motion" program. The results were awful by comparison. This puzzled me, because several years ago I used their Motionperfect program and thought it was pretty good. Since I'd already killed an hour doing all this, I downloaded Motionperfect and tried it. The results were equally bad. It looked like the fields had somehow been reversed. I used Vegas to reverse the fields and tried again. The results were still terrible. I finally realized that this program only works with progressive input. I used Vegas to create a progressive version of my input and this produced smooth results. However, there were all sorts of weird artifacts from the interpolated frames that Motionperfect creates (it actually attempts to synthesize intermediate frames using motion estimation rather than simply blending adjacent frames).

Bottom line: If you are willing to twiddle the settings, Vegas Slo-Mo is amazingly good.
jeremyk wrote on 10/15/2003, 6:53 PM
Thank you for sharing the results of your research. VERY interesting!

I just wish I understood all I know about Vegas...
mmzz wrote on 3/14/2004, 9:50 PM
im working a a 35 minute birthday video for a freind. everything was cool until i copied some files from another project and pasted them in. i can still hear the music and sound just fine but when i render it there is no sound. i have allready saved over the old file so i cant back out of this. this project was supposed to be done monday to be given as a gift but it looks like a months work is now going to be late. any ideas?? im desperate!!

johnmeyer wrote on 3/15/2004, 8:27 AM
You will get better help if you post this as a new topic. It has nothing to do with the original (long-dead) topic.

Make sure you render as a DV AVI file, or if you are rendering as MPEG for DVD Architect, you must do a separate render to AC3.