Audio clipping error messages

darkhop wrote on 12/9/2002, 10:56 AM
There is really only one thing I want CDA for, and that's track crossfades. I've listened to too many Zappa albums (that guy didn't want a second of valuable time wasted), so I actually find it weird when CDs have silence in between tracks.

So far, with both the beta and the purchased version, I can't even snug one track flush against another. It'll *let* me do it, of course, but when I hit the 'burn' icon I suddenly get an error box that tells me most, if not all, my tracks contain audio clipping. I let the burn proceed one time and indeed got a disc full of jumps when one track hands off to the next.

If I go back and look at the junctions, there does seem to be the smallest little change in the graphic representation. Basically instead of a straight line up and down there'll be a little corner shaved off.

Now, my cd writer needs a firmware upgrade, because it gets quirky when I burn track by track in SF5 (the finalize portion goes way too fast and leaves an ear-splitting "CCHHHKK" sound at the tail end of the cd). But I don't see how a possible hardware problem would cause errors before a burn takes place.

Has anyone else run into this? If necessary I'll get the exact message tonight if no one knows what I'm talking about. Running WinME on an HP 1.5ghz machine.


SonyDennis wrote on 12/9/2002, 4:27 PM
If the audio you're crossfading is loud, the sum could easily induce digital clipping. If you play across that section, the master meters should should clipping (a red indicator and a number greater than 0.0 dbFS).

Are you using the auto-crossfade provided by overlapping events, or are you using the second audio layer? If the latter, you may need to attenuate your audio slightly to avoid the clipping. Watch the master meter peak hold to determine how much to cut by.

dauthiatull wrote on 12/9/2002, 7:58 PM
try using another cd burner app. one that can write disk at once.

use an app like acid pro to mix and cross fade all your tracks and render it to a single file then use a wave editor to cut the mix into tracks

to make sure that all the tracks will fit tight togther, the total number of samples of each track MUST be divisible evenly by 588. that is because each sector on the disk will hold 588 samples exactly. if the total samples is not evenly divisible, the last sector of that song will only be partially filled with audio and the rest is padded with zeros. zeros are the equevelnt to silence. 588 samples is equal to 1\64 of a second which will sound like a click or a pop.

once you have cut your mix and all of the tracks ( the last one doesnt matter )are divisible by 588 ( I use sound forge with the sample ruler on ) open your cd app and insert the songs in the correct order, then burn using DAO (disk at once)

I have used this method and it works
email me a if these instructions are not too clear Ill be glad to help
Geoff_Wood wrote on 12/9/2002, 9:07 PM

That about the weirdest suggestion I've ever heard !


Darkhop, If you are getting clipped peak messages, then you are clipping peaks. To avoid the messages address whatever you are doing to generate clipped peaks. There are volume envelopes and overall track levels to help here. No matter what app you use, if you add 5 + 6 you will get 11, instead of adding 5 + 5 and getting max 10.

The 'second audio layer' can help to twiddle the relative volumes in your fade areas.

SonyDennis wrote on 12/9/2002, 9:39 PM

You don't need to do that in our applications. You can align audio to any sample position that you want.


P.S. I'm sure you meant to say that a CD Audio sector is 1/75 of second, not 1/64.
darkhop wrote on 12/10/2002, 9:46 AM
No, I'm not getting any into-the-red peaks, and even if it were, would that cause the audio to jump? What I mean by that, and what was the case all through that one disc I burned, is that nearly a full second of audio at the beginning of a track would be gone. For instance, if a tune starts right on the downbeat, that first downbeat would be missing. That's what I meant by "clipped" -- not audio washout, but a jarring jump, like bumping into the turntable when a vinyl record is playing and the needle skips a groove.

Unfortunately I didn't get a chance to turn on my computer last night. Will try to get the exact error message tonight. Thanks for the reply.
darkhop wrote on 12/10/2002, 9:54 AM
>>use an app like acid pro to mix and cross fade all your tracks and render it to a single file then use a wave editor to cut the mix into tracks<<

I'm afraid you've lost me here. Why would I need acid pro when I've got SF5? And I'm not sure what you mean by wave editor -- since SF would seem to be one -- but anyway, since I've gone and spent the cash on CDA it might be in my interest to try getting it to work rather then spend more cash (which I don't have) on yet more apps, yes?

Unfortunately when you start talking about 'number of samples' and the like, you're way over my head, which is why I buy things like CDA, so I won't have to worry about it.
SonyDennis wrote on 12/10/2002, 3:15 PM
Oh, I thought you were getting the "some audio may have digital clipping" message. What exactly does the error message say?

If you're missing the downbeat when playing back on a CD player, I think what you're seeing is either mis-aligned audio to track start, *or* a big un-mute time in your player. Try turning up the CDA5 unmute simulation time, and turn on emulation, and see if you get the same effect.

Player unmute times are why you should never put a track start right on a downbeat.

But, if you're still getting screeches at the end, something is wrong with your burner. Update the firmware, like you said.