Audio glitches since upgrading to Vegas 13 64 bit

studioredfern wrote on 10/9/2014, 1:57 AM
I am wondering if anyone else is experiencing this problem.

If I am working with audio, and then I add a plug in like iZotope Nectar Elements, I experience glitching as the mouse glides over the audio clips. This happens only when using ASIO audio drivers but not under Windows Classic Wave Driver or Microsoft Sound Mapper.

This problem has been discussed by other users on audio forum thread:

It has become a real problem for me as it means that I can't record audio with input monitoring on with some plugins enabled.

I have been using Vegas mainly as an audio editor since very early days but this problem is really getting in the way of my work flow.

My audio card is M-Audio Delta 66.

Has anyone else experienced this and is it a problem with my sound card or vegas? Thanks Phil


studioredfern wrote on 10/10/2014, 2:14 AM
Hi there, no-one at all come across this problem?

DiDequ wrote on 10/10/2014, 3:45 AM
Hello studioredfern.

New with Vegas 13( using 12 before), I tried several Izotope Nectar Elements presets and cannot listen any glitch, pop or click.
i'm using 2 different Asio devices : ( Creative Xfi internal sound card ) (USB device - Tascam Us 600)
Each uses a different output - no problem.

I have had a look to
I had a similar problem under linux years ago and it was a driver issue - updating it solved the problem.

1 Now, have you checked all your power cords as most people think this has no influence, in fact, there's always a neutral an a phase wire ( plus the ground cable), and this might add some extra noise in certain cicumstances.

As it's very easy to plug a power cord in 2 ways (the good and the upside down) in france, maybe you encounter the same problem.
Even if your problem does not come from here it's always better to check all your power cables.

2 when touching a metal surface ( if any), can you feel strange vibrations ? if yes, you might have a leaking device and some current flows through you to ground.
Just remove this device that causes this and try again.

3 try to plug another amplifier / loudspeaker system on your sound card to check if problem remains, just in case ...

Edit :
4 at last, try deactivating temporarily all your inputs from your soundcard software.

Good luck, I hope someone else can help you !