Blurry overlaid text

kunal wrote on 10/5/2009, 7:36 PM
I'm overlaying a couple of lines of text on video using the ProType titler. Source footage is 1080-60i. Frame size for the Titler is 1440x1080.

I've tried the default font size of 2.0 with the Candara font and various combinations (drop shadow applied, font weight set to normal/bold, sharpen filter of 0.0/0.2 added to the titler) but the resulting font is extremely blurry and out-of-focus when the MPEG-2 SD DVD is played on a 720p projector. The font is crisp when the DVD is played on an LCD monitor. I also tried the old text media event but got roughly the same results.

Any ideas what to try to improve sharpness? To see if it's something with the projector, I tried a different DVD of my earlier movie (shot from SD footage and edited on FCP by a friend) and the fonts looks crisp on that one, so I think I'm somehow not having the right settings.

Thanks for any help...


Terry Esslinger wrote on 10/5/2009, 7:59 PM
A couple of general things with texts/
The simpler the better/ No filigtrres, serifs. thin narrow fonts/
No contrasty background and font co;ors.
Make your text reso;tion twice your project resolution. If your source footage is HDV 1440x1080 make your text 2880x2160
TheHappyFriar wrote on 10/5/2009, 8:20 PM
i think vegas automatically anti-alias's the fonts for you, which looks great in many situations but in some doesn't.

do what's suggested & increase the resolution of the text event & it will look much sharper.
kunal wrote on 10/5/2009, 8:38 PM
I doubled the resolution as suggested but it didn't make the difference I was expecting. It did improve the sharpness if I'm using 2.0 font size, bold and drop effect. This size is too large, however (both for projection and viewing on a TV/computer). If I reduce the font size to 1.2, it loses a lot of crispness when projected. (but looks great on a monitor/TV)

Here's a snapshot of the 1.2.

Are there any "safe" standard fonts that have been used w/o problems? I was thinking Verdana but wasn't quite sure.
Rory Cooper wrote on 10/5/2009, 9:38 PM
Read this article it may have a bearing on your problem

kunal wrote on 10/6/2009, 7:41 AM
xfx - Thanks for that link. I wasn't sure though what to apply from that link towards my problem. I didn't see a mention of text in that article. Maybe I missed something?

If anyone has Protype presets that they would be willing to share, that would help a lot as well...thanks.
Laurence wrote on 10/6/2009, 7:41 AM
Yeah, that Glenn Chan link has the answer, but it might not be obvious unless you delve in a little. What is going on is that the text white in your project is at the default white setting of RGB colors red, green and blue at levels of 255,255,255. These are beyond what is legal in studio RGB color range and your projector and as a result, your text is oversaturated and the white looks blurry. What you need to do is go into your text generator and set the white to 235,235,235 or less.

The same problem would also exist if you had any animated photos in your project. Vegas decodes jpegs and pngs at computer RGB levels and if these levels aren't corrected they will look oversaturated on an HD TV set or your projector.

This may not seem like it at first, but it is exactly the same subject as some of us are talking about in thread.[/link] It is also what we are discussing[/link]

This is a common issue and there should be a sticky at the top of this forum.

Basically what is going on is this:

Vegas works in the cRGB (computer RGB) range. DV and HDV footage is sRGB (studio RGB) range. DV and HDV footage looks washed out in the Vegas preview window because it is sRGB, but renders correctly.

Text generators in Vegas default with their whites at 255,255,255 and their blacks at 0,0,0 which is the cRGB range. Text from these generators should be in the sRGB range which spans from a black of 16,16,16 to a white of 235,235,235. Text at the default cRGB range will look great in the Vegas preview window but will be oversaturated in a final sRGB render.

Still photos (jpegs, pngs, etc) display in the cRGB range when you put them on a Vegas timeline. Because of this they look great in the Vegas preview window but are oversaturated upon render. The solution is to put a cRGB to sRGB color convertor on all the stills in a Vegas project. This can be done on each still photo event or just once on a track containing all your stills.

With your sRGB level DV or HDV footage, your sRGB range text and your color corrected photos all on the Vegas timeline, you are now in sRGB color space except for your blacks which still go down to 0,0,0 every time you fade to black. For most HD TVs and projectors this won't be a problem, but for some really old CRT TVs, this will cause your horizontal sync to go crazy every time you fade to black. It can also be a problem with broadcast.

If you want to have a proper 16,16,16 black, you have two solutions: put a broadcast colors filter on your output, or put a solid media generator track of 16,16,16 black on the bottom track which extends the entire length of the project. I like the media generator approach because it still lets you smart render the DV, HDV or Cineform. Also, I use the media generated black track to extend the ending of the project a bit so that it kind of hangs on on the black a little after the video ends rather than ending abruptly after the last fade to black.

Now that you are all sRGB legal, the only problem left is that your Vegas preview window will look quite washed out. If you are using an external monitor, the Vegas preview color correction can be set to correct this, but if you are like me and using the small preview window, you will need to add color correction for preview.

To add preview color correction, just go to you master video effects buss and add a color corrector with the "Studio RGB to Computer RGB" preset. Use this while you are editing but don't forget to disable it when you render.

For my preview color correction, I really like using the free Colorlab[/link] plugin. There aren't obvious sRGB to cRGB and cRGB to sRGB presets, but it is quite easy to make your own.

To set up sRGB to cRGB color conversion in AAV Colorlab, uncheck the "6-vector" tab and check the "Adjust" tab. Click on the word "Adjust" so that the related parameters come up on the right. Look at "2) Input Range" and click on the "Preset" box and select "Convert from studio RGB" and use the "Both (normal)" option. Save this setup with a name like "Studio RGB to Computer RGB"

The reason I like this plugin so much for adjusting the Vegas video preview is that right by the input color color range correction are brightness and contrast controls that you can use to further tweak your image much like you would on an external monitor. I also like that right below the brightness and contrast controls are output level controls. When you boost your brightness and contrast a bit, you are likely to be getting blown out highlights. Bringing down the top output level a little can correct for this and still leave you a punchy looking preview. It's just for preview so what is really important is that you set it so it looks right. To set it up a good way to do it is render out a bit of footage that you are happy with and play it back on your HD TV setup. Now match this with the AAV Colorlab settings. Once you get a good match, you now have a preview correction filter that will be much pleasanter to look at and will at least get you in the ballpark color wise. No it's not as good as a calibrated monitor, but it's a heck of a lot better than trying to guess colors without this correction.

Remember, turn the preview color correction on when you edit, but don't forget to turn it off when you render to anything that is going to be played back on a TV, an HD TV or a projector. You can leave the correction on when you render Youtube if you like that look better.
Laurence wrote on 10/6/2009, 7:48 AM
Sorry about the long answer. The short answer is to set your Pro Type Titler whites to 235,235,235.
farss wrote on 10/6/2009, 1:51 PM
Keeping levels legal is part of the answer. Using the right combinations of colors is another e.g. red text on a blue background is going to look bad. Despite all that and a lot of futzing around I've not been able to get text to look as clear as what comes out of FCP or even iDVD's menus on a CRT. As far as I can work out it has something to do with anti-aliasing.

TheHappyFriar wrote on 10/6/2009, 6:51 PM
projectors shouldn't have issues with 0-255 RGB. They're replacements for monitors after all. :)

Odds are the projector is to bright if that's the case (I've never had issues with projectors I've used, but if it's to bright it may be on a "movie" setting or something similar).
Laurence wrote on 10/6/2009, 8:29 PM
If the projector is in a mode that will make a movie or video look good, 255 white is going to be too bright. 235 is the brightest he should go. A bit darker would probably be even better.
kunal wrote on 10/6/2009, 10:13 PM
Thanks, Laurence and everyone else.

I tried the 235,235,235 setting but there's still a noticeable blurriness in the font. The projector is in the standard mode (I haven't tried the high-saturation 'cinema' mode yet but, as a reference, other subtitled/captioned DVDs don't have this crispness problem in this mode)

I tried a few different fonts - Trebuchet, Arial, Georgia, Comic Sans, MS Reference Sans Serif, Tahoma. Some have this problem to a larger extent but all have this basic problem. I also tried different font sizes (ranging from 0.7 - 2.0 in ProType) and the sharpen filter and the drop effect.

Each of the clips in my video has text overlaid on it, so I'm concerned about getting this right.. Any other suggestions? Thanks...

farss wrote on 10/6/2009, 11:37 PM
The Sharpen FX is probably doing next to nothing. The edge that it's trying to sharpen is between the text and nothing (transparent). Even if it did it's job it may well make the problem worse. Sharp edges could might make the scaler in the projector do nasty things.

You could try adding a very tiny soft outline to the text. Try 50% grey (128,128,128). I know it sound counter intuitive making something soft to make it sharper but give it a try.

TeetimeNC wrote on 10/7/2009, 4:48 AM
To add preview color correction, just go to you master video effects buss and add a color corrector with the "Studio RGB to Computer RGB" preset. Use this while you are editing but don't forget to disable it when you render.

Laurence, this is seems like nice suggestion. What, if any, effect will this have when color balancing (i.e., selecting white) off the preview window with the Color Corrector eyedropper?

TeetimeNC wrote on 10/7/2009, 4:50 AM
You could try adding a very tiny soft outline to the text. Try 50% grey (128,128,128). I know it sound counter intuitive making something soft to make it sharper but give it a try.

Bob, this technique has worked well for me although as you say, it does seem a bit counter intuitive.

TheHappyFriar wrote on 10/7/2009, 6:18 AM
if subtitles look ok from DVD's then it's most likely AA vegas does on the fonts. Subtitles/CC aren't AA, they have very hard edges.

there is no solution to this. In video AA normally is better then no AA. What you could do it make your text in a separate app & see how that works (IE Pshop/gimp, etc).
Laurence wrote on 10/7/2009, 7:46 AM
Have you tried adding a very subtle amount of shadow? Use a 16,16,16 black, zeros for both your x and y offset and just the tiniest bit of feathering.

If you could hook up a laptop to the projector you could experiment until you got it right.
kunal wrote on 10/7/2009, 9:09 AM
Bob - I tried varying amounts of outline (0.5 - 3). It did make a small difference...I'm going to have to try different levels. What levels have you used for this?

Laurence - you mean drop shadow? I tried that but it actually made it slightly more blurry. I didn't try the 16,16,16 black though. (I was trying the default of 0,0,0). How do I add feathering in ProType?

As a backup, if I want to import text created using FCP (that a friend has), how do I go about doing so?
kunal wrote on 10/7/2009, 9:15 AM
>>As a backup, if I want to import text created using FCP (that a friend has), how do I go about doing so?

I meant to say FCP or Photoshop.
Laurence wrote on 10/7/2009, 9:16 AM
I forgot you were using pro type. I I was talking about drop shadow without any drop. just a little black feathering around the edges of the text. I'm still feeling like it is oversaturation issue.

If that doesn't help, how about an even lighter white. 225,225,225 still looks white but it will be less bright.
Laurence wrote on 10/7/2009, 9:25 AM
Are you playing it on a DVD into your projector?
kunal wrote on 10/7/2009, 9:29 AM
I'll have to try 225.

Yes, I render the DVD using MPEG-2 and play that DVD over the projector.
Laurence wrote on 10/7/2009, 9:31 AM
Now I remember. We discussed downrezzing in thread[/link] and privately. How are you doing your downrez? It could be that the way you're downrezzing is hurting the edges of your text.
kunal wrote on 10/7/2009, 9:39 AM
I have a 1080-60i project with interlace set to blend in project properties. I render as MPEG-2.

I tried your suggestion of using Mike Crash's smart deinterlacer in a 30p project and rendering as progressive but that wasn't making a difference in the sharpness of the image (I didn't try it with the text experiments). I wanted to revisit that deinterlacer later, so I moved on to the text aspect.
Laurence wrote on 10/7/2009, 10:06 AM
The text should not be going through any sort of deinterlace filter. It should just be rendering out at the target resolution. For example, if you render an HD 1440x1080i version, load that into a new Vegas timeline, and downrez that to DVD resolution, your text won't be nearly as sharp as if you rendered the SD mpeg directly from the original timeline.