BUG: Build 370 cannot load .MP4 AVC if "enable legacy AVC decoding"

RedRob-CandlelightProdctns wrote on 3/22/2023, 8:40 PM

Just tried loading an AVC (.mp4) file into my timeline to edit.. Vegas Build 370 won't accept the file when "enable legacy AVC decoding" is checked.



It loads OK if "enable legacy AVC decoding" is unchecked.

Vegas 21.300

My PC (for finishing):

Cyperpower PC Intel Core i7-7700K CPU @ 4.2GHz, 64GB mem @ 2133MHz RAM, AMD Radeon RX470 (4GB dedicated) with driver recommended by Vegas Updater (reports as 30.0.15021.11005 dated 4/28/22), and Intel HD Graphics 630 driver version 31.0.101.2112 dated 7/21/22 w/16GB shared memory. Windows 10 Pro 64bit version 10.0.19045 Build 19045.

My main editing laptop:

Dell G15 Special Edition 5521, Bios 1.12 9/13/22, Windows 11 22H2 (10.0.22621)

12th Gen Intel Core i7-12700H (14 cores, 20 logical processors), 32 GB DDR5 4800MHz RAM, Intel Iris Xe Graphics, NVIDIA GeForce RTX 3070 Ti Laptop GPU w/8GB GDDR6 RAM, Realtek Audio

 

 

Comments

fr0sty wrote on 3/22/2023, 11:46 PM

Then uncheck it. You don't want to use the legacy decoder when possible.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

RedRob-CandlelightProdctns wrote on 3/23/2023, 12:09 AM

I'd love to leave it unchecked, and will try doing so again.. until I can't.

On both my new Dell laptop and my 3YO desktop, the only way we can get through stable editing these past few jobs is with it checked -- otherwise we were getting crashes every 5-10 minutes, significantly hampering our productivity and causing hair loss in the process ;-) Kidding aside, constant crashing makes ppl want to leave the platform, so the relief from checking the box and avoiding crashes -- was needed. And we're not alone.. other users reported similar.

Last changed by RedRob-CandlelightProdctns on 3/23/2023, 12:10 AM, changed a total of 1 times.

Vegas 21.300

My PC (for finishing):

Cyperpower PC Intel Core i7-7700K CPU @ 4.2GHz, 64GB mem @ 2133MHz RAM, AMD Radeon RX470 (4GB dedicated) with driver recommended by Vegas Updater (reports as 30.0.15021.11005 dated 4/28/22), and Intel HD Graphics 630 driver version 31.0.101.2112 dated 7/21/22 w/16GB shared memory. Windows 10 Pro 64bit version 10.0.19045 Build 19045.

My main editing laptop:

Dell G15 Special Edition 5521, Bios 1.12 9/13/22, Windows 11 22H2 (10.0.22621)

12th Gen Intel Core i7-12700H (14 cores, 20 logical processors), 32 GB DDR5 4800MHz RAM, Intel Iris Xe Graphics, NVIDIA GeForce RTX 3070 Ti Laptop GPU w/8GB GDDR6 RAM, Realtek Audio

 

 

Former user wrote on 3/23/2023, 3:49 AM

I'd love to leave it unchecked, and will try doing so again.. until I can't.

On both my new Dell laptop and my 3YO desktop, the only way we can get through stable editing these past few jobs is with it checked -- otherwise we were getting crashes every 5-10 minutes,

The AVC file that you can't load with b370 using legacy decoder you could load with b326 using legacy decoder?

There's a number of AVC camera files that can't be loaded by legacy decoder because it doesn't know about more modern codecs. The main crashing problem was the use of hardware decoding on Vegas, you can use the new decoder without using hardware decoding by selecting 'hardware decoder to use' to off. You still had this crashing every 5-10mins with vp20b326 when using hardware decoder?

In my limited testing a while ago, I noticed legacy decoder was more efficient (CPU wise) than new decoder when not using hardware decoder, that is more of a problem for your Core i7-7700K, but shouldn't be noticeable on your i7-12700H

The reason I don't use hardware decoding (where possible) is due to timeline performance, it lags more on edit points with GPU decoder on, this problem has existed since VP15

RedRob-CandlelightProdctns wrote on 3/26/2023, 12:37 AM

I'd love to leave it unchecked, and will try doing so again.. until I can't.

On both my new Dell laptop and my 3YO desktop, the only way we can get through stable editing these past few jobs is with it checked -- otherwise we were getting crashes every 5-10 minutes,

<...snip...> The main crashing problem was the use of hardware decoding on Vegas, you can use the new decoder without using hardware decoding by selecting 'hardware decoder to use' to off. You still had this crashing every 5-10mins with vp20b326 when using hardware decoder?

Yes. Both 326 and the latest build -- I just tried on a new project I'm finishing up.

If hardware decoding is set to "off" (not choosing any GPU) it still crashes often.. very unproductive. Checking "use legacy decoder" and it's solid/reliable. Note I also did enable video acceleration on the "video" tab and things are going smoothly -- as long as "legacy decoder" is checked.

I understand you're saying that not using legacy and setting it to "none", you'd think, would make for stable editing, but it doesn't for us here.

Vegas 21.300

My PC (for finishing):

Cyperpower PC Intel Core i7-7700K CPU @ 4.2GHz, 64GB mem @ 2133MHz RAM, AMD Radeon RX470 (4GB dedicated) with driver recommended by Vegas Updater (reports as 30.0.15021.11005 dated 4/28/22), and Intel HD Graphics 630 driver version 31.0.101.2112 dated 7/21/22 w/16GB shared memory. Windows 10 Pro 64bit version 10.0.19045 Build 19045.

My main editing laptop:

Dell G15 Special Edition 5521, Bios 1.12 9/13/22, Windows 11 22H2 (10.0.22621)

12th Gen Intel Core i7-12700H (14 cores, 20 logical processors), 32 GB DDR5 4800MHz RAM, Intel Iris Xe Graphics, NVIDIA GeForce RTX 3070 Ti Laptop GPU w/8GB GDDR6 RAM, Realtek Audio

 

 

RedRob-CandlelightProdctns wrote on 3/26/2023, 2:26 PM

Worth noting -- setting "use legacy decoder" and setting the decoder to "None" aren't doing exactly the same thing.

Why do I say that?

When you enable the Legacy Decoder, Vegas rebuilds all the audio peaks. If you disable it, it will rebuild them again. It doesn't do that when simply setting decoder to "None".

So there's still some different processing being done under the hood regardless of if the hardware decoder is set to "none". There's a bug in there somewhere which causes instability on both my laptop and desktop, and as reported here, some other users are experiencing too.

Vegas 21.300

My PC (for finishing):

Cyperpower PC Intel Core i7-7700K CPU @ 4.2GHz, 64GB mem @ 2133MHz RAM, AMD Radeon RX470 (4GB dedicated) with driver recommended by Vegas Updater (reports as 30.0.15021.11005 dated 4/28/22), and Intel HD Graphics 630 driver version 31.0.101.2112 dated 7/21/22 w/16GB shared memory. Windows 10 Pro 64bit version 10.0.19045 Build 19045.

My main editing laptop:

Dell G15 Special Edition 5521, Bios 1.12 9/13/22, Windows 11 22H2 (10.0.22621)

12th Gen Intel Core i7-12700H (14 cores, 20 logical processors), 32 GB DDR5 4800MHz RAM, Intel Iris Xe Graphics, NVIDIA GeForce RTX 3070 Ti Laptop GPU w/8GB GDDR6 RAM, Realtek Audio

 

 

RogerS wrote on 3/26/2023, 8:49 PM

They aren't the same thing. One is the legacy decoder (compoundplug) and the other is the modern one (so4compound) with GPU decoding disabled.

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with latest driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (latest available driver), dual internal SSD (1TB; 1TB), Windows 10 64 bit

VEGAS Pro 19.651
VEGAS Pro 20.411
VEGAS Pro 21.208

Try the
VEGAS 4K "sample project" benchmark: https://forms.gle/ypyrrbUghEiaf2aC7
VEGAS Pro 20 "Ad" benchmark: https://forms.gle/eErJTR87K2bbJc4Q7