[bug] Vegas 20 - freeze when undoing Melda plug-in (and more)

Foo-Bar wrote on 2/14/2023, 5:28 AM

Not sure if this is the right topic, so excuse me if not.

I just bought Vegas Pro 20 (after working on the same large project for years in Vegas Pro 17 / 18 and 19).

But I discovered that "undoing" any action in a Melda plug-in does freeze Vegas totally.

I use some paid plug-ins from https://www.meldaproduction.com/MFreeFXBundle

For example, I setup the Mequalizer with a simple adjustment, try to "undo" it and Vegas freezes totally.

This happens in all three most recent builds of Vegas Pro 20 and with both the VST2 and VST3 plug-in from Melda.

I have been working on the same project with the same plugins for years now (it's a large and complex project) and Vegas 17 / 18 / 19 did not freeze at all.

So now I have bought Vegas 20, but I can't use it because undoing anything from the Melda plug-ins freeze up the program.

It can be a "Melda problem" but on the other hand everything works fine in Vegas 16 / 19, so it's maybe a "Vegas issue" as well (since it's related to the "undo" option).

Of course I can provide more information, when needed, but it looks like it can't pass the undo queue.

In Vegas 19 sometimes a "Melda action" couldn't be undone and other could be.

So the ones that couldn't be undo, where simply skipped.

Maybe now Vegas 20 is trying to undo an action that can't be undone, because it's outside it's scope?


When I change a simple thing in Melda, let's say adjusting the output from 10 to 11dB the following happens;

- Vegas 19 does not "record" (save / stack) this action, so you can't undo it (besides that, everything works fine)

- Vegas 20 does "record" (save / stack) more than 200 "undo states" for this single action.

It looks like it's not "undoing" 10 to 11, but 10.00 to 10.01 to 10.02 to 10.03, etc... until it reaches 11.00

And when trying to undo this (in Vegas) undoable thing, the whole software freezes.

So it has definitely something to do with the "undo stack" or how it is called.


Besides the undo stack overflowing, another thing is interesting.

When you make a change in a plug-in and than hide the plug-in window (or switch to another plug-in, even a Melda one), you can undo the complete list of undo's without freezing.

But once you make the plug-in you want to undo visual (seeing what happens in the plug-in GUI), the software freezes direct.

So it looks like a software / GPU (driver) / plug-in combination?

When I use the internal undo from Melda itself, everything works fine.

But when Vegas stumbles upon a Melda undo-history-state (and tries to undo it) the whole software freezes.


In Vegas 19 when using an enveloppe to automate an FX from Melda (let's say bringing the EQ from 9.5 to 9.25) it slows down the complete timeline. Stuttering, verrrrrrrrrrrryyyyyyyyyyyy sssssslllllllooooooooowwwwwwww audio, etc... even when the slope is about 1 second, it takes 10 second to pppplllllaaayyyyyyyyy;


In Vegas 20 it's superfluid! So thing did change for good, but also for worse.


I discovered that the RX plugins also overflow / flood the undo history.

When I change one single parameter (let's say from 4 to 3) the history has 25 undo's for it (4.75, 4.73, 4.31, 4.30, etc...).

It doesn't freeze like Melda, but it's something that shouldn't occur;



I've another bug and that's when you click on the plugins in the plugin chain (to turn them off / on or just to see what their parameters are) the order is messed up.

So plugin A - B - C will become A - C - B sometimes (both VST2 and VST3).

This bug does not occur when you right click on a plugin in the tab view and "select" it, only when you left click and "select it direct".

Also sometimes a plugin is not "checked" but the GUI (right click) says "checked / selected".

Hard to say, but this is a complete mess-up for professional use.


The redraw of an plugin is also terrible slow when you jump from plugin A to B.

Sometimes it takes more than a second or two and the whole screen flickers like hell.

In Vegas 19 it's almost instant, but Vegas 20 redraws the canvas sssssssllllloooooooowwwwwwwww.


Another bug.

When I change something using a knob (from Melda or RX plugin) the system almost stops being responsive.

Let's say change a parameter from 1 to 0.

When I check the undo-stack, it has almost 750 undo-states recorded.

Maybe my system is not top-notch (12gen Intel, Samsung PRO ssd's, 64GB ram), but it can not even handle those undo's.

I am a Vegas user since 2008, so I do know something about it.

Up to 2013 you could hit the internal prefs and set "create undos for fx parameter changes" to false.

It's now part of the default prefs and DOES resolve some problems, but under the hood they are still there.


Installed Vegas 17, just to compare things.

17 is so extreme superfluid, compared to 19 and 20.

The GUI of the plugins is instant, changes are very responsive, undo is "like it should be" (one action / one undo).

Knobs, parameters, Bezier curves for the enveloppes... I was totally forgotten how fast, smooth and quick Vegas could be.

What went wrong after 17?

I also checked the data-folder for Vegas 19 and 20, and it's loaded with error reports; thousands of them, for just the last 48 hours of testing from my side?


iEmby wrote on 2/15/2023, 9:51 AM

undo cause of lag vegas is very old issue bro.. still not completely fixed.



Operating System: Windows 11 Pro 64-bit (Always Updated)
System Manufacturer: ASUS
BIOS: 1402 (type: UEFI)
12th Gen Intel(R) Core(TM) i7-12700 (20 CPUs), ~2.1GHz - 4.90GHz
Memory: 16384MB RAM
Available OS Memory: 16126MB RAM
Page File: 11134MB used, 7934MB Available
DirectX Version: DirectX 12




Intel® H610 (LGA 1700)
Ready for 12th Gen Intel® Processors
Micro-ATX Motherboard with DDR4
Realtek 1 Gb Ethernet
PCH Heatsink
PCIe 4.0 | M.2 slot (32Gbps) 
HDMI® | D-Sub | USB 3.2 Gen 1 ports
SATA 6 Gbps | COM header
LPT header | TPM header
Luminous Anti-Moisture Coating
5X Protection III
(Multiple Hardware Safeguards
For all-round protection)


Card name: Radeon RX 560 Series
Manufacturer: Advanced Micro Devices, Inc.
Chip type: AMD Radeon Graphics Processor
Display Memory: 12241 MB
Dedicated Memory: 4076 MB
Shared Memory: 8164 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)

HDR Support: Not Supported



Intel UHD Graphics 770



Monitor Name: Generic PnP Monitor
Monitor Model: HP 22es
Monitor Id: HWP331B
Native Mode: 1920 x 1080(p) (60.000Hz)
Output Type: HDMI



Drive: C:
Free Space: 182.3 GB
Total Space: 253.9 GB
File System: NTFS
Model: WD Blue SN570 1TB (NVMe)


jetdv wrote on 2/15/2023, 10:16 AM

It appears that "Melda" (which I originally though was a typo for "media") are audio plugins?

VEGAS Pro 20 added support for VST3. Which version are you using in VEGAS Pro 20?

Foo-Bar wrote on 2/15/2023, 11:08 AM

undo cause of lag vegas is very old issue bro.. still not completely fixed.


I've got an temporary fix for the issue.

The situation under Vegas V20 together with Melda / RX is so extreme bad that it totally freezes the software once you do an "undo" in the third party plugin queue / stack.

The thing is that every freaking handle is recorded and pushed in the stack.

Changing a knob from 1dB to 1.1dB records almost 125 undo actions!

It's not like "state #1 - 1dB / state #2 - 1.1dB", it's like "1.0dB, 1.01dB, 1.02dB, 1.03 dB, etc... until it reaches 1.1dB".

When I change a dB setting, an enveloppe and some finetuning with and EQ, Vegas records thousands of undo's, fired by both Melda and RX (maybe others, I don't use them).

Solution : turn of the "undo state triggered by plugin parameters" in the options.

This is default available in "options" or (older Vegas) in "internal options".

Downside : the native plugins don't record undo's as well.

But both Melda and RX do have there own, internal undo mechanism - so you can still use those (which are better than Vegas history handling, btw).

Besides crashing the complete DAW, the extreme history state also makes the GUI for Melda totally unusable;

When you drag an EQ point from X to Z, also every pixel of the mouse is recorded as an undo state, which freezes the complete GUI.

My system is not top notch (Intel 12th gen, 64Gb RAM, Samsung PRO 980 SSD's, etc...) but it can not handle those undo's both technically and GUI-wise.

Undo - disable - Vegas

Undo - enable - Melda

Undo - enable - RX

Foo-Bar wrote on 2/15/2023, 11:10 AM

It appears that "Melda" (which I originally though was a typo for "media") are audio plugins?

VEGAS Pro 20 added support for VST3. Which version are you using in VEGAS Pro 20?

Nope, it's a plugin company - pretty awesome and useful for all the DAW's in the world.


Vegas 20 freezes with all plugins from Melda (VST2 VST3 32bit 64bit).

Even one single plugin with one undo does crash the system.

I don't like plugins, and external plugins even less, but Melda (and RX) are outsiders.

Quick, fast, useful, consistence, regular updates, quality, low latency, very transparent.

You can try the free package from Melda, to see how they work / how the plugins work.


(and you can pay whatever you want, just to say "thank you" afterwards).

So it's pretty bad that Vegas 20 totally freezes, where even Vegas 17 (and other NLE) are smooth as boiled butter under the Sahara sun.

RogerS wrote on 2/15/2023, 6:31 PM

Thanks for reporting that. Vegas has a new VST engine so hopefully this can be fixed.

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (driver, dual internal SSD (256GB; 1TB), Windows 10 64 bit

Vegas 19.648
Vegas 20.270

VEGAS 4K "sample project" benchmark: https://forms.gle/ypyrrbUghEiaf2aC7
VEGAS Pro 20 "Ad" benchmark: https://forms.gle/eErJTR87K2bbJc4Q7

Foo-Bar wrote on 2/16/2023, 4:46 AM

Thanks for reporting that. Vegas has a new VST engine so hopefully this can be fixed.

Could be the case.

It happens with both VST2 and VST3, and only since Vegas 20.

The re-ordening of the plug-in chain, by clicking on them (selecting, not dragging), is also very annoying because it also does influence the output of the signal.

When my plugin-chain is like;

  • EQ / Compressor / Noisefloor

It can become like this, when I click on "compressor" in the tabview (to open it);

  • Compressor / EQ / Noisefloor

So they switch places, which will, of course, effect the output.