Build 714 Crash w/ NewBlue Motion Effects

Kimberly wrote on 9/11/2013, 8:03 AM
Hello All:

Can someone with NewBlue Motion Effects test this ~

1. Enable your Nvidia GPU in Build 714.

2. Ensure your properties for NewBlue Motion Effects look like this:

3. Apply the MotionEffects to an event.

4. Attempt to preview the event.

For me this causes a crash during preview attempt; often it crashes when I apply the FX to the event. Opening projects with this FX also crashes during opening or seconds after opening.

I have several Video Essentials packs as well as Colorfast. These do not crash with or without the box checked. However some create weird jitters in render depending on how the box is set (see For this reason I tend to keep the box checked. (Also noticed that VE6 Picture Grid crashes if you have only one video track and apply this FX. That sort of makes sense because if you want a picture grid then you need more than one track, but it still probably shouldn't crash.)

Motion Effects seems fine when I turn the Vegas GPU off or run Vegas GPU with the Intel 4000 card.

I did not have this issue in Builds 670 or 486. I didn't specifically test for this, but I had Vegas GPU on and off all the time while messing around and didn't have any such crashes.




Grazie wrote on 9/11/2013, 8:30 AM
Ugh..... I've got NB motion effects. And when I'm able to I'll do what your asking. Give me 3 hours?

Oh dear....


CJB wrote on 9/11/2013, 8:52 AM
I applied an Earthquake from Motion Effects. Previews just fine with full GPU. I have an NVidia GeForce GTX 550 ti
Kimberly wrote on 9/11/2013, 9:55 AM
Hey Chris:

Just to confirm, what was the status of your checkbox thingy on your Motion Effects?
ritsmer wrote on 9/11/2013, 10:43 AM
Did exactly as You said and showed in the Dropbox screenshot - ¨
Result: when I pressed the play-button I immediately got a Vegas Stopped Working.
I let it send full info to SCS and in the text I included the address of this thread.

Then I restarted Vegas and reloaded the same project - and before I touched anything: Vegas Stopped Working.
I let it send full info again.

Actually I use NB ME often - without any problems as I always disable anything even remotely looking like GPU "acceleration" :- )

Edit: just to be sure I repeated step 2 - and immediately got a VSW again.

Edit2: Opened Vegas and disabled Vegas's GPU "acceleration" - and now I can open the .veg with the NB ME media

Edit3: And now I have disabled GPU for all NB products - and feel on safe ground again.
Grazie wrote on 9/11/2013, 10:48 AM
Repro Kimbo.

But, why would I want to do this? Why would I elect to have GPU in M.E. OFF when in VP12 it is set ON? I think I'd have a mental crash over that one -? Or am I missing an obvious issue here?



ritsmer wrote on 9/11/2013, 11:01 AM
Graham: Kimberly is a Certified Auditor.

I use one in my company too - and it is always reassuring how these people sense and identify problems before they become issues for me.

So: this is some good input for R&D at NB and/or SCS - and correcting this issue might prevent more severe/hidden issues in the future.
ECB wrote on 9/11/2013, 11:53 AM
I checked Disable GPU for this product (NewBlue Motion Effects) I applied Earthquake from Motion Effects. Vegas Stopped working screen posted. I have a Quadro 4000. To recover I launched Vegas Pro 11 and turned the NB GPU on.

Ed B
Kimberly wrote on 9/11/2013, 12:31 PM
Hey Grazie:

Yeah seems odd that you might want this on/off, but I was getting jitteries as a result of this switch in one of my other projects and, as I recall, I had the "disable all" thingy selected so it was disabled by default.

Oh and the word "thingy" is bona fine auditor language : )

videoITguy wrote on 9/11/2013, 12:47 PM
I hope you all recall that NewBlue GPU products are designed to pull differently on code than how SCS products have been designed thus far. THerefore, when you run them concurrently on the single timeline there are bound to be some conflicts. In past versions and builds of Vpro12 this was alleviated by choosing a compromise in the video driver to settle the effects down a bit.

Are we establishing that build 710/714 has seriously changed the dynamic?
Grazie wrote on 9/11/2013, 12:56 PM
Kimberly thank you for why this switch may/might be there. I can only think that it is a fail-safe for those tiptoeing through this new dawn of using GPU and 3rd Party-Plugs.

In which case I like this from videoITguy: "Are we establishing that build 710/714 has seriously changed the dynamic?" this could very well be a nod towards this happening - or not.

Ritsmer I think I understand your wish to "frame" the expertise on this Forum and I shall read your future input with not a little scrutiny.

Grazie wrote on 9/11/2013, 1:54 PM
What I'm also doing is take advantage of the Updates from NB! So far I've got through 2 of 'em!


NormanPCN wrote on 9/11/2013, 2:28 PM
Works fine for me for what it's worth. Any combination of Vegas GPU on/off and NB GPU on/off.

However, I have an AMD GPU setup.
ritsmer wrote on 9/11/2013, 2:52 PM
Ritsmer I think I understand your wish to "frame" the expertise ??

If your use of "frame" is not positively meant - then - it was not so.

I think that I wrote that it is helpful when some people have the skills to sense and target problems earlier than other people - and that this is very reassuring for the rest of us to have them around - as this helps improving the systems we are using.
Grazie wrote on 9/11/2013, 3:07 PM
Ritsmer I can't tell you how much I agree with you.



jetdv wrote on 9/11/2013, 3:32 PM
1. Why did you turn off GPU in Motion Effects? Does the same thing happen with GPU turned on?

2. Was this working fine in the previous build of Vegas? (sounds like it was)

3. Which effect in Motion Effects are you using? Or does it matter? Does it matter if you pick a different preset?
Kimberly wrote on 9/11/2013, 4:38 PM
Hey Edward:

[I]1. Why did you turn off GPU in Motion Effects? Does the same thing happen with GPU turned on?[/I]

I had Motion Effects applied to some generated media in a project created in Build 486 that I successfully edited in Build 670. It was the first time I'd used Motion Effects (bought during "Awesome August") so the GPU settings probably were whatever default GPU settings came with the OpenFX installation . . . which I assume were "Disable GPU."

I don't recall changing the settings, but I may have. As I mentioned in my above post, I had a case of the jitters with GPU enabled for certain other NewBlue Effects ( Disabling the GPU for that particular effect cured my problem, so it is possible that I unchecked the GPU on Motion Effects just to see what would happen in Build 486 or Build 670 (when I test new software I always fiddle with all the settings to see what happens). So it's possible I changed this and left GPU disabled in Build 486 or 670.

I became aware of the problem when I updated to Build 714 and tried to open my project. The crash report included a lot of mumbo-jumbo, but Motion Effects jumped out as one of the causes. Thus I was able to go back to Vegas and isolate the behavior.

[I]2. Was this working fine in the previous build of Vegas? (sounds like it was)[/I]

Yes, I believe it was. I can roll back to Builds 486 and 670 if necessary to confirm this.

[I]3.[/I] Which effect in Motion Effects are you using? Or does it matter? Does it matter if you pick a different preset?

I have tried several presets and they all crash when the GPU is disabled.

Thanks for getting involved on this Edward -- we always appreciate your help : )

I don't see this as a NewBlue issue just now because everything seemed to be working fine before the Build 714 update. I was planning to write to NewBlue customer support if it looked like I was the Lone Ranger on this one. Seems like SCS might be able to isolate what was changed in Build 714 before NewBlue does a bunch of work on this.


Kimberly wrote on 9/11/2013, 5:47 PM

This issue did not exist for me in VP 11 Build 701.

It did exist in VP 12 Build 670. I was unable to rollback to Build 486.

VP 12 (both builds) does not crash when preview is set to Draft-Auto or Draft-Quarter. But it does crash when the preview is set to anything else. I tried unchecking the "Optimize GPU Preview" box in the Options/Preferences/Display tab but this made no difference.
CJB wrote on 9/11/2013, 8:50 PM
sorry, I goofed. I had both boxes unchecked and it worked fine. (with GPU enabled in Sony VEGAS preferences).

After further checking if NewBlue GPU is disabled while Sony Vegas GPU is enabled it fails.

If both are disabled it works

If both are enabled it works.
Kimberly wrote on 9/11/2013, 9:11 PM
[I]If both are disabled it works
If both are enabled it works.[/I]

Excellent find!
videoITguy wrote on 9/11/2013, 9:11 PM
dancerchris and Kimberly - specify your video card (s) - whether you are using more than one card concurrently to enable an output to a preview window - and what your respective video card software driver(s) version (are... )
Kimberly wrote on 9/11/2013, 9:19 PM
Dell XPS Laptop. No external monitor.

NVIDIA GeForce GT 640M
Driver 311.51

Intel HD Graphics 4000

I also noticed if I set the Nvidia Control Panel settings to "Integrated Graphics" then I don't get a crash even when Vegas 12 Options/Preferences/Video is set to Nvidia for the GPU acceleration of video processing.

I could leave the Integrated Graphics on as shown in the above picture, but then I cannot use NewBlue Titler Pro 1, which is stable on my system.

I can certainly use a few workarounds to get where I need to go. I'm sure a fix will come out at some point from SCS or NewBlue or both . . .


CJB wrote on 9/12/2013, 12:07 AM
Asus GeForce GTX 550 ti driver 314.22
videoITguy wrote on 9/12/2013, 10:01 AM
Thanks to you both for posting your specs, appears to be widely different EXCEPT, I note, although the selected driver versions are very close and may in fact be the same in this particular aspect of the working causes.
Adam QA SCS wrote on 9/16/2013, 10:44 AM

I am a new QA Tester for SCS. As part of my job I look through the forums to see if I can help people and or see if people have issues that I can add to our database for the engineers to look at.

I have added this issue to our database for consideration of being fixed in a future release.