Can't import DVD from Sony External DVD unit.

Roboburger wrote on 8/11/2008, 1:40 PM
I swear I did this before.

I used a Sony Consumer Component DVD recorder to record video from a ordinary camcorder and the audio from my club's soundboard. The finalized disc plays fine on my crappy dvd player here at home, and it plays fine on my laptop.

But when using "Import...DVD Camcorder Disc" in Vegas 6 (build 210d), it moves along without error and does the following: Asks me Source and Destination as normal, and then an operation window pops up as normal and starts calculating remaining time. But then about four seconds into it, it says Complete, with nothing added to my project.

This disc does have two tracks on it- I hit record and captured 10 seconds of empty dark stage for use in the DVD menu. the content that I really need is the second track. But i swear this wasn't a problem before...

I'm about ready to put it back into the Sony DVD recorder and iLink it to my laptop together and capture it again in real time!

Any ideas on what setting is wrong? I just reinstalled everything onto this laptop after buying a nice new huge hard drive for this laptop. I could understand if I just didn't tweak something right.


UlfLaursen wrote on 8/11/2008, 11:16 PM

Have you remembered to finalize the disc in the recorder - I miss that once i a while myself :-).

I have done this several times, from a Sony DVD recorder and into my Vegas, but only Vegas 7 or 8 - good result every time.

Roboburger wrote on 8/12/2008, 2:12 PM
I'm gonna give that a go- I remember doing it, but maybe I didn't hit 'Enter'!
Roboburger wrote on 8/13/2008, 11:15 AM
Well, it was finalized. I'm trying an external program to rip the DVD into an AVI file. that sucks that I can't do it in Vegas in this case.

I'm gonna try some other DVDs from the club.
Roboburger wrote on 8/15/2008, 9:28 AM
So dig this: I just learned that .VOB files are just Mpeg2 files. I just used Windows Explorer to copy the DVD data to my folder, and then used the Rename function to change .VOB files to .MPG files, and vegas works with them just fine.