can't install vegas 13 - failed to register module

gwailo wrote on 5/1/2014, 5:35 PM
I'm getting this message:

ERROR: -2147163964 occurred during installation
Module C:\Program Files\Sony\Vegas Pro 13.0\x86\sfvstproxystubx86.dll failed to register.
HRESULT -2147024703. Contact your support personnel.

I've already tried uninstalling / reinstalling all my c++ redistributables

It just gets to the registering modules portion of the installer - then immediately jumps into a message saying rolling back and then I get the error above.

I've stopped my anti-virus and even uninstalled it
I've also tried run as administrator

Any ideas?

Comments

ChrisDolan (SCS) wrote on 5/2/2014, 11:08 AM
gwailo,
I forwarded this message to our installer programmer and he says the following. With your permission, I'll get your email address from ForumAdmin and follow up with you offline, OK?

"Can you contact him to collect his logfiles? This what I need:

1) Enable MSI logging:

In the registry create the key:

Key (folder): HKLM\Software\Policies\Microsoft\Windows\Installer
REG_SZ Name: Logging
REG_SZ Value: voicewarmupx

the "voicewarmup" part is actually all the command line flags in one row: (v)erbose (o)utofspace (i) status messages, etc. See link for more info: http://support.microsoft.com/kb/223300

2) Reboot
3) Run installer and let it fail
4) Collect our install log from C:\Users\<username>\AppData\Roaming\Sony
5) Collect the TWO most recent MSI logs from C:\Users\<username>\AppData\Local\Temp. They will have names like MSI?????.LOG where the ?'s are random letters and numbers.

6) Mail the 3 files to me.

This should give me everything I need to solve his issue."
gwailo wrote on 5/2/2014, 1:22 PM
Wow, I like the new Sony

Yes you can get my email address from the forumadmin

I have the 3 files collected and ready to send.

I found 1 other person suffering from the same problem in the Creative Cow forums.
ryclark wrote on 5/3/2014, 11:53 AM
And yet another one. Sony install log sent to customer support two weeks ago and no useful answer back yet apart from pointing me at useless bits of the Knowledge base. Not a happy bunny. :(
ryclark wrote on 5/14/2014, 11:48 AM
Almost another two weeks on and still no response from Sony Customer Service. Has anyone yet had a resolution to this problem? I would like to be able to install my software upgrade and use it after having owned it for almost a month.
ryclark wrote on 5/27/2014, 10:43 AM
Anyone had a satisfactory resolution to this problem yet? I am still going backwards and forwards with Customer Service after over a month without being able to install Vegas 13. If only one could stop the installation rolling back then one might be able to better diagnose the problem with the errant module!
ChrisDolan (SCS) wrote on 5/27/2014, 4:06 PM
One of our engineers has been working directly with user gwailo. So far, we haven't been able to reproduce it at SCS and when we got detailed install logs, the results have been pretty perplexing. We'll continue working on it and will definitely post here when we figure out a solution.
Matt_Iserman wrote on 5/31/2014, 9:29 AM
Add another user with the same install issue... The problem occurs when trying to install Vegas and Sound Forge. DVD Architect installed without issue.
Steve_Rhoden wrote on 5/31/2014, 10:06 AM
Gentlemen, You have something installed on your system that is conflicting with your Vegas installations!
Or your system or Registry is corrupted in some ways!
ryclark wrote on 6/11/2014, 12:47 PM
Still awaiting a solution to this problem. The last suggestion from the Support team was to try uninstalling GoPro Studio. But I am still unable to install the VP 13 upgrade after 8 weeks of trying. :(
Matt_Iserman wrote on 6/11/2014, 9:11 PM
Here is the latest response I received...

Hi Matt,

Thank you for writing back. I found this issue reported in our Development system, and our engineers confirmed that you are receiving that error because one of two things may be occurring:

1. There is a corrupt or otherwise broken registry

2. There is a virus or other permissions limiting software running.

It is recommended that you take your machine into a technician, or a reinstall/recovery of the OS may be a fix as well.

If you still have a follow-up question on this particular incident, please feel free to update it. If you have a completely different question, please create a new incident.

Sincerely,

Travis G.
Customer Service


Sony's software is the only software not installing correctly. Requiring me to pay for expensive technical support and/or completely re-installing the OS are not acceptable solutions.
Matt_Iserman wrote on 6/18/2014, 9:48 PM
ryclark,

Any updates? Sony has been unhelpful in my case. They insist the problem is with my computer. I say, since the only, ONLY software that will not install on my computer is theirs, maybe the problem is with their software.
Matt_Iserman wrote on 6/23/2014, 9:34 PM
Sony couldn't fix the issue and is in the process of issuing a refund. (They still say the problem was my computer.)
ryclark wrote on 6/27/2014, 5:38 AM
I have had a reply from Tech Support saying that there will be a fix in the next update. But, so far, no ETA.
ryclark wrote on 7/4/2014, 7:14 AM
At last I have managed to install Vegas Pro 13. :)

I had a problem with another program not booting due to a missing .dll problem. Cured both by doing a Repair Install of Microsoft Visual C++ 2012 Redistributable (x86) - 11.0.61030 and Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.61030
PierreAVS wrote on 7/5/2014, 4:14 AM
I had the same problem.

Your solution help me a lot. I managed to install to install Vegas Pro 13.0 too.

Thanks
ChrisDolan (SCS) wrote on 7/16/2014, 1:05 PM
ryclark,
Thanks very much for reporting success to this thread! This particular problem has consumed a lot of time for our installer team at SCS with not much to show for it. We had suspected C++ redist, but never could prove it because we've failed to get a machine into the bad state despite considerable effort.

If anyone else can try ryclark's solution and report back success or failure here, it would be very helpful to us.
Chris
Mike C wrote on 5/29/2015, 7:59 PM
I was running a prior version of Movie Studio Platinum and it wouldn't start up when I tried to run it yesterday. So I tried installing the latest version 934 64-bit and now I am getting the installation error reported above. I re-installed the two versions of MS 2012 libraries and that didn't fix the problem. Has Sony got a fix for this? I last used the software 4/6/15 to make a short video and it worked fine. I have an older version 10.0 but I really want to use version 13.0.

I tried re-installing version 879 and that has the same problem when it tries to register the sfvstproxystubx86.dll. The COM error that comes back is 800700C1. When I tried to hand register the DLL, it said it was incompatible with the 64-bit system.

I wish SONY would test their damn installation software before they distribute it!!!

Does anyone have a solution?

Thanks.

Mike

PS - I got it to install by copying a good version of sfvstproxystubx86.dll into the install directory. However, it gets some other kind of error when it starts up.
Leandre wrote on 10/19/2015, 12:29 PM
Same problem here. Solved by uninstalling VC++ redistribuable 2013 and installing VC++ resdistribuable 2012, then reinstalling Vegas. I also did the repair install on VC++ 2012 just in case.

LĂ©andre
forrest-smith wrote on 10/26/2017, 9:32 PM

I'm legit having this problem right now please help! I was having problems opening windows movie maker so I got this and now it won't open. I have movie studio 14. I've tried repairing and uninstalling and re stalling the c++ drivers.

Bruizeh wrote on 4/6/2018, 8:22 PM

Enable TrustedInstaller in your Services.msc a.k.a "Windows Modules Installer"

OpaxZity wrote on 4/10/2018, 1:41 PM

Okay, so I also have been having this exact same issue. It's actually only been a day, and I got it to work. Some of these steps might not even contribute to the fixing of the solution, but do them anyways in order, because I have done it.

1. I opened the installer, and I saw that it said ERROR: -2147163964 occurred during installation
Module C:\Program Files\Sony\Vegas Pro 13.0\x86\sfvstproxystubx86.dll failed to register.
HRESULT -2147024703. Contact your support personnel.

2. I first opened the uninstall thing in windows 10, which i found by typing "uninstall" in the windows search bar.

3. Then, do (windows + r) and type "services. msc " and find "Windows Modules Installer" (this is from Bruizeh's post above). Right click it and press start.

4. Found Windows visual c++2013 (there is 2 of these) and uninstalled them

5. Then, I clicked change for the 2 Windows visual c++ 2012 (x64 and x86) and clicked repair. the (x64) one will tell you to restart. Restart after youve repaired both.

6. Then, I right clicked the installer and "run as administrator" and it installed.

(I know alot of the above users said it, but it took a long time for me to see what I actually had to do, so this is for those who want)

I saw many other forums, but this method was the only one that worked for me. Hope this helps ;)

Dubious wrote on 12/1/2018, 11:32 AM

I had the same problem with Vegas Pro 14.0 on Windows 10 Pro 10 (sfvstproxystubx86.dll registration error). Thank you ryclark! I figured it was a Visual C++ thing since I've had problems with those after hard drive problems this year. I first only tried repairing the x64 before I saw the post and still had the problem. I then tried repair the x86 as well and I was able to install successfully.