Can't render FULLHD 50i footage with NV encoder in Vegas 16 Pro

Capeta wrote on 4/3/2019, 1:03 AM

Hi guys!

I have 1080_50i footage and I want to render it in 50i using NV Encoder setting field order upperfield (I noticed that it is the best quality) becasue I realized that it is so much faster rendering with GPU. After selecting Magix AVC Internet 1080p 25 FPS NV Encoder and setting upper field I get an error saying: An error occured while creating the media file... Error 0x80660008 (message missing). When setting it to progressive it renders but the motions are so blurry. Before that I render using SonyAVC settings but I can't find the option to use the GPU in that setting. Do you guys have any idea how to resolve it?

Comments

3POINT wrote on 4/3/2019, 2:24 AM

Strange, in VMS16, I'm able to change the NV Encoder setting to upperfield field order and render with it. Those renders play fine on my UHD-TV, but not on my PC.

I discover also on my edit PC more renderproblems with Vpro16 than with VMS16. Will check my NV 1080i renders possibility of Vpro16 later today.

I prefer always to render 1080i to 1080i instead of 1080p.

If you want less blurry 1080i to 1080p renders, than set in projectsettings deinterlace method from blend fields to interpolate fields or smart adaptive.

j-v wrote on 4/3/2019, 5:03 AM

@Capeta

Maybe you use the wrong name 50i?
25i here means 50 half interlaced frames, together 25 whole frames.

No problem with me, look

Last changed by j-v on 4/3/2019, 5:28 AM, changed a total of 1 times.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 16,17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 451.77 Studio Driver, desktop the Studio DHC driver
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Capeta wrote on 4/3/2019, 5:22 AM

Thanks for the replies! As soon as I get home I will post a video too! :)

Capeta wrote on 4/3/2019, 11:49 AM

Here it is when I get the error. Without overwrite it is the same.

j-v wrote on 4/3/2019, 12:17 PM

Strange.
Sadly we cannot know what the errror is.
We can try to see maybe differences between our set ups because as you could see with me no error.
Do you have the latest Vegas build 361?
Which kind of driver and which driverversion of the Nvidia GPU do you use?

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 16,17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 451.77 Studio Driver, desktop the Studio DHC driver
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Capeta wrote on 4/3/2019, 12:23 PM

I have Build 361, nVidia driver is 419.67

Here is a footage: https://1drv.ms/v/s!AuFI605A5gGDiatObbssZP6x62xdfw

Can you check it on your computer?

j-v wrote on 4/3/2019, 1:02 PM

I have Build 361, nVidia driver is 419.67

Can you check it on your computer?

I have the same Vegas build and the same driver version and I checked your file on my desktop ( the former video was on laptop installation) and this is my result, doing exactly ( I believe) the same things you did.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 16,17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 451.77 Studio Driver, desktop the Studio DHC driver
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

j-v wrote on 4/3/2019, 2:49 PM

Here is a footage: https://1drv.ms/v/s!AuFI605A5gGDiatObbssZP6x62xdfw

What I don't get are your used cam settings.
That footage of you comes from a Sony FDR-AX53 and you are shooting at AVC FHD 50i.
My advice would be at least to shoot at AVC FHD 50p you not need to alter that framerate while rendering, but if you wish it is possible to render to interlace with I think better quality than the other way around.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 16,17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 451.77 Studio Driver, desktop the Studio DHC driver
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Capeta wrote on 4/3/2019, 3:47 PM

It is strange that it works on your side. The reason I recorded in 50i is because I wanted to render so every TV device can playback it. If I shoot in 50p it can't be playbacked only on computer. And if I render 50p to 25p then in my opinion it is not as smooth as 50i. I already reinstalled Vegas, cleared cache. What codec pack do you use? Could it cause the problem? It is a new computer and a new install of Windows.

OldSmoke wrote on 4/3/2019, 3:55 PM

You are trying to render 25 frames upper first. It has to be 50frames interlaced, it’s also called 50i for that purpose.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

OldSmoke wrote on 4/3/2019, 3:56 PM

In your situation, I would record 50p, you may loose a stop or two depending on your camera but with 50p, you can render to 50i, 25p and anything else your heart desires without any loss.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

j-v wrote on 4/3/2019, 4:20 PM

It is strange that it works on your side.

Not strange, to me it looks normal as designed in Vegas 16

The reason I recorded in 50i is because I wanted to render so every TV device can playback it. If I shoot in 50p it can't be playbacked only on computer.

Only pretty old TV cannot play it.
Any flat TV of the last years plays FHD AVC 25p, those of the last 3 years also HEVC with higher framerates in progressive format.
The last 2 years I make for my own TV from signature only HEVC 50p mp4in UHD or FHD.

What codec pack do you use? Could it cause the problem?

Codec packs?
I deïnstalled them all I had, especially all the stuff and Titles of New Blue FX, what can I not do with Vegas Pro for all that I need?

It is a new computer and a new install of Windows

My both pieces of hardware are older than 2 years and on my upgraded desktop in 2016/17 I installed the Windows 10 upgrade with now the latest builds.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 16,17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 451.77 Studio Driver, desktop the Studio DHC driver
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

wwaag wrote on 4/4/2019, 12:25 AM

You might give Happy Otter Scripts a try at https://tools4vegas.com. Here's an Nvenc render using your footage.

You'll note that the render rate is about 5x real-time, that the rendered file is interlaced, upper-field-first, and that it plays OK using MediaPlayerClassic-Home Cinema.

The underlying app in HOS uses the latest Nvidia SDK and supports the latest Turing GPU. I use a 1050ti which uses the Pascal GPU and still the renders seem pretty quick to me.

Capeta wrote on 4/4/2019, 1:51 AM

Thank you guys for the answers, I'm really glad that you guys try to help me. It turned out that interlace rendering works on my older computer, so maybe something is wrong with the install of my Windows. However I am not satisfied with the results. https://1drv.ms/f/s!AuFI605A5gGDiatPzdClA8-E3Kb9Xw

Here you can find 3 videos. AVC is the setting I used for a long time but it takes so much time to render. I hoped that with NV Encoder I can help but look at the quality using NV Encoder. They are terrible. Is there some twist I might have missed?

3POINT wrote on 4/4/2019, 2:51 AM

Here you can find 3 videos. AVC is the setting I used for a long time but it takes so much time to render. I hoped that with NV Encoder I can help but look at the quality using NV Encoder. They are terrible. Is there some twist I might have missed?

For me the quality of the NV Encoder was always less, it gives a lot more blocky artifacts. The first video shows the interlacing, that's what I meant in my first comment that it doesn't play fine on a PC, but the video plays fine on my TV.

3POINT wrote on 4/4/2019, 2:57 AM

You might give Happy Otter Scripts a try at https://tools4vegas.com.

I did, unfortunately it didn't render at all, gives only an error message on my system.

wwaag wrote on 4/4/2019, 10:15 AM

@3POINT

"I did, unfortunately it didn't render at all, gives only an error message on my system."

Specifics? Type of error message? Did you upload a crash report? Any info would be appreciated.

fr0sty wrote on 4/4/2019, 10:16 AM

Capeta, even 1080i TVs will play a 1080p video, you do not have to downgrade your video quality for compatibility. Most video being fed into broadcasts at 1080i are starting as a 1080p source, if not 4k.

For this particular file, in the mean time, have you tried the adaptive GPU de-interlacing available in project settings? Go to file>project settings and look under deinterlace mode, try smart adaptive.

Last changed by fr0sty on 4/4/2019, 10:18 AM, changed a total of 1 times.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Radeon VII

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

Capeta wrote on 4/4/2019, 12:14 PM

Thank you guys again for the replies. I am getting closer to the conclusion.

Here you can find my footage from today: https://1drv.ms/f/s!AuFI605A5gGDiatTiC-iXimQpl70ew

I recorded in 50p and 50i and I named them as source then render.

For me, 50i to 50i rendering is still smoother but again it takes much more time.

You may ask why just not render 50p to 50p? Well for example my Samsung Smart LED TV from 2013 can't play videos above 30 frame and it can happen to people too who might want to play their videos. That's why I stick to 50i for a long time.

OldSmoke wrote on 4/4/2019, 1:22 PM

@Capeta do you have a link to the original 50p footage too? I have done 60p to 60i renders countless times and it turns out as good as original 60i footage, as it should.

Last changed by OldSmoke on 4/4/2019, 1:22 PM, changed a total of 1 times.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

Capeta wrote on 4/4/2019, 1:35 PM

@Capeta do you have a link to the original 50p footage too? I have done 60p to 60i renders countless times and it turns out as good as original 60i footage, as it should.

There you go: https://1drv.ms/f/s!AuFI605A5gGDiatXU7wtvY1tCvWOjg

3POINT wrote on 4/4/2019, 2:16 PM

@3POINT

"I did, unfortunately it didn't render at all, gives only an error message on my system."

Specifics? Type of error message? Did you upload a crash report? Any info would be appreciated.

@wwaag I will come back to this, after next week, when I'm back from holiday (leaving tonight) and have more time to investigate.

OldSmoke wrote on 4/4/2019, 4:11 PM

@Capeta do you have a link to the original 50p footage too? I have done 60p to 60i renders countless times and it turns out as good as original 60i footage, as it should.

There you go: https://1drv.ms/f/s!AuFI605A5gGDiatXU7wtvY1tCvWOjg

Thank! I will give that a try. Keep in mind that watching 50i on a computer monitor doesn't look good, you have to watch it on a TV and judge the quality/smoothness.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)