Cannot get VLC Player to speak to my speakers

PeterWright wrote on 6/16/2016, 3:31 AM
You know how in Vegas, under Audio Device, you can select from available devices?

VLC Player also has a menu item called Audio Device, but it doesn't produce a list of devices.

On one of my PCs I have a Steinberg UR22 USB audio interface, and Vegas finds it and uses it perfectly.

When however I try and play a CD or audio file in VLC player, there is a deafening silence.

Does anyone know how I tell it to use the USB, to which my loudspeakers are attached?

Thanks for any help.


Steve Grisetti wrote on 6/16/2016, 7:07 AM
VLC will use it if is it is set up in your Windows/Sound control panel as the default audio.
musicvid10 wrote on 6/16/2016, 8:51 AM
Your particular computer or laptop may be designed not to do this; MS put a lot of pressure on manufacturers in the 2000s to block D->D audio transfers. Just an unsubstantiated guess, if I read your question correctly.

DrLumen wrote on 6/16/2016, 10:37 AM
I would second the checking of the Windows Sound control panel settings. I too have an external USB audio interface. It works fine with VLC audio once I set the default.

intel i-4790k / Asus Z97 Pro / 32GB Crucial RAM / Nvidia GTX 560Ti / 500GB Samsung SSD / 256 GB Samsung SSD / 2-WDC 4TB Black HDD's / 2-WDC 1TB HDD's / 2-HP 23" Monitors / Various MIDI gear, controllers and audio interfaces

PeterWright wrote on 6/16/2016, 7:48 PM
Thanks for the ideas.

I've been to Device Manager and three items appear under Sound video and games controllers:
AMD ~~~~~~~
Realtek ~~~~~~
Steinberg UR22

I can't find anywhere to nominate the Default Device, so I Disabled the AMD and Realtek - still no joy.

There may be a few more clues -

If I try and play a WAV or mp3 file in WMP, I get:

"WMP cannot play this file. The Player might not support the file type or might not support the codec that was used to compress the file."

The WAV is a standard CD file,

VLC Player appears to be playing it, but no sound comes out.

Vegas plays everything fine through the Steinberg UR22.

The PC is a few months old - possibly it's always been like this - I generally only use it for Vegas.

Any more ideas?

ddm wrote on 6/16/2016, 7:56 PM
You want to go to Control Panel/Sound... there you should see your listed devices and a big ol button to "Set Default"
PeterWright wrote on 6/16/2016, 10:45 PM
Thanks ddm - I just did that, and found that the UR22 already has the green tick as Default Device.

Neither WMP, VLC Player nor "W10 "Groove Music" will play an audio file or CD, yet they all play perfectly in Vegas.
PeterWright wrote on 6/16/2016, 11:59 PM
Update – got it!!

Even though Windows told me I had the most up to date drivers, I went to the Steinberg site and found a later one – downloaded and installed it, and it all works!