CD Arch 5.2 - Plugins don't work in Sonar

Marc Batchelor wrote on 11/5/2005, 5:56 PM
Hey all,

I own CD Architect 5.2, and the plugins work fine within the product. Once I try to process audio using the Sony plugins in Sonar, the audio gets corrupted with the silly beeps indicating it thinks it's in demo mode.

I've un-installed and re-installed several times, I've installed in the default location (one of the suggestions I've read), I've run the "migration tool" to re-register the plugins, etc. I've done everything I can think of, and I come up with no joy.

Gaaah!!! Can anyone help? I've got a question into technical support - we'll see if they can help me solve the problem. Meantime, has anyone else run into this problem? Any solutions out there?


Weka wrote on 11/6/2005, 6:06 PM
This is well-known to Sonar users. Give up and use the Sonar plugs.
Who's to blame is an historically much-debated issue.
Marc Batchelor wrote on 11/6/2005, 6:11 PM
Thanks for your reply, but I don't find that an acceptable state of affairs for a product I've spent over $100 on.

I'll see what Sony tech support says, but I don't find theirs to be a reasonable position. It's their plugin that "thinks" it's in demo mode when operating in Sonar, and I've got plenty of other plugs that work fine in Sonar.

Thanks though - I take it that nobody knows of a fix or a hack to make things right?

Take care,

Weka wrote on 11/6/2005, 6:59 PM
Place a post in the Sonar Users Forum and see what jumps up.
attalus wrote on 11/7/2005, 9:16 PM
I had this same problem when i installed cda 5.2 over cda 5.0. Plugins go into demo mode in sonar. tech support is aware of this issue. here is what they told me to do:

To ensure that you get a proper installation of your software onto your
system, we would ask that you un-install all of your Sony Pictures
Digital and older Sonic Foundry software. Do this from the Windows Control
Panel's Add/Remove Programs Menu.

Note: Uninstalling Sony Pictures Media Software will wipe out/delete
all user settings and preferences that were initially saved/applied to
the program. If you need to backup audio presets that you had made then
we would recommend using our Preset Manager utility, which you can find
For information about backing up custom Video FX and transition presets
please see the following article:

Title: How to recreate your custom presets on Video FX and transitions

Once un-installed, delete the following folders:

C:\Program Files\Sonic Foundry
C:\Program Files\Sonic Foundry Setup
C:\Program Files\Sony (Do not delete this entire folder if you have
other Sony applications installed such as Sonic Stage, Everquest, Star
Wars Galaxies, etc. If that is the case then only delete the folder for
the Sony Media Software application you are using as well as the Shared
Plug-Ins folder.)
C:\Program Files\Sony Setup

Once un-installed, click over to your Windows Registry Editor (Start ->
Run -> regedt32).
WARNING: The Registry is a very sensitive area to work in. If you are
not comfortable with advanced configuration and system changes, ask an
administrator to help you with this.
Once in there, delete the following registry entries:
HKEY_CURRENT_USER\Software\Sonic Foundry
HKEY_CURRENT_USER\Software\Sony Media Software

After removing all of the previous items, just download and re-install
from the latest updated versions of software from this link - These
files will be the latest full installers for our software. Your
product serial numbers are listed below for your convenience.

Weka wrote on 11/7/2005, 10:28 PM
Having done this, I think that you may still find that many of the Sony plugs will still have issues with Sonar. I am - and always have been - beep-free but have long given up on them. If you are having success, particulary with the pitch shift, I'd be interested to hear. I'm still with S4.3. Perhaps things have improved with S5.
attalus wrote on 11/8/2005, 9:13 PM
I can't guarantee the above instructions i wrote will work, this is the answer tech support gave me a couple months ago and i have not tried it yet, i'm somewhat lazy and have also given up on cdarchitects plugins aswell mainly since sony won't update them. One day i will follow the tech supports instructions when i'm ready to reinstall cda 5.2 again (for cd text)and also to get my Noise reduction plugins to stop beeping aswell, but now i have 5.0 on my computer, and you are right about still haveing problems because pitch shift always have never worked right! I'm really not even interested in the plugins anymore tho (hopefully one day Sony will improve them)!
Marc Batchelor wrote on 11/23/2005, 5:01 PM
Well everyone - the fix was actually installing 5.2a. I installed it this evening, and voila! No more problems in Sonar.

Note - I also installed the Sonar 5.0.1 patch. So, it was one or the other. But, no matter - I can now use pitch shift within my Sonar projects.

Take care,