CD Architect 5.2d has Bugs

giantsteps wrote on 11/17/2009, 12:34 AM
I recently upgraded from CD Architect verson 5.2 to verson 5.2d and the new version has problems.

When I went to burn a Red Book Standard CD using the new version of CA I kept getting error messages that said that the type of media Iwa susing was incompatible with my drive.

I tried two different types of CDR's including the best of the best, the MFSL 24k Gold CDR's which we use for all of our CD Audio Masters for replication purposes. Both times I got the same error message.

I also tried burning at every speed from Max to 4X and the same error message was received each and every time.

I sent an email to tech support and they of course referred me to the KB article on troubleshooting which I had already read.

After emailing tech support three times and not receiving a sound reply to my query I decided to uninstall CA version 5.2d and reinstall verson 5.2 which I still have on a CD-ROM.

After installing version 5.2 I attempted to burn a Red Book CD and presto, no more problems.

CD Architect version 5.2d has problems. I can't be the only user here who has experienced this. I am a professional audio mastering engineer and I swear by Sony's products having used them for the past 10 years to master almost 50 albums that were commercially released worldwide.

It concerns me that Sony has not taken the time to better test their "upgraded" software as clearly it has issues.

So for those of you out there that may have experienced a similar problem my advice to you is to remove version 5.2d from your system and install version 5.0 and you will be back up and running.

I am using an Sony Vaio with Windows XP Home Edition for those curious. My CDR/DVD burner is a Pioneer model.

I welcome any thoughts, comments or questions pertaining to this post.

Best wishes.


Geoff_Wood wrote on 11/17/2009, 7:42 PM
Though CDA5.2d seems fine for most people and their platforms, it certainly looks as is there may be an issue specific to your install of CDA5.2d, your hardware/software platform , or your particulur model drive.

A little more background (actual drive model, OS sp-level, etc) may help somebody here discount some aspects as to being the cause of your problem. Vaios have been mentioned as having some hardware pecadillos.

FWIW I myself have had no problems with 5.2d on XP Home SP2, SP3,and Plextor Premium, , Plextor PX-750A DVD/CD, Plextor SCSI 12/4/32, and a Sony DL USB/Firewire drive . But I guess (apart from indiating not completely broken version) that isn't much consolation to you. Maybe try a different (plugin USB maybe ?) drive, just out of curiosity.

giantsteps wrote on 11/17/2009, 10:50 PM
Thanks Geoff for your input.

It could very well be that my situation (computer, drive, system software etc...) and CDA 5.2d not working for me is an unique one.

Has anyone else here had the same problem burning CD's in CDA 5.2d that I previously described in my post?

I'm perfectly content with version 5.2, it works fine and I don't think I'm missing out on any major improvements especially since I can't get the new version to work on my system.

I'll most likely wait for the next upgrade and hopefully that version will work on my system flawlessly.
Geoff_Wood wrote on 11/18/2009, 3:06 PM
In the meantime try updating your burner's firmware.

synthpup wrote on 1/4/2010, 1:15 PM
I have a Pioneer DVD-RW DVR-216D. It is almost brand new and I too am having troubles burning a cd from CDA 5.2d. When I go to burn the disk it identifies the disk in the drive as a cd-r disk OK. It renders a temp hard disk file, tests OK, but when it goes to write the disk I get an error message that says the disk in the drive is read only.
I have no problems writing a data disk from Windows. So the drive IS writing.

jackn2mpu wrote on 1/6/2010, 5:32 AM
Try this: if you're using cd+r disks, try using cd-r disks. I have that problem with the optical drive in my daw computer (Toshiba Satellite 1955 laptop). So I wind up using cd-r or cd-rw discs.

kryten wrote on 1/6/2010, 9:50 PM
There is only one type of CD-R disc (well...2 really...Music discs and data discs). DVDs have + and - variants.
Geoff_Wood wrote on 1/7/2010, 1:28 PM
There is no such thing as a CD+R disc !