CDA Won't burn my CD and gives error messages

Kevin James wrote on 5/2/2010, 7:01 PM
I'm having major problems burning a master disc with CD Text in CD Architect. The disc is for large scale replication. I keep getting either of these two error messages:

"The media disc type is not supported by the drive"
"The disc in the drive is read only"

I have made sure I am running the latest version 5.2D, I have tried using several different brands of blank CD-R's, I have tried burning on two different computers, I have turned off all back ground services and hidden all Microsoft services, I have even bought a brand new external DVR drive and made sure before buying it that the drive supports reading and writing of CD-R's and CD Text.

The two computers are both Toshiba Satellites. One is running Windows XP and has a Pioneer DVR - K16a DVD drive. The other is running Windows 7 and has a HL -DT-ST DVD RAM GT20F DVD drive which I assume is Toshiba's own because it doesn't list a brand, and the external DVD drive I tried is a Pioneer DVR XD09

At first I was able to burn on the internal drive of the XP machine if I disabled CD Text, but once CD text was turned on it would give the "The media disc type is not supported by the drive" error. Now it will not even burn without the cd text, either way I get the "The disc in the drive is read only" error message. That is what promted me to try the other computer and to buy the external drive. Both still give the same " The disc in the drive is read only" message.

I have also tried burning CD's using another program and the internal drive on both machines and they burn so I know the drives are not the problem, the CDA software is. Unfortunately these discs are not usable as a master because they put gaps between the tracks and this is a continuous multi track dj mix which can NOT have gaps and also can not be set up as just one track.

I am at my wits end here as this problem is about to stop this replication project dead in its tracks as I've been trying every conceivable thing to fix it for 3 days and I still cant burn a master disc. Any ideas what could be wrong?


Geoff_Wood wrote on 5/2/2010, 9:46 PM
Although one of your drives is brand new, try updating the firmware.

Kevin James wrote on 5/3/2010, 6:14 AM
Yes, I have verified the drives have the latest firmware.
jbolley wrote on 5/3/2010, 7:39 AM
What other CD burning software is on these machines? I had an issue like this and one piece of software was "opening" each blank CD I put in the drive (ie writing just a little bit to it) so that it couldn't be used for audio burning. I believe it was Sonic Solutions product but I can't swear to it. Turning off this "drag to disk" feature or uninstalling the software fixed my issue.
These machines and the burners are similar (even the external.)
It may be a long shot but it sounds like you need help, fast.

Kevin James wrote on 5/3/2010, 9:08 AM
Hi Jesse,

The other burning programs are Roxio Record Now, and I just added and tried Nero yesterday as it was included with the external drive I bought (that one I can’t seem to figure out how to set the pregaps to 0 and it keeps modifying my CD Text so it’s a no go also.)

I have been testing each of these CD-R’s after my burn failures in CDA and verified they are totally blank, so while your suggestion is a good one, that doesn’t seem to be the issue. Also I can burn CD’s in those other programs so again it seems its only a problem in CD architect.

And yes you are correct, this is very time sensitive as I need to get the master out to the replication house this week. It doesn’t help that technical phone support is only available Monday –Friday 8-6… I’m at work during those hours so I can’t call and I have no access to my machines during those hours either.
Geoff_Wood wrote on 5/3/2010, 1:46 PM
Have you tried logging the fault online for an email response ?

But it does sound like something peculiar to your system. I would try uninstalling any CD writing software (and packet-writing CD drivers), then reinstalling CDA . IIRC Roxio used do do some nasty tricks some years back....

Kevin James wrote on 5/3/2010, 2:01 PM
I'm not sure what you mean by logging the fault online. If you mean where it pops up and asks if you want to send an error report then yes, I have. If your refering to something else then no.

I will try uninstalling Roxio and Nero. I'm not sure what difference that will make though as the Windows 7 Machine I also tried on does not have any CD burning software aside from whats in the Windows 7 operating system and I still got the "The Disc in the drive is read only" error.
Kevin James wrote on 5/3/2010, 8:44 PM

I got home and uninstalled all other CD burning software on my machine, turned off all background services and hid and disabled all microsoft services then rebooted.

Then I opened my project and tried to burn the CD again. I set it to 4x burn speed, Test first, then burn CD, and set it to write CD text.

This time I noticed something I don't remember seeing before. It specifically said: DISC STATUS: EMPTY CD-R DISC.

I started it, it test burned the lead in, test burned the tracks, then started to test burn the lead out....... then it abruptly stopped at 9% and gave me the "The disc in the drive is read only" error AGAIN.

This time I kept the same disc in the drive closed out of the failed burn and went back in to start over, and again it told me this same disc was a BLANK CD-R

So now I am just totally confused and frustrated. At the begenning of the process it aknowledges its a blank disc in the drive, and at the end before it actually burns it says its NOT a blank disc but a read only disc. What could possibly be happeneing.. I just dont get it.
Geoff_Wood wrote on 5/4/2010, 3:36 AM
With the other CD stuff uninstalled. also uninstall CDA then reboot. Delete the Program Files/Sony Setup/CD Architect folder, and reinstall.

Then try again.

Itsounds more like you burner(s) is not talking right to CDA (some control messages getting corrupted, or are non-compliant for some reason). Maybe reseat your cables. And check your PSU is adequate wattage for all your drives. Clutching at straws here sorry !

ChristoC wrote on 5/4/2010, 6:13 AM
Known Issues - from

"lf CD Architect software incorrectly detects that your CD recorder is not able to write CD Text, select the Overwrite CD Text autodetection results check box on the General tab of the Preferences dialog to turn on CD Text writing for your drive.
Please check the documentation provided with your CD recorder to determine whether the drive is able to write CD Text."