Change the default audio properties

chap wrote on 3/1/2016, 12:59 PM
Hey all-

Putting together a lot of animatics for a client, and have to drop in real audio. The audio is edited by line number.

Many times per project, I have to speed up or slow down a take to match timing of animation, and the only way to do this that sounds reasonable is to change the properties of the audio event (RIGHT CLICK>PROPERTIES) and switch the TIME STRETCH / PITCH SHIFT METHOD from "None" to "Elastique" and then the "Stretch Attributes" to "Soloist (Speech)"

Is there a way to make this setting the DEFAULT on all new audio events?

It would save a lot of time.

As a hack-around, I can put all the events on the timeline, and then change the attributes of one of them, COPY it and select every other event and past the attributes, but it makes for sloppy editing.

Thanks!
Chapman

Comments

Former users wrote on 3/1/2016, 1:21 PM
If you are doing it with your method, no there is no way to set the default without writing a script.

If you apply the TIME STRETCH effect, you can save a preset.
ChristoC wrote on 3/1/2016, 2:09 PM
élastique Timestretch as default

Hold down Shift while selecting "Preferences" in Options Menu (this reveals 'secret' Internal preferences...)
Select the "Internal" TAB in Preferences window.
At bottom of window, in the 'Show only prefs containing:' area type 'timestretch' (without quotes).
You should just see 4 lines of internal preferences now.
Make the next four ones read:
Timestretch Quality = 0.30000001
Default Timestretch Method = 2
Default Timestretch Mode 1 = 2
Default Timestretch Mode 2 = 3

It's the last one which switches elastique to 3 = "Soloist(speech)" when stretching event on timeline.
********************************************************************
some more info:
********************************************************************
First of all, I'm just describing behaviour when Timestretch is applied to Audio clip on timeline by holding down Ctrl and moving either end of the clip, where a little 'percentage' display shows (assuming 'Active Take Information' is enabled in View menu), and then Right-Click on Audio clip, select 'Properties' gives a window with more information & settings; not when elastique is applied as a plugin in Mixer channel .... I don't know what sets the defaults there.

Timestretch Quality = 0.30000001
- I have no idea what this does ??? setting there is what I found by default, and I don't remember changing it.....

Default Timestretch Method = 2
0 = Classic
1 = blank - don't do it, can make Vegas crash
2 = Elastique
3 = None

Default Timestretch Mode 1 = 2
- change attributes when "Classic" method is selected in "Method"; have not bothered to map all this: e.g. 2 = A03,Music 3 (less echo).

Default Timestretch Mode 2 = 3 (in your case)
- sets Elastique quality:
0 = Pro
1 = Efficient
2 = Soloist(monophonic)
3 = Soloist(speech)

*********************************************************
Former users wrote on 3/1/2016, 3:07 PM
ChristoC, I found those entries but did not seem to affect the PROPERTIES options. Did it change your defautls?

In Vegas 12 this doesn't seem to change anything.
ChristoC wrote on 3/1/2016, 4:38 PM
Donald, as I said, it changes the default behaviour when Timestretch is applied to Audio clip on timeline by holding down Ctrl and moving either end of the clip; i.e. it changes the default behaviour of the Timestretch tool, not when clicking directly on Properties, because initially Properties will just show "None" until you have actually done something to the clip... only then will it show what was done etc.

What I suggested works on VegasPro10, 11, 12 & 13.
Former users wrote on 3/1/2016, 4:43 PM
Curious, when I click on PROPERTIES, after altering speed, my defaults are Elastique and Efficient. When I change those entries in the internal settiings, those do not change.

Does it default to this state, but not display it or is mine malfunctioning?
ChristoC wrote on 3/1/2016, 11:57 PM
Perhaps you are putting the Chicken before the Egg.

If you already time stretched a part, then changed the Internal setting to a new default, the existing method you used for the original part is still retained; the new setting is only effective for changes made to clips that have not been time stretched already; its just a setting for all new edits, otherwise chaos would ensue.


Former users wrote on 3/2/2016, 8:27 AM
thanks, but that is not the problem either.

I open VEGAS and change the internal preferences (before loading any project).

Load a project, CTRL drag the edge of an audio event and then open properties, I still see Elastique and Efficient. So apparently mine is not seeing the Default changes.

Weird.
ChristoC wrote on 3/2/2016, 2:46 PM
Ah, now I see what is going on - this seems to be the case:

In an existing Project, even if the clips were not time stretched, the prevailing Time Stretch settings (when the Project was saved) for those clips is embedded in the clips; therefore when we change the Internal Defaults it really only applies for Newly Added clips in existing Projects and clips in New Projects.

Former users wrote on 3/2/2016, 3:05 PM
Okay, that makes sense, I guess. Thanks for following up on that. I really appreciate the feedback.

joseph-w wrote on 11/22/2017, 11:23 AM

I have this same problem in V14 (and had a friend test in V15) where I cannot get Vegas to default to PRO for audio stretching. Timestretching always defaults to the lesser quality "efficient" setting. There's an internal option (as described by ChristoC above in post 3) but as mentioned by Former Users it do work. The timestrech method always defaults to "efficient" (ctrl-strech audio clip, right click audio clip,properties) regardless of what value I put

Can this be fixed in a future version of Vegas so that it's possible to default the timestretch method to Pro (best quality) and not efficient???

I forgot to change it from efficient to Pro on a recent project before delivery so the quality was worse than it should have been :(

Thanks!