Serena wrote on 11/26/2010, 4:10 AM
I did have problems but got that sorted. Which cineform product are you using? NeoHD? Latest version? Project properties?
wuzabeeb wrote on 11/26/2010, 5:36 AM
Cineform NeoHD latest build 5.2.2 283 project identical to Vegas 9 at 1920x1080 60P - renders out in Vegas 9 to Cineform HD 1920x1080 60P but crashes every time in Sony Vegas 10a.

I've tried just a singleclip on the timeline to eliminate any confusion, with no processing - just rendering causes the crash. Perfect in Vegas 9.0c
PDem wrote on 11/26/2010, 10:33 AM
Yes I am experiencing exactly the same problem using Windows 7 64bit. Have tried everything but it always crashes. I have now given up with this issue and render selection to MFX. Hope Vegas 10b may fix the issue.
David Newman wrote on 11/27/2010, 11:48 AM
Seems like a question for CineForm support as export as working fine in Vegas 10a. Please file a trouble ticket :

David Newman
CTO, CineForm
Laurence wrote on 11/27/2010, 2:13 PM
Same problems here. Cineform not usable in Vegas 10a. Cineform in Vegas 9 is working fine.
John_Cline wrote on 11/27/2010, 2:22 PM
At this very moment, I am rendering a project at 1920x1080-60p to a Cineform NeoHD file in Vegas v10.0a-64bit and it's zipping right along. I'm using a beta version of NeoHD that was posted on November 24th. There is also a beta version of NeoScene if that's what you're using. You can find them here:
ryclark wrote on 11/29/2010, 10:11 AM
Not crashing in 10a but very slow to render. 1hr 52min Cineform to Cineform with a few cuts/fades/audio level adjustments is taking over 5hrs to render. Any idea how long it should take? Seems to be about 10 frames/sec. I would have thought that it should be at least real time if not quicker on an Intel Q8400 overclocked to 3.2GHz. :(
Randy Brown wrote on 11/29/2010, 10:35 AM
I downloaded the trial yesterday and was going to convert an HDV clip in the stand-alone mode and it locked up to where I had to hold the power button to shut down (couldn't get to task manager).
I opened my DAW (Sonar) this morning to finish up a project and all it showed was the Cineform drivers. I uninstalled Cineform but that didn't help so I did a system restore and finally got my Delta 1010 back.
musicvid10 wrote on 11/29/2010, 11:06 AM
"I would have thought that it should be at least real time if not quicker on an Intel Q8400 overclocked to 3.2GHz. :( "

I have never recommended OCing on a rendering machine. The CPU may be throttling back to save calories, and actually slowing the render.
LReavis wrote on 11/29/2010, 12:17 PM
I immediately render every clip to Cineform, then render my final projects to Cineform (60p). Bought latest version upgrade for my NeoScene. Can't get things to work right in Vegas 10 - have given up (can't remember all the details) - still editing in Vegas 8c and rendering in 9c (never a quirk or quiver - gotta luv it).
R0cky wrote on 11/29/2010, 1:03 PM
I am having terrible problems with V10a crashing and have gone back to V9. There are a lot of variables but cineform footage is a constant.

I have a test project with one piece of cineform media and a few cuts that crashes in Win7x64/Vegas64. I'm using the latest release 5.2.2 283 and will try the beta release.


BCC7 also seems to crash too....trouble tickets in at both Boris and Cineform.
ryclark wrote on 11/29/2010, 3:22 PM

"I have never recommended OCing on a rendering machine. The CPU may be throttling back to save calories, and actually slowing the render."

No, all auto settings for CPU clocking are off and CPU is running at 3.2GHz all the time.

Tried different versions of NeoScene but both the same. Seems very odd for a file of which over 95% doesn't need recoding.
John_Cline wrote on 11/29/2010, 4:35 PM
I was working in a 1920x1080 progressive project for the last few days in Vegas v10.0a-64bit and Cineform renders from Cineform NeoHD or MP4 source files worked fine.

Today, I started working on a 1920x1080 interlaced project and upon render it crashes with an "Unmanaged Exception (0xc0000005)" in "CFHDEncoder64.dll." The same thing happens in Vegas 10.0a-32bit but with the 32bit version of the Cineform encoder (CFHDEncoder.dll) Rendering to anything else, like uncompressed, Lagarith or the Blackmagic MJPEG codec using the same source files works fine. Rendering to Cineform NeoHD progressive seems to work fine, however interlaced crashes, regardless of the type of source files.

Also, 1920x1080 progressive 16x9 Cineform files will smart render, 720x480 16x9 Cineform files will not.
David Newman wrote on 11/29/2010, 8:24 PM

We don't install any drivers -- you need to check again. Nothing we install is at the driver level, as we can never take down a working system. However, if you have had a blackmagic card (or similar) installed, and removed, that can cause issues, but it is their driver that a failing we Neo checks for I/O cards.


I tried an interlaced project, which I admit I do so rarely, but that is also working fine in my render tests. If there is anything odd about the project, let support know, as we would like to try and reproduce the failure.

David Newman
CTO, CineForm
John_Cline wrote on 11/29/2010, 8:46 PM

The project is about as plain vanilla as it could be; a single 40-minute 1920x1080-60i file with a fade up at the start and a fade out at the end, no titles, no filters. It crashes as soon as I start to render using the latest Cineform NeoHD codec (NeoHDv524b286-101124). Vegas does write a 180,224 byte file with the correct filename before it crashes. It crashes whether I'm using Cineform source files converted from the original MP4 source using HDLink or the original MP4 files. Like I said, it will render to anything but the Cineform codec. Here is the crash report:

Application Name: Vegas Pro
Application Version: Version 10.0a (Build 388) 64-bit
Problem: Unmanaged Exception (0xc0000005)
Fault Module: C:\Program Files (x86)\CineForm\Tools\CFHDEncoder64.dll
Fault Address: 0x000000002FB54B23
Fault Offset: 0x0000000000024B23
Randy Brown wrote on 11/30/2010, 6:43 AM
Dan said: "We don't install any drivers -- you need to check again."

I guess I should have gotten a snippet of what I saw but I can tell you there were no other drivers to choose from...just "Cineform...something" (I don't recall what all it said but Cineform was in there. This was after opening/closing Sonar, rebooting etc.
alltheseworlds wrote on 12/1/2010, 12:59 AM
I have been going absolutely nuts over the past 24 hours trying to render my timeline with Cineform avis. If there are any fades on that media it crashes both v8 and v10 immediately. If I eliminate fades and render each edit one at a time I can get selective renders, but what a pain ! I simply can't render the timeline, no matter how simple !

It's just crazy. Instead I'm using freeware to convert files for my next project and all the test renders there are perfect.

Pfffft. What gives ?
Laurence wrote on 12/1/2010, 7:34 AM
My crashes are exactly like Johns. File starts to render then crashes almost immediately. Simple project. Same timeline renders to other formats just fine. If I do an EDL save so that I can load the same project into Vegas 9, it will render from Vegas 9 in Cineform perfectly.
alltheseworlds wrote on 12/1/2010, 9:34 AM
I've just managed to get my project out and my shattered nerves are just recovering from the horror. I intend to contact Cineform.

Has anyone already done so ? Have they anything to say ? Seems to me their product is basically broken in Vegas.
Xander wrote on 12/1/2010, 1:07 PM
I was getting constant crashes last night whilst rendering to Cineform HD. Worked when I originally got Vegas 10a. Think I did a Cineform update between then and now - might try and older version and see if that solves the issue.

Edit: 5.2.1 and 5.2.2 both caused crashes. The Beta for 5.2.4 doesn't crash Vegas but First Light wouldn't open the file up. Said the file was corrupt.
hazydave wrote on 12/3/2010, 12:49 PM
Here's my understanding of the problem.

Vegas 9 uses Cineform like any other DirectShow or Video for Windows CODEC... and it works. When I upgraded to Vegas 10, I was using Cineform NeoScene 1.6 or some such.

They basically said, Vegas is now "Cineform aware"... meaning there's some private Cineform API, and Vegas is using that. Perhaps it can go faster, or get better results, I don't really know why you would need a private interface for something that already works just dandy with the defined OS-level interface requiring no special coding from Sony at all. But hey, maybe that's progress.

So I had to upgrade to NeoScene 5.x, and grab the latest beta, to get my files into V10 at all. That was the first bad sign. As an engineer, I don't expect to look at a 10+ year old interface like a video CODEC and just assume there's some magic new API there. There needs to be a way to ask the Cineform CODEC if it has this private interface (or whatever it is), and just drop back to regular Windows interfaces if it's not there.

But hey, let's make it even easier. Back in the olden days, we all used DV CODECs. Microsoft had a pretty crappy one, Sony included a built-in version that was much better. But if you wanted to use the one from Windows, all you needed was to disable the Sony interface. At the very least, they should have disabled this magic new interface via a checkbox somewhere, so I could use 1.6, or render to any Cineform CODEC without crashing Vegas.

But yeah.. I have been unable to render Cineform. It always crashes in Vegas 10. Never a problem in Vegas 9. That points to Sony, not Cineform. But whatever this private API thing is, it could be both. Clearly, shipped without testing.

As it stands, I dropped coin on a new NeoScene, even though I had no other reason to upgrade, and it's all but useless. And while I like the idea of improvements, going from a Vegas that renders to Cineform to one that doesn't is a huge improvement in the negative direction. Changes with such a huge potential to go wrong need an escape clause of some kind... a check mark, a registry entry, I don't care. That's just good software practice.