Clips go black

VanLazarus wrote on 8/15/2011, 8:36 PM
In the latest version of Vegas, 10.0d, some clips on my timeline just go randomly black (black on timeline and black in preview window). I have to close Vegas and reload the project to get these clips back. Vulnerable clips seem to be from any camera (at least MP4s from GoProHD and MOVs from T2i). It's very frustrating when one renders a lengthy video only to find that one of the clips in the project was rendered ALL BLACK!

Has anyone else encountered this and knows a solution?

I haven't noticed any pattern myself.


musicvid10 wrote on 8/15/2011, 8:49 PM
GoPro provides you with a free Cineform codec you can try as an intermediate.
ushere wrote on 8/15/2011, 8:59 PM
i would never try to edit (especially mixed) non-mainstream codecs on the tl no matter what i'm promised by sony....

i usually convert to .mxf and have never had a problem.

VanLazarus wrote on 8/15/2011, 11:22 PM
I own Neoscene 5.x, and do use Cineform in some cases..... but I cannot use it as an intermediate for every clip on every project.... I currently have 3TB on my PC and over 5TB on my NAS... all almost full.... It's impossible for me to have intermediates for every project!

I'm not sure what people do if they have dozens of projects and use intermediates for everything. Some of my projects are over 300GB with just the DSLR source.... If I converted them all to Cineform, one project would take 1TB! That would mean I could only work on 8 projects at once! Do most editors have 100's of TB?

Besides, the clips in question (that turn black) have been 'stabilized' with Vegas and are in AVI form.... I'm not sure what codec Vegas uses for them. I would assume it's a codec that Vegas should handle very well.

@Ushere... Non-mainstream? GoPro HD footage and Canon DSLR footage are pretty mainstream. Besides, I didn't have this problem until recently, so.... unfortunately, Sony has introduced a new bug with one of the last few versions.
ushere wrote on 8/16/2011, 12:24 AM
i consider anything other than (as quoted):

Vegas Pro 10 software has extensive capture, import, and export support for video and audio. With the Vegas Pro 10 collection, you can efficiently edit and process DV, AVCHD, HDV, SD/HD-SDI, R3D and all XDCAM™ formats in real time, fine-tune audio with precision, and author surround sound, DVD and Blu-ray Disc™.

as being non-mainstream, well, for vegas at least.....

as for projects, i suppose it depends on what sort of work you do. mine's mostly short form doco, and i only have one 'major' project on the go at one time, with maybe a couple of minor projects ticking over in the background (tvc's, etc.,). any more than that then i think i'm spreading myself too thinly (and overworking!).
i do know wedding guys (and girls) who might be editing three / four weddings on the go at any one time, but even then if they shot the whole day i couldn't see them getting more than 120gb from one camera, and two say 300gb so conversion (if necessary) wouldn't be the end of the world - and no need to store raw footage (on line at least) after the deal is done....

all my major projects (in their entirety) reside on individual hd's (320 > 500gb hd's and all bk'ed up to off site storage as well).

my own stock shot library / music, etc., is only about 175gb at max, so sits on the pc and an external as well.

i can't imagine having 8tb of material that i would need to refer to at any one time, and as and when i did need it, i could encode / convert whatever then....

just my observations...

(long render even on a i7!)

Serena wrote on 8/16/2011, 5:59 AM
Yes, I've experienced the same problem and I always use Neo intermediates. This started with Vegas 10a with some incompatibility between Vegas and Cineform, and appeared to be fixed by one of the Neo upgrades. SCS and Cineform seemed unable to reproduce the problem and I had some debate with David Newman as to who was at fault. He said SCS. On that particular project I thought the occurrence was random but did find repeatability and reprocessed those clips with the later versions of Neo and all was fine. I downloaded the relevant clips to SCS but they did not identify a problem or a solution. I raised the problem on this forum, but no-one else seems to have experienced blackouts. Unfortunately I find the problem recurring with a current project (using Vegas 10e) and I guess I'll have to restart the debate with support. It's the old aircraft problem: the engine people say the problem lies with the airframe, while the airframe people know it is the propulsion system at fault. At least I know it wasn't a peculiarity of my computer system, for this is now happening with a new system.
crocdoc wrote on 8/16/2011, 4:06 PM
I've experienced this as well. It's fairly random - everything runs smoothly and then one of the clips becomes a black event (which also renders black if tried). Unfortunately, I've added too many variables in the mix to be able to pinpoint the cause - I started using Vegas 10 not long after making the shift to using new video codecs (MP4 from my dSLR and AVCHD from my dedicated video camera). Although I can say that it never happened to me when using Vegas 8 and HDV footage, I can't say whether it is Vegas 10 causing the issue or the codecs I am using. I have Cineform but rarely convert files any more because Vegas 10 handles my camera codecs so much more smoothly than Vegas 8 did so there hasn't been as much of a need.
TheHappyFriar wrote on 8/16/2011, 4:28 PM
I experienced something like this with my 48 hour film I was editing last weekend. Nothing was black on the TL but when I would render parts would be black. Kind of like a strobe. It only happened on parts I accelerated the clip speed, nothing else. I could re-render the clip and it wouldn't happen again. No clue.
Marc S wrote on 8/16/2011, 4:51 PM
I experience this on a regular basis using Cineform.
Serena wrote on 8/17/2011, 6:15 AM
Well it's good that several people are experiencing this problem; last time it seemed to be just me and it got little traction at SCS and Cineform. Seemed to me to be associated only with using Neo intermediates in Vegas, so if other occurrences (changing clip playback speed) then even more likely the problem is in Vegas. Seems to be forgetting where to find clip video (audio is never dropped), even though normally that produces "media offline" messages. Please put in trouble tickets.
AndyMac wrote on 8/17/2011, 7:32 AM
I'm also a Cineform user, and I can confirm I get the same issue on a regular basis.
Quite randomly, clips on a timeline will cease to display and 'go black', forcing a reboot.
Mind you, I've been having to re-boot frequently of late, not just for this issue but several others.

I've been using Vegas snce version 3, and still prefer it by far to other NLEs I've tried (and tbh, only Vegas can handle the audio demands I often place on a project), but I am sadly experiencing an awful lot more instability and crashes with the later versions.

And yes, in answer to an earlier poster, some of my longer-form projects exceed 2TB, so I have to spread over several drives. With multi-camera, long-form work, you get through an awful lot of hard drives ;-]
Robert Johnston wrote on 8/17/2011, 11:03 AM
I didn't have to re-boot. I just closed the project and opened it again. The CineForm clips went black right after I changed the project properties. Only CineForm clips have gone black on me. I never had other formats go black.

Intel Core i7 10700K CPU @ 3.80GHz (to 4.65GHz), NVIDIA GeForce RTX 2060 SUPER 8GBytes. Memory 32 GBytes DDR4. Also Intel UHD Graphics 630. Mainboard: Dell Inc. PCI-Express 3.0 (8.0 GT/s) Comet Lake. Bench CPU Multi Thread: 5500.5 per CPU-Z.

Vegas Pro 21.0 (Build 108) with Mocha Vegas

Windows 11 not pro

Serena wrote on 8/18/2011, 12:33 AM
I spoke loosely! Have to restart Vegas, NOT reboot the machine.
Robert Johnston wrote on 8/18/2011, 1:24 AM
I didn't have to restart Vegas either, just the project. Let's see you top that one. lol

Intel Core i7 10700K CPU @ 3.80GHz (to 4.65GHz), NVIDIA GeForce RTX 2060 SUPER 8GBytes. Memory 32 GBytes DDR4. Also Intel UHD Graphics 630. Mainboard: Dell Inc. PCI-Express 3.0 (8.0 GT/s) Comet Lake. Bench CPU Multi Thread: 5500.5 per CPU-Z.

Vegas Pro 21.0 (Build 108) with Mocha Vegas

Windows 11 not pro

Serena wrote on 9/1/2011, 6:48 PM
SCS says:
"Please disable Startup applications and Background Services. To disable these items from starting, you can go to the Start menu and select Run. Then type msconfig into the field provided and press Enter or OK. In Windows Vista, there is a field at the bottom of the Start menu that you can type directly into.

Open the Startup tab, press the “Disable All” button and then Apply. Then go into the Services Tab, check the box next to “Hide All Microsoft Services” at the bottom of the window and choose Disable All. Then press Apply and OK and reboot the computer.

** Note: This measure is for testing purposes. If you are disabling these services, none of these services are critical for your computer to start or function. We recommend this troubleshooting step to remove as many variables from the problem as possible; though you may also be disabling desired services like anti-virus or portable device recognition services like iPod Service, etc. If this solves your issue, you may want to repeat the steps above to open the MSCONFIG dialog so that you can re-enable most of these services. You may want to spend some time re-enabling these one at a time until you find the culprit. Most likely there are just one or two services that are causing the conflict."

diverG wrote on 9/2/2011, 3:21 PM
I’ve been trialling Neoscene and having a few problems with some clips that display in project media but show ‘black’ on the timeline or trimmer. To try and nail the problem I made a short capture using HDVSplit (m2t) and converted to avi using neoscene. The latest version failed to convert correctly, so the direct capture and convert also failed. This problem is known to neoscene.
Following a thread on their support page I unistalled v332 and installed v261. This converted mt2 to avi but the capture seemed flaky. Installed v332 directly on top of v261 and problem seems to have cleared. Have added loads of FX and rendering seems OK.
Am now testing on a more up to date laptop.


Sys 1 Gig Z370-HD3, i7 8086K @ 5.0 Ghz 16gb ram, 250gb SSD, 2x2Tb hd,  GTX 4060 8Gb, BMIP4k video out. (PS 750W); Vegas 18 & 19 plus Edius 8WG DVResolve18 Studio. Win 10 Pro (22H2) Bld 19045.2311

Sys 2 Gig Z170-HD3, i7 6700K @ 3.8Ghz 16gb ram, 250gb SSD, 2x2Tb, hdd GTX 1060 6Gb, BMIP4k video out. (PS 650W) Vegas 18 plus Edius 8WG DVResolve18 Studio Win 10 Pro (22H2) Bld 19045.2311

Sys 3 Laptop 'Clevo' i7 6700K @ 3.0ghz, 16gb ram, 250gb SSd + 2Tb hdd,   nvidia 940 M graphics. VP17, Plus Edius 8WG Win 10 Pro (20H2) Resolve18


VanLazarus wrote on 9/4/2011, 8:00 PM
My problems with clips going black are not related to Cineform clips! Just recently I've been rendering a 40 minute project that has many native clips from my T2i, with multiple composites.... and randomly, a few of the clips are rendered either black, OR they flicker black frames and have static/garbage near the bottom of the frame. This is extremely frustrating when a render takes 90 minutes. I've been forced to render out my project in chunks to Cineform, isolate the BAD parts, and rerender those small chunks to a new Cineform chunk. Then I can render all the Cineform chunks into a MP4. But it's a PAIN to have to do this.

For me, Cineform doesn't seem to cause the problems, but has rather enabled this workaround for me.

I think my current problem lies with AVCHD not being a standard at all. Native clips from my cameras have had improved robustness in Vegas, but footage from my Sanyo HD2000 would crash Vegas 9 regularly and Sony's response was that they couldn't support all the 'forms' of AVCHD out there. AVCHD footage from my T2i seems to work fine in Vegas 10.... but maybe not all the time. Why isn't AVCHD a true standard?
Serena wrote on 9/5/2011, 7:46 PM
Several people mentioned this problem of clips going black (audio OK) but did you all report this to SCS? Is it fixed? The test SCS suggested (disabling all start up programs) is not a bad starting point (i.e. the fault is not in Vegas) but presently I'm out of office and cannot pursue this.
filmy wrote on 9/5/2011, 10:39 PM
Ahh - glad to see this is not just me.

I thought I would pop in after encountering the issue to see if anyone else had this.

This is my scenario (To quote the Dramarama song): Re-render/s for a 24p project. Uncompressed clips (first) loaded fine. But then went black on the timeline. I shut down Vegas and re-opened it. All was well on the timeline when I checked the "black" section. I went ahead and rendered out. Came back several hours later and check the render. Got to the "black" part and it Went back to Vegas and checked the timeline and sure enough this same clip was now "black".

I should also note when this happens it will also play "black" in the media bin preview.

Although here is the odd thing compared to this thread overall: It only happens with uncompressed clips. I actually re-rendered out the clip with Cineform to bypass the issue. Never any issue with CFHD turning black at all.
Serena wrote on 9/6/2011, 2:45 AM
CF reckon the problem is in Vegas, so other examples are useful. Have you reported your problem to SCS? I'm pretty sure Vegas has the problem but it will get little attention if we don't all flag it for support.
Serena wrote on 9/6/2011, 7:45 PM
Vegas support has mentioned: "Usually when a clip goes blank on the timeline it is the result of anti virus applications or other security software disallowing the script pointer which connects the event to the actual media on the hard drive. "
Presently I'm out-of-office and can't follow up, so I hope others are testing what does seem a quite logical explanation. Generally I don't run my editing machines on the web (so have all security software uninstalled/disabled), but this hasn't been the case for my new machine.
VanLazarus wrote on 9/7/2011, 12:51 AM
Disconnecting my work machine from the internet is not an option for me. I need access often when working on a project.

That being said, I haven't encountered black clips since upgrading to 10.0e a few days ago.... I'll wait and see. If it happens again, I'll try disabling my virus software temporarily and see if that changes anything.
Laurence wrote on 9/7/2011, 2:51 PM
I am getting random black frames with stock footage library clips in .mov photo-jpeg format. Is this the same (or a related) problem?
Serena wrote on 9/8/2011, 3:09 AM
Could be. I've had only complete clips going black, but others ([/link]) speak of 'frames'. Some users (e.g. me) think it is related to Cineform, but that might be because we are using Neo. Cineform believe the problem is peculiar to Vegas, so your errors may be confirmation of that.
david-ruby wrote on 9/15/2011, 4:42 PM
I had this as well and did turn off all startups and it went away. I thought it might have been problem with deshake though. Or stabilizing in general. If I took my stabilizer subclips off it seemed ok. I did report this to sony so will see but I am also noticing I don't need neoscene as much if at all for our machines as 10 e is rockin quite well.