Closed Captioning gone

Roger Bansemer wrote on 12/21/2022, 12:26 PM

I've put closed captioning on my programs and rendered it in a MXF format. Been doing this for a decade. This gives me the .SCC file and also embeds the captions in the video file. I had to go back and re-render a few programs that had captioning and when I put some of the rendered programs back on the timeline the blue CC markers do not appear so I can't "promote closed captioning markers"

I've rendered over a 140 programs with closed captioning and never had this happen before. I'm using V20.
The captions are all there when I open the original project so I have no idea why a few of my programs don't have the captions embedded anymore after rendering them. Is there a setting somewhere that I'm missing.


DMT3 wrote on 12/21/2022, 12:41 PM

If you have an earlier version of Vegas, did you try the video to make sure captions show up? That could narrow down the problem to V20 for sure.

Roger Bansemer wrote on 12/21/2022, 1:01 PM

I'll be darned. Guess this is another bug in V20..... I put the file on V19 and the captions appear.
Thanks for the suggestion. When on earth are they going to fix this version?

VEGASDerek wrote on 12/21/2022, 2:43 PM

@Roger Bansemer: We are not aware of anything that would have broken changes have been made in both the MXF and general closed captioning sections of the code for several years. Would you be able to provide the VEGAS team a project file where you are seeing this problem?

MyChain wrote on 12/22/2022, 2:31 AM

@VEGASDerek Vegas Closed Cation does not show Thai Font on Preview video window. I would like the team to help me to fix this problem. I use Vasst Plugin Caption Assistant to help Vagas Pro still can't display Thai Font.


Steve_Rhoden wrote on 12/22/2022, 3:32 AM

@Roger Bansemer In Vegas 20, had you made sure that "Closed Captioning" is selected, which is located directly above the preview window?

DMT3 wrote on 12/22/2022, 7:29 AM

@Roger Bansemer make sure that ENABLE SCAN for CLOSED CAPTION is enabled in internal preferences.