Color shift when rendering to MP4 (MC or Sony AVC)

Liam_Vegas wrote on 3/16/2012, 4:47 AM
Using V11 (latest 64 bit)

Odd problem. I have an image (jpg) I'm using in a project. Here it is.



When I render to MP4 (using either mainconcept or Sony AVC) this is what the frame looks like when played using quicktime or windows player (ignore the black box around the frame... just look at the color of the map)



Odd thing is if I load the rendered MP4 file back in to my project the colors are identical to the original.

Anyone seen this problem before?

Thanks

Comments

Marco. wrote on 3/16/2012, 7:45 AM
It is because these players expect studio-rgb and decode every signal to computer rgb.
amendegw wrote on 3/16/2012, 9:43 AM
Nick Hope has an excellent write up on this "phenomena" here: YouTube Levels Fix

...Jerry

System Model: Alienware Area-51m R2
System: Windows 11 Home
Processor: Intel(R) Core(TM) i7-10700K CPU @ 3.80GHz, 3792 Mhz, 8 Core(s), 16 Logical Processor(s)
Installed Memory: 64.0 GB
Display Adapter: NVIDIA GeForce RTX 2070 Super (8GB), Nvidia Studio Driver 527.56 Dec 2022)
Overclock Off

Display: 1920x1080 144 hertz
Storage (12TB Total):
OS Drive: PM981a NVMe SAMSUNG 2048GB
Data Drive1: Samsung SSD 970 EVO Plus 2TB
Data Drive2: Samsung SSD 870 QVO 8TB

USB: Thunderbolt 3 (USB Type-C) port Supports USB 3.2 Gen 2, DisplayPort 1.2, Thunderbolt 3

Cameras:
Canon R5
Canon R3
Sony A9

GlennChan wrote on 3/16/2012, 12:43 PM
Here's an article that explains it:
http://www.glennchan.info/articles/vegas/v8color/vegas-9-levels.htm

2- The YouTube Levels Fix article is not entirely correct.

3- You could put in a feature request for Vegas to handle this stuff for you.
Liam_Vegas wrote on 3/16/2012, 2:21 PM
Thanks all... that's obviously what is going on. Looks like this is happening for stills only... and applying the "broadcast colors" FX simply allows me to see the problem in my project. So I'll have to adjust the colors in the source image to a "safe" range manually.

[EDIT]

Ahh... I apply the "Levels" fx to these images and choose "Computer RGB to Studio RGB" and that does the trick. OK cool!
paul_w wrote on 3/16/2012, 2:45 PM
oh no.. not those crazy Vegas levels again! loosing count how many threads have started with different subject headers only to be diagnosed as those crazy Vegas levels strangeness. Vegas fails in this area.

Paul.
Liam_Vegas wrote on 3/16/2012, 2:55 PM
Yep... very used to using the Levels and Broadcast colors in "the old days" of tape... but I have not had to worry about this for some time. Surprised that I have not been hit by this until now. So this is a Vegas thing rather than a "MP4/player" thing?

EDIT

and... I of course searched the forums for "color shift MP4" and of course that didn't bring back anything that seemed relevant. :-|
paul_w wrote on 3/16/2012, 3:05 PM
"So this is a Vegas thing rather than a "MP4/player" thing? "
Yes. no other NLE does this.

And yes searching the threads probably would not find anything. But there are many threads indirectly connected to this error, because of the incorrect levels produced by Vegas. Work arounds do exist, but thats just what they are ' work arounds' not a proper fix.

Paul.
bhurst wrote on 4/12/2012, 9:58 AM
Except now my extra-sharp, hi-res images look dull.
bhurst wrote on 4/13/2012, 9:59 AM
Well, as it turned out, applying the Levels effect did not fix the problem I am having, so maybe what I am seeing is different.

I am using a group of high-res pics (16 MegaPixel). When I render using the Main Concept codec, I don't get a consistent color shift, I get random "flashes" of color shift ... single frames where the colors look like a negative image. All the other frames are file. HD video in the same project never has the flashes.

Is this a symptom of the same issue or something else entirely?

Any ideas?

Thanks!
GlennChan wrote on 4/14/2012, 1:26 PM
That sounds like something else entirely.

Try contacting technical support? This sounds like a bug either in Vegas or in the codec.

2- What if you make the images smaller before bringing them into Vegas?
bhurst wrote on 4/16/2012, 9:08 AM
When I render the same project to HD WMV, there is no problem. So far, only happen when I use the MainConcept MPEG-2 codec ... HDV or NTSC.
GlennChan wrote on 4/17/2012, 1:47 AM
Try disabling GPU accleration for MPEG2?

I cannot remember where the menu option is... search for it.
Marco. wrote on 4/17/2012, 7:34 AM
GPU render acceleration is available only for AVC rendering not for MPEG-2.
Creative Film wrote on 4/18/2012, 2:20 PM

Hi,

it looks like we re having same problem at the same time.


What I did tonite was easy fix to get project done to my liking,after trying different formats ,I ended up using :
Main Concept Mpeg 2
setting : Blue ray 1920 x 1080 25p 25mpbs
customised audio by clicking to include audio stream so that file turns out to be M2T,it means it will have audio inside included,not separate as it is the case with blue ray video stream as it is template set up for.

Final output was full hd M2T file that looked way better then 22,000kpbs MP4 same file and colors where the same as shown in Vegas preview on my ASUS G74S 16G I7 2670
Gave up on mp4 render and I use Vegas since 2007,so I am not newbie.
My advice is go to mpeg2 and use high settings of at least 20mbps,i use variable 25mbps,it is also faster render.
If you need smaller file just use converter program.

Cheers