Contour Shuttple Pro2 focus issues?

joe-f wrote on 1/28/2023, 2:38 PM

Shuttle Pro2 user for nearly 2 decades - not only with Vegas, but the many other apps Contour supports. It's a wonderful if not critical tool. I also double as an IT Professional, owing back to disassembling boot sectors back in the Atari 6502c assembler days.

Setup: PC / Windows 11 current / Vegas 20 Pro. No other applications running - Vegas Pro 20 is it.
Problem: Vegas 20 Pro loses focus on the Shuttle Pro device - i.e. forgets it's there.
Symptoms: Vegas boots, loads the project file, Shuttle is there, works perfectly. Shuttle through a clip, and all of a sudden, it's non-functional.
Workaround: While Vegas Pro is running and has focus, open the Contour Control Panel app and leave it there. When Vegas loses the Shuttle - i.e. no longer responds - alt-tab to the Control Panel, click it, then alt-tab back to Vegas. Voila, Shuttle is back and perfectly functional. Until it isn't.

Not a roadblock, in that the workaround always works, but man, it's getting annoying having to frequently alt-tab/left-click in the middle of an intense session, just to alt-tab back again.

First time I've ever seen this, in all the Vegas iterations I've had going back to my first experience with the Shuttle + Vegas 5.

Maybe Windows 11 stealing focus perhaps? Dunno - thoughts anyone?


Grazie wrote on 1/28/2023, 5:08 PM

Maybe Windows 11 stealing focus perhaps? Dunno - thoughts anyone?

@joe-f - CSP2 is working fine here, on Windows 10. I don't have any of the symptoms you're getting - sorry.

Wiew wrote on 1/28/2023, 5:26 PM

@joe-f  @Grazie 

I have the shuttle xpress on W11 , no problem over here,

the focus stays in Vegas 20

Last changed by Wiew on 1/28/2023, 5:33 PM, changed a total of 2 times.

Camera's ; Panasonic HC-X1 / Panasonic FZ2000 / DJI mini 3 pro drone

Hardware ; AMD Ryzen 9 5900X / MSI Radeon RX 6750XT / 32GB Ram

Screen ; BenQ 27" 4K

My showreel

Grazie wrote on 1/28/2023, 5:41 PM

@joe-f - Questions:

1 - Has it worked with VP20 under W11 before?

2 - Has it worked with the latest VP20 update before?

3 - Have you recently updated to W11?

joe-f wrote on 1/28/2023, 6:10 PM

New PC (pre-built Dell) factory installed Win 11 Pro, fresh install of everything, updated drivers, including BIOS. VP20 updated to current prior to first use.

Dedicated film editing box.

I suppose if the Shuttle Xpress works, the Pro2 should as well. Just lucky I guess. Alt-tab it is!