CTASIO Warning Message with Vegas 4

BrianSw wrote on 2/28/2003, 7:58 PM
I can't get rid of these warning windows popping up everytime I do something.
I'm running the latest demo and I get a warning message when first starting Vegas 4
saying "The Creative ASIO devices have changed. You may need to restart this program before using creative ASIO devices"
I have to click on the "OK" button a few times to make the warning message go away.
Then Vegas will start. If I start making changes within Vegas the Warning window pops up again. Sometimes I can't get rid of it and Vegas freezes up. Have to then Ctrl_Alt_Del Vegas. I tried unchecking ASIO in the audio device setup and still won't solve the problem.
Driving me nuts now. Help is appreciated
I have a SoundBlaster Audigy 1 with latest drivers. Operating Syatem XP Pro/SP1
1.3ghz AMD processor, 768meg ram.



Syn wrote on 3/1/2003, 9:21 AM
I am also experiencing the same dilema. Only I'm using the Audigy 2 Platinum.

On startup, the CTASIO dialog pops up 4 times before Vegas loads completely. Setting Vegas to use ASIO through it's Audio Properties however, results in an endless loop of CTASIO dialogs. The only way to get out of it, is to End Task the CTASIO box, which in turn shuts down Vegas completely.

I'm just as puzzled, I can't find any ASIO related settings within the Creative software/drivers suite.
BrianSw wrote on 3/1/2003, 10:06 AM
I thought I noticed that when I installed Vegas 4 that I saw it was installing it's own Soundblaster drivers(ASIO Maybe) don't know for sure. I tried reinstalling the original SB drivers but that didn't help either.
pwppch wrote on 3/1/2003, 7:09 PM
This msg is reported by the Creative ASIO drivers. The problem appears that the Creative installer does not clean up the entries in the registry when installing new drivers.

Two possible solutions:
- Completely and entirely wipe clean all SB drivers and installs and reinstall. This is a nightmare to get the SB software to do. It hooks things in all over the place.

- Edit the registry: Locate this key in your registry:

You will find a number of entries in here depending on your system. Locate any entry that says creative or audigy. You should only have one entry for the audigy or creative stuff. If you have more than one you will have to locate the entry for these labled:


Rename one of these to xCLSID

Start Vegas.

If you get the error msg, then you renamed the wrong one.

Let me know what you discover.


BrianSw wrote on 3/1/2003, 9:19 PM
Funny, I fixed the problem before I even read your reply. You are correct though it was because of more then one entry in registry for ASIO. I had two entries in there.
I just deleted one entry and it fixed the Vegas ASIO problem.
Sonic Vegas also showed 2 entries for ASIO in Audio Device settings. Everything is good to go now. Thanks much for your reply. It just confirms what I found to be the cause of the problem.

JohanAlthoff wrote on 3/1/2003, 9:40 PM
Ah, useful to know there's a hack for that bug. I had to re-install to get rid of it.

(Oh, and on a side note... I HATE CREATIVE! =)
Syn wrote on 3/2/2003, 10:40 AM
I had 3 ASIO instances in the Registry location you mention:

Creative ASIO
SB Audigy ASIO [A400]
SB Audigy ASIO [B400]

Each of them had the CLSID entry.

I first renamed the CLSID in Creative ASIO to xCLSID. I started Vegas, and only encountered one CTASIO dialog as opposed to the usual 4. After closing Vegas, I noticed the SB Audigy ASIO [A400] entry had dissapeared completely. I also notced another CLSID had been entered into Creative ASIO.

Curious, I didn't change anything further. So I opened Vegas again. No dialogs this time! I can also go to Vegas' Audio Device properties and dabble with ASIO as much as I like without anything irregular happening :).

So to conlude, my registry now consists of the following entries:
Creative ASIO
SB Audigy ASIO [B400]

Both contain CLSID entries.

Thank's a lot for your help Peter!
pcfreakx wrote on 3/21/2003, 10:15 PM
You know you would think the number one sound company in the world could get off their butts and write a decent driver. I can't believe they have had hacked up drivers for two years now. I guess THX certification (not a biggie since they own the company now) is more important to them - my bluescreens and system hangs sound great.

Thanks for solving this problem guys!
MikeLV wrote on 2/1/2020, 3:35 PM

I have a Creative SB Audigy 2 card, and recently upgraded to Windows 10. There's no Win10 drivers for this card and I thought I had a workaround after some searching, but now I'm getting this same CTASIO warning. Thinking about replacing the sound card. Onboard motherboard audio doesn't work, some flaw I've never been able to fix so I need a card. What do you recommend that works in Windows 10? I don't do any surround sound or complicated audio, just need something that works in Windows 10 and doesn't cost a bundle.