Dark dark video

LV studio wrote on 10/30/2012, 12:47 PM
When I render mp4 or DVD mpg the black in the video is much much darker when playing back in windows media player or youtube. When in the project I have to decrease the contrast a lot so that the video appear bla during editing. Same computer, same monitor. Is there a setting in vegas to make the preview more like the end render? It's been this way for me from V10-12. I use 32 bit floating, 2.222 in the project.


musicvid10 wrote on 10/30/2012, 3:00 PM
1. Use an 8-bit project.
2. Edit for the levels you want to see in the Vegas preview.
3. Put a Studio->Cumputer RGB levels filter on the output just prior to rendering.

There are other methods, but this is one of the simplest.
Since your output (and probably input) are both 8-bit 4:2:0, a higher bit project just confuses the levels issue and does no good.
mikkie wrote on 10/31/2012, 3:19 PM
> " Is there a setting in vegas to make the preview more like the end render?"

Not that I'm aware of though you do have your choice of display devices.

Not sure this will help since ATI is a bit rare among forum users here, & I've no recent experience with the Nvidia graphics most use, but here goes just in case...

In the ATI Cat Control Center there's a setting to use system wide color, gamma etc. based on adjustments made in the CCC, or you can select to have it use any individual app's settings if that app has such. And/or maybe in combo with Windows color profile settings might find something that helps.

It might feel like more of a kludge, but there are LUT apps, or could switch monitor profiles, or maybe program a monitor preset? My main monitor's set up with a custom LUT, & I know that with it loaded Vegas tends to display too dark, so I unload it -- with Vegas maximized the color/brightness of everything else is irrelevant anyway -- then I re-load the LUT when I'm done.

essami wrote on 11/3/2012, 6:41 PM
This is definitely one of the most confusing and annoying issues and applies not only to Vegas. But what music vid says is true.

If you have a external monitor another way which I prefer nowadays (just to pass the extra levels plugin at the end) is to use external monitor for when you color correct and grade. On external monitor (just dragging the preview window to ext. monitor wont do, you need to click the "Preview on external monitor" button on preview window and view in full screen), there you will see the material in correct color space as opposed to Vegas preview window that will show you washed out image.

Then when you're done you render the video and upload it to Youtube, Vimeo, burn a DVD or watch it on your TV and it will look as intended and correct. On computer it will look washed out but there are players such as VLC where you can set it up to play it on your computer in the same color space as it would on an external monitor. Not that quicktime player doesnt work that well on a PC and I wouldn't trust it for color space.

LV studio wrote on 11/5/2012, 10:24 AM
Thanks folks. Good things for me to check.

I don't quite understand the 8 bit vs 32 bit thing in the project properties. I've learned that I have to be in 8 bit when using the stabilizer in V12 but should I run in 8 bit all the time? What happens when I render at best? Are the render function and the project settings (bit level specifically) independent? Will fades, transistions, efx's, etc all render at the lower bit level?

Simply, the only thing I know about 8 bit is to use it if your video doesn't play well when editing.
LV studio wrote on 11/5/2012, 10:26 AM
8 vs 32 bit. Do you think running 8 bit will help NBTPro run better? I've turned off GPU accel during titling projects because of instability and crashes.
Alex_Madrid wrote on 11/5/2012, 10:44 AM
load up your histogram and trust it. Definitely check your renders on a different machine also.

I fought the same issue for a while until I realized my monitors weren't adjusted right.
paul_w wrote on 11/5/2012, 11:04 AM
" Is there a setting in vegas to make the preview more like the end render?"
Yes, if you use either an external preview monitor or use Full Screen mode while previewing.

From the Preferences->Preview Device tab, Select check box:
"Adjust levels from Studio RGB to Computer RGB" (as in v11).

This makes your full screen preview / external monitor show as proper expanded 16-235, ie. as it would be once rendered and played back.

The trick is to get everything you render out to conform to 16-235 levels, not 0-255. Vegas fails miserably in this respect and if you try to add graphics and titles over video, it gets worse... The vegas video levels nightmare has been around from day one im afraid. But there are workarounds available to make it work as you want it to.

musicvid10 wrote on 11/5/2012, 12:23 PM
LV Studio,
Your video is 8-bit.
Your output is 8-bit.

Therefore, use an 8-bit project.

If you buy a $10,000 camcorder at some time in the future that delivers raw 444 over SDI, you "may" want to learn what 32-bit float is for.
Until then, there is little else worth knowing about it (or the mayhem it will wreak on your 8-bit Y'CbCr colorspace!).
LV studio wrote on 11/6/2012, 12:15 PM
Thanks folks. I'll post after a test of your ideas. Thanks again.