Paul_Varjak wrote on 5/3/2004, 5:55 AM
I recently convinced a friend of mine to purchase Vegas 4.0. His main purpose is to capture analog VHS and convert it to digital via the Canpous ADVC-100 and then edit with Vegas. He is experiencing some issues since installing Vegas and Acid. I'm not sure if it is related to Vegas or not. Here is the message I received:<PG>

Since installing Vegas & Acid I have been having problems with my windows configuration which is resulting in the screen turning blue with a warning that windows has to shut down due to i.e. newly installed hardware or virus. I had this happen again yesterday and was able to reboot. I ran a Virus scan this morning with no virus detected. I went to use TV Wonder last night for the first time in about a week or so and the following message appeared:

He is running XP on a Dell. Any thoughts on this? Is it safe to enable DMA on his hard drive. Looks like it's a Western Digital.



cbrillow wrote on 5/3/2004, 6:58 AM
DMA is available on virtually all modern hard drives, and is a basic necessity for successful video capture. It's hard to say what happend with your friend's system, but it's very unlikely that Vegas disabled DMA.

He should go back into Device Manager, click on Properties, and look around for DMA setting options. (Can't be more specific, because I'm not near a computer with XP...) If that doesn't work, it may require changing a BIOS setting.

C'mon back if he still needs more help. He'll get it.
Paul_Varjak wrote on 5/3/2004, 7:20 AM
Thanks for your help c.
Unfortunately I don't have XP at work so I can't check it out either.
johnmeyer wrote on 5/3/2004, 8:59 AM
1. Open Control Panel.

2. Open the System Icon.

3. Click on the Hardware tab.

4. Click on the Device Manager button.

5. Click on the "+" button next to IDE ATA/ATAPI controllers.

6. Double-click on Primary IDE Channel.

7. Click on the Advanced Settings tab.

8. For both Device 0 and Device 1, make sure that the "Transfer Mode" is set to "DMA if available." If it is set to "PIO only" then you have found the problem.

If these options are not available, and your friend has a Dell computer, these computers (and possibly others) change these settings through an Intel piece of software. I can't remember the exact name. If this software is installed, you have to set DMA through the software; the Control Panel options will be grayed out.

JakeHannam wrote on 5/3/2004, 10:21 AM

There are several things you may need to do. First, do what cbrillow and johnmeyer suggested. If that does not work, there are two other things you might have to. One is to use a special utility that comes with your hard drive or you can download it from the hard drive manufacturer's site. As stated earlier, all new hard drives are capable of ultraDMA BUT for compatibility purposes it is not always enabled automatically. Hence the need for the HD manufacturer utility. I know Western Digital offers this utility and I suspect Seagate and Maxtor and others do as well. Check their web site.

Finally, if you are running an Intel chipset-based system, there is an application (specific to the chipset - make sure you get the right one) called Intel Application Accelerator that enables high-performance on your system.
You can download this (again, make sure you know the chipset your computer uses!) from www.

I hope this helps.

Paul_Varjak wrote on 5/3/2004, 10:34 AM
Thanks for all the input. He could not change from PIO to DMA. I just told him to join the forum so hopefully he will be adding to this thread.

bobforce wrote on 5/3/2004, 11:07 AM

I am the friend of Paul....just joined the forum. Did what cbrillow and johnmeyer suggested no luck. The setting were as follows:

Device 0

Device Type Auto detection (greyed out)
Transfer Mode DMA if available
Current transfer mode PIO Mode

Device 1
Device Type Auto Detection (not grey)
Transfer Mode DMA if Available
Current Transfer Mode Not applicable

I believe I have an intel chip-set based system I am going to try for the Intel Application Accelerator and check my manuel. Thanks for all your help it is much appreciated. I will be changing my screen name it is not meant to offend. bob
JakeHannam wrote on 5/3/2004, 11:40 AM
Bob and Paul,

Let us know how you make out. That way others will be able to benefit.


P.S. Try the hard drive utility option first. What brand of hard drive do you have?
bobforce wrote on 5/3/2004, 12:29 PM

According to my system information it appears I have a western Digital 120 hard drive(WDC WD1200JB-75CRAO). I went to the Western Digital site and they have the following Utility

IDE Upgrade Utility (Non-3ware controller Cards)

Before I download it my question is this the one I want?

thanks ....bob
dvdude wrote on 5/3/2004, 12:35 PM
I don't think you should really need this. Did you build this system (or had someone build it for you)? Is it an "off-the-shelf" rig?

I would be checking the system BIOS about now to make sure DMA support is turned on. If it's not enabled on the motherboard, you could download software 'til you're blue in the face and it still won't work.

If you know what motherboard you have, post the details
JakeHannam wrote on 5/3/2004, 12:59 PM

The utility you want is the Ultra ATA Manager. I believe it is part of the Data Lifeguard toolset that should have come with your hard drive. If not, you can download it from here:

I think the file you were looking at is for RAID drives.
Sr_C wrote on 5/3/2004, 8:47 PM
I just did a complete format of my Hard drives and reinstalled windows and all apps (due to a very nasty crash on boot up) anyways, after I got it all up and running again I was dropping frames like a madman on capture. I checked the hard drive settings and they were exactly what yours are (DMA if available but running in PIO mode) what happened was when I reinstalled everything, Windows just loaded standard MOBO drivers, which I didn't even think about because it appeared that all was working at first. Anyways, I went to the manufacturer site of my MOBO (MSI) and downloaded the current drivers for my chipset and IDE controllers) After I loaded those, both drives correctly set themselves in DMA mode.

What kind of mother board do you have? It might be an issue that needs the correct IDE drivers rather that just running the standard windows ones.
Paul_Varjak wrote on 5/4/2004, 5:48 AM
I'm picking up the ball for Bob (allcraptome) as he, unlike me :) does not have internet access at work.

Bob sent me the following this morning:

Went into the BIOS..Drive Configuation........found the following

re: his mobo; he has a Dell XPS. Not sure if Dell has their own or not.
johnmeyer wrote on 5/4/2004, 8:49 AM

I assume you read my earlier post above. In it, I mentioned that if you have a Dell computer, you must change DMA through the Intel software, not through the Control Panel. Another poster correctly described the software: I tis called the Intel Application Accelerator. If you cannot find it on your Start menu, then you will find an Intel folder in your Program Files folder, and you can navigate to the EXE file from there and start the application.

Once started, click on the "+" mark next to the "Primary Channel," and then click on the Master drive. In the right pane, you will see various settings, most of which you cannot change. The only one that you can change that relates to your problem is the "Transfer Mode Limit" parameter. That should be set to "No Limit."
bobforce wrote on 5/4/2004, 3:02 PM
Thank you John for the reply. I will take your advise and try to make the change tonight. Last night I downloaded the following:

Data Lifeguard v11.0 for windows
Ultra ATA Manager

Although both were downloaded and opened Windows closed them down "windows encountered problems...."

I also downloaded Data Lifeguard Diagnostics-DLGDIAG for Windows which I opened and ran a "Smart Test" which reported the drive as OK

I rechecked my setting in BIOS which shows IDE Drive UDMA-ON
Went back and rechecked the Device Manager and the Current Transfer Mode was still set at PIO Mode

I must also report that once I downloaded Ultra ATA Manager my system seemed to stabilize that is the monitor stopped the occasional blinking and now is constant, focused and stable. all many thanxs......bob Will let you know how i make out with the Accelerator
johnmeyer wrote on 5/4/2004, 4:17 PM
The other thing that was already mentioned, but bears repeating, is the drivers for you motherboard. I have a VIA chipset motherboard, and there are some updated "4 in 1" drivers that I downloaded and installed. It solved a few minor glitches I was having. This is different from a BIOS update in that these are Windows drivers, not firmware.
JakeHannam wrote on 5/4/2004, 4:51 PM

It sounds like you may have some other system issues (e.g. getting the Windows errors running the Ultra ATA Manager). Plus, running it should have NO effect on your display stability to my knowledge. Weird!

johnmeyer is right about the "4-in-1" drivers IF you have the Via chipset. Make sure you have the latest version for your motherboard. IF you have a Via chipset, I'm not sure the Intel Application Accelerator would be of any help and it could even mess up your system. That's why we all said up front to make sure about your system (e.g. the chipset, processor, etc.),

Unfortunately, there are so many motherboards and system variations out there that it is really hard sometimes to track down the problem or problems.

Here is another possibliity:
Do you have a CD or other non-hard drive sharing the IDE cable? Sometimes that will slow down your system. If possible, put your CD/DVD drive on the other, secondary, IDE connector. At the very least, make sure your hard drive is the MASTER and not a SLAVE to the CD.

CHECK YOUR MANUAL carefully before making any significant changes!

Paul_Varjak wrote on 5/7/2004, 9:21 AM
At this point it appears there is something else wrong. I spoke w/Bob last night and he is having a real problem with his hard drive.
It sounds like it will have to be replaced. Once he gets that issue straightened hopefully he will be able to set his HD to DMA. Thanks again for all the help.
JakeHannam wrote on 5/7/2004, 9:32 AM
Thanks for writing back. Good luck to Bob!