DMA Mode issues

thrillcat wrote on 6/2/2004, 8:06 AM
Something happened to one of my drives on Sunday night, and it won't go into DMA mode anymore. I've check the device manager, and it is still set to DMA if available, but it says the current mode is PIO.

I've tried everything I can think of, but I can't get it to go back to DMA. Is the drive shot? Anyone have anything like this happen before? I can't get any work done, because the files won't play off it smoothly...they stutter, spit, and crackle...

I'm running a:
P4 2.4ghz
1 gig of RAM
Vegas 4.0e
2 Hard Drives:
1 (40gig) Boot Only
1 (200gig) Data Only


JJKizak wrote on 6/2/2004, 8:19 AM
Check your CMOS and see what it says. Check your cables to make sure they are fully seated and the correct cables.

SCErwin wrote on 6/2/2004, 8:40 AM
What version of Windows are you running? In older versions (98) I had this problem frequently and the only way I found to fix it was to go into the device manager and delete the IDE channel (Primary or Secondary) that was in the wrong DMA mode, then reboot. Windows will reload the driver and all was fine. This happens when Windows detects an error while reading/writing to the drive. It assumes that the drive is sending data too quickly to be reliable and therefore slows it down a notch. Over time, if it keeps finding errors you end up in PIO mode. Deleting the driver resets the process and it reconfigures to the fastest speed. This was a common problem on VIA chipset motherboards, and while the fix can be a pain, it is the only one I know.

Hope this helps.
thrillcat wrote on 6/2/2004, 8:47 AM
I'm in Windows XP Home, not sure what my chipset is (it's a Dell Dimension). I'm currently running drive diagnostics on it.

Will I have any issues deleting this IDE channel, since it has my boot drive on it too?

SCErwin wrote on 6/2/2004, 9:01 AM
No. ONLY delete the driver (either the Primary or Secondary IDE Channel listed under "IDE ATA / ATAPI Controllers"). This is only a driver for the IDE channel, not the drive itself. Upon reboot, Windows will recognize the missing driver and automatically re-load it.
johnmeyer wrote on 6/2/2004, 10:01 AM
If you have the Dell Dimension, you will find that Dell, in its infinite wisdom, decided to override the settings using an Intel piece of software that actually sets the DMA mode, and locks you out from changing it in the hardware device menu. See Intel Dell DMA for more info.
thrillcat wrote on 6/2/2004, 10:20 AM
I do have a Dimension (4550), but I am able to change the setting through the Device Manager, and cannot find the Intel software from that other thread.

When I ran the drive diagnostics, the drive failed. I'm actually getting very frustrated right now. I used to have 4 hard drives in my system, the boot drive, the 200gb drive, and two 250s. A couple months ago, something went through and corrupted about 80% of my files on the 3 big drives, but not on the boot drive. I reformatted all four drives, reinstalled windows, and was still having issues with the 250gb drives. I pulled them, reformatted everything again, and have been working on just the 200gb drive (it's kinda like going from my nice big desk to one of those tiny little things from junior high).

Everything was working pretty smoothly until this just popped up yesterday. I cannot figure out what is going on with my system that it keeps destroying hard drives. Could there be some sort of virus buried into the actual motherboard that is doing this? What could it possibly be after 2 complete reformats and Windows reinstallations?
johnmeyer wrote on 6/2/2004, 10:31 AM
Anything is possible.

1. Virus. Use one of the main virus checkers, with up-to-date virus definitions.

2. Adware. Use Adaware or similar product to detect and remove "adware."

3. Updates. Download and install all Windows updates (using the Windows Update feature built into Windows).

4. Manual removal. I have found -- just in the past two days, working with client computers -- many exploits that are not detected or removed by virus or adware checkers. One of these exploited the windows media player. The "wmplayer.exe" file had been replaced, and any time a media file was played, the bogus wmplayer.exe file was called and would start downloading garbage. The tip off was that the media player icon was now a generic Windows icon.

Part of manual removal is to make sure that nothing is loading when your computer boots. Run Regedit and navigate, starting with the Local Machine branch, to


Check all of the Run entries, including those in the RunOnce and other similar "Run" keys. The favorite place for bad stull to hide is in the folders that house programs that are only supposed to run one time (this is supposed to be used by programs that must re-boot to complete installation). These are harder to detect, unless you remove them via Regedit.

As always, backup your registry before you edit it.
JakeHannam wrote on 6/2/2004, 11:07 AM

There was another thread on DMA issues and lots of people had suggestions. Try here: