DMA?? on this drive?

Caruso wrote on 4/22/2004, 3:18 AM
I just installed a new Seagate 160 GB HD into my system. To make room for it, I pulled out one of the system CD RW drives and installed it as a slave on the secondary controller.

My system sees the drive, addresses all of it's 160 GB of space, and I've formatted it as NTSF (I'm running winXPProSp1).

My first test render to that drive plays back with rhythmic start/stop characteristic that makes me think DMA may not be enabled.

Problem is, I can't fugure out how to check this from within XP. I looked up DMA in my online XP help file, and there is some discussion about going through device manager to resource settings, but when I do that for this drive there is no resource settings tab.

I don't know why MS doesn't just give straight answers on searches like this. There can't be many reasons for a user to search for "DMA" other than wanting to check that setting for a hard drive. Instead of a straight answer, I get this description of DMA and a whole run around which, when followed, leads me to a point that doesn't solve the problem.

I'm guessing it's simple - hope someone here can point me in the right direction.

DMA may not be my problem, so, if you have other suggestions, please share them.

I'm a long time Vegas user (2.x through 5.0). Typically, I render to firewire drives. I decided to install this last drive internally because my system did not recognize it as 160 GB when installed in the FW enclosure.

I'm not sure if I could have overcome that via firewire (someone clue me in if I could have), so, since I had an extra CD drive that I never use, I pulled it to install this Seagate internally.

My system recognized it right away as a 160 GB drive.

Thanks for any help.



Caruso wrote on 4/22/2004, 3:22 AM
One more question - I'm guessing that the test avi file on the Seagate is probably fine - ie rendered correctly - but just can't be played back smoothly. I've freed up space on one of my FW drives and am in the process of copying the test avi to that drive.

I expect it will then play just fine - and also assume that will confirm my suspicion that the new drive just isn't able to stream out video properly because of an improper dma (or other) setting.

Won't know until the file is transferred, but, does my line of thinking make sense?

Caruso wrote on 4/22/2004, 3:50 AM
. . . yup, transfered this file to one of the firewire drives and it plays fine - so, until I figure out the problem with the new internal, I'll have to dump non-media files to it to make space for renders elsewhere. I still need to fix this problem, so any help would be appreciated.

sdmoore wrote on 4/22/2004, 5:23 AM
Hi Caruso,

To check the DMA settings on WinXP you need to look at the properties of the "Primary IDE Channel" (or Secondary) and not the drive itself.

There should be an "Advanced Settings" tab which lists the DMA/PIO modes of the devices connected as Device 0 (Master) & Device 1 (Slave)


Former user wrote on 4/22/2004, 7:12 AM

You mentioned that you installed this new Seagate as a slave on the secondary. What is running as master on the secondary?

Also - report back what DMA level your drive is at...Ultra DMA 5, 4 etc etc..


Cuzin B
rmack350 wrote on 4/22/2004, 7:26 AM
Hi Caruso,

Most systems are built with a 40 conductor, non Ultra-ATA cable for the secondary channel. Also, your drive will be limited if it is on the same channel as an optical disk.

Start there.

Rob Mack
Caruso wrote on 4/22/2004, 3:29 PM
Thanks for the replies. To fill you in on questions you raised:

I have a Compaq SC140s optical drive (CD ROM) on the secondary controller as master.

DMA Level (I guess level is what I’m seeing here) is multiword DMA mode 2.

Thanks for directing me to the IDE controller in Device Manager (why doesn’t Microsoft tell me this??!#@$).

It was originally set for PIO (I don’t know what that is).

So, I changed the setting to DMA if available – either that wasn’t my problem, or DMA isn’t available, because, even after re-booting, there is no change in the performance of the drive.

Playback is very jerky – definite start stop. The file itself is fine – plays fine when transferred to another drive..

I only installed this drive internally because my system would not address the drive as more than 137 gb when installed in a firewire enclosure.

I’m not married to the idea of having it installed internally. Also, I did use the cable that came with my computer – a Compaq 7994 – still running the stock 900 mHz CPU – guess that system dates to ’00 or so.

I do thank you all for your responses. Let me know if you have additional suggestions.

Oh, if you wouldn’t mind, Rob, explain why being on the same controller as an optical drive will limit the performance of my HD. Thanks.

Flack wrote on 4/22/2004, 4:09 PM

I have found that its better to set the drive up inside your pc with XP then to insert it in to your firewire/USb caddy. I had exactly the same thing I put a new drive in my firewire housing and XP did not recognise it as a 160 gig, it told me I had a 120 gig, and would only format it to that size.

So I took it out of the caddy and set it up on the master channel IDE 0 and XP recognised the full capacity and set it up correctly. I then just placed it back in the enclosure firewire/usb and its been perfect ever since.

Former user wrote on 4/22/2004, 4:11 PM

Most modern motherboards can handle the DMA/UDMA differences between an optical drive and a hard disk. Older boards will always default to the lowest speed drive to avoid data anomolies etc...what that means is your new drive immediately gets the brakes put on it by the motherboard. Not saying that's exactly what is happen here - but it sounds pretty close.

Did you notice what the exact DMA setting was for the drive when you first opened Device Manager?

General good practice is to have like drives sharing an IDE cable...two UDMA 5 hard disks will play nice on the same cable as will two optical drives.

That fact that you are seeing Multiword DMA 2 indicates that must be the optical drive.

Q: What drives do you have on your Primary IDE? If you can find a way to get this hard drive over to pair up with another hard disk - you may solve this issue. I must stress that the 80 pin IDE cable is key - without it - you will never get full speed out of this thing.

Cuzin B
rmack350 wrote on 4/22/2004, 5:35 PM
CuzzinB pretty much spelled it out.

I do training materials for one of the big PC vendors. Every season we shoot systems being dimantled. They always use the 40 wire cable for the second channel disks. This cable limits you to UltraATA33 speeds. You have to use an 80 wire cable for anything faster.

If you look at the ribbon cable on your primary channel you should see that the strands are finer and there's more of 'em. That's an 80 wire cable. The connectors themselves are all the same.

As far HDD and optical drives coexisting on the same IDE channel, well, it's news to me. Good news. But before you assume it'll work on your system, remove the optical drive entirely and put the HDD on the end connector of the ribbon. Set the jumper to master or CS, (It was set to slave or CS before, right?) Check to see how it performs now.

The problem with the drive not being recognized as the right size may have to do with the bridge board in the enclosure. They only recently began to be able to address larger disks.

--Use an 80 wire UltraATA100 type ribbon cable.
--Try the drive without an optical disk in the chain (put the ODD in the 1394 enclosure for now.) Better to try it than to assume.
--Make sure it is on the right connector and the jumper is set right-Master on the end, jumper set to master or CS.
--Now move on to the BIOS and Windows settings.

Rob Mack
JakeHannam wrote on 4/23/2004, 6:23 AM

Cuzin Band Rob Mack are correct. Try their suggestions.

However, there is one other thing you should try if their suggestions do make a difference:

Drives are usually set by the manufacturer to run on the majority of computers. In other words, they are NOT set up to run as fast as they can.
Usually, there is a utility on the disk that came with the drive or you can find it on the manufacturer's web site. I have never had a Seagate but I know you have to run this utility with Western Digital and Maxtor drives. Check the Seagate web site for a utility to actiivate Ultra DMA.

Caruso wrote on 4/23/2004, 3:11 PM
Thanks for the suggestions. I have not had opportunity to implement the suggestions - I think the comment about 40 vs 80 pin connectors may just be the key.

Frankly, I'm not concerned that my drive run at its top speed, just need it to run fast enough to stream video/audio out to my DV Cam.

I will try each of these suggestions this weekend - will let you know.

Thanks again.

rmack350 wrote on 4/23/2004, 3:27 PM
Good luck!

Rob Mack
JakeHannam wrote on 4/23/2004, 6:19 PM

Yes, good luck. Maybe the cable swap will be all you need and if that doesn't help then rearranging your master and slave drives might.

Frankly, I'm not concerned that my drive run at its top speed, just need it to run fast enough to stream video/audio out to my DV Cam.

I need to say, though, that when you are capturing video and/or writing it back out, you WANT the fastest speeds you can get out of your drive. Enabling Ultra DMA with the Seagate utility will help with this IF your system did not enable it already (again. the cable could be the issue). Hepefully, you'll get it ironed out soon! Let us know how you make out.

johnmeyer wrote on 4/23/2004, 7:58 PM
I think you've got most of the information you need to fix the problem. If you find that the primary channel cable is 80 and the secondary is 40, then set up your new drive as a slave to your boot disk on the primary channel. With older systems, it was better to have set the drives as masters on each of the two channels, and then set up your optical (CD, DVD) drives as slaves. With a newer system, you want both hard disk drives on the 80 pin cable.

Second, do you have a Dell computer? Dell uses their own utility to set DMA, and you won't be able to set it using Device Manager.

Finally, if your hard drive is defaulting to PIO, then you absolutely correct in your diagnosis of the problem. Thus, if you move your new drive to the primary channel and make it a slave to your main disk, your problem should go away.
rmack350 wrote on 4/23/2004, 10:30 PM
I'd bet the channel defaults to PIO because the optical disk is there as a master.
Caruso wrote on 4/25/2004, 12:01 AM
Well, stopped by BB to pick up that 80-pin cable. Always amazes me how things "computer" change under my nose. BB has no flat cables for general purpose, the new wave being round cables (to save space and aid in air-flow. Anyhow, I tell the guy I want an 80-pin cable (explain to him what it's for), he gives me a 40-pin.

Installed it, no improvement - will take it back Monday.

Went to CUSA - asked for an 80 pin cable and the guy looks at me as though I'm out of my tree. States that there is no such thing.

I might have argued with him on a good day, but didn't really feel like it on this afternoon.

I may have to move this drive back out to an enclosure in order to use it.

I'd disable the optical drive (rarely use it), but believe I need at least one optical as an optional boot device in case something goes wrong.

Thanks again for your help. Feel free to jump in, be critical - Thanks.

JakeHannam wrote on 4/25/2004, 8:16 AM

Are you sure you didn't get a cable with your new drive? Western Digital and Maxtor always include one with their new drives and I can't see Seagate not doing the same.

Look for a flat-ribbon cable (looks exactly like the old 40 except the 80 has a sky blue strip of plastic on the ends).

Also, your motherboard has to support Ultra DMA (it has to have matching connectors). All MBs made in the last few years DO include Ultra DMA support so that should not be an issue but check you manual to make sure.

Make sure you match the red stripe on the cable with pin 1 on your MB IDE connector.