DVDA7 Error when preparing large blu ray project to ISO

Teagan wrote on 12/10/2020, 6:36 PM

After it gets to about 56% I get this error:


"An error occurred while preparing compilation"

"File name: 00001.m2ts
Status: mscorlib.dll::ThreadHelper::ThreadStart_Context::This program has a bug. - m_ptsOfNextGOP is empty."


OK, information about my project, which is a compilation blu ray disc of my hi8 home movies:

It's one file that is 34.5 hours long with over 900 markers in it, which I shortened to about 90 in DVDA7. The maximum to be detected is 255 and it just returned nothing, so I re-created the ones I absolutely needed in DVDA7 manually with time codes from Vegas Pro 17. I could not use the source files individually in separate files added to DVDA7 as that was making it crash due to a memory error, most likely because it is a 32 bit program. The only option was using a very large file or a couple medium-large files. I have only tried the former, one very large file, since rendering is extremely long and takes about 20 hours.

720x480 4:3 29.97i lower field first AVC at 3Mb/s 41GB in size. Menu is 1920x1080 29.97i and has animated thumbnails. The menu is 18Mb/s AVC.

The audio is SonyWave64 .w64 and is 24 GB in size due to the current issue of dolby digital .ac3 not being available in Vegas Pro 17, for some reason. I have it set to re-compress the audio to .ac3 dolby digital at 192Kb/s in DVDA7 since it allows that codec to work and encode in DVDA7 but not in Vegas Pro 17. Once that is set the size of the project is under the maximum size limit of a BD-R DL 50GB.

So far I have tried setting my project menus to 23.976p to see if interlaced encoding was the problem but it had the same error when I tried to prepare the project menus to 29.97i.

When I was watching the DVDA7 project prepare to ISO file it had 75 hours remaining on the main video file encode and crashed at about 53 to 56%, since I wasn't watching it at the time it had the error pop up. It completed all the menus fine, from what I could see. It then had the problem on the main video file.

Any suggestions?


No comments yet - be the first to write a comment...