Enable Multicam editing

BillRankin wrote on 5/15/2019, 5:42 PM

When editing 5 camera angles (all proxy tracks) plus several audio tracks with 'Enable Multicam Editing" enabled, my preview monitor is very choppy, even when set at Preview 1/4. I just finished editing a 5 camera angle shoot with no problem. The preview at 1/4 is difficult to edit with even if it was not 'choppy'. When I disable the 'enable Multicam editing' button, the preview window is smooth.

Any ideas???

Comments

Joelson-Forte wrote on 5/15/2019, 6:00 PM

Go to Options/Preferences and in Video Dynamic RAM preview max (MB) set the value for "0".

BillRankin wrote on 5/15/2019, 6:38 PM

Perfect...I totally do not understand why, but it worked!!! I would think to increase the ram preview, but what the hell do I know.

BillRankin wrote on 5/15/2019, 7:05 PM

This works, however, not for long. After about a 1 or 2 minutes, it start the stutters. Not bad, but it does begin. Premierie Pro has some kind of way of clearing cache when something like this happened. Does Vegas Pro 15?

BillRankin wrote on 5/15/2019, 7:09 PM

Also, there was a way to 'render' part of the timeline and play it back. The "Build Dynamic Ram Preview" under 'Tools' is greyed out. I don't see a way to do that on Vegas. Is there a way?

 

BillRankin wrote on 5/15/2019, 8:22 PM

1. Removing thumbnails worked for a few minutes, but then little stuttery. 2. Ram Preview does work for me. I have to wait but that might be a good time for a break. I am hesitate to disable anything in program files because I have a lot of work stacking up and cannot afford much downtime (just in case). If it matters, my codec is xavc L. I have a feeling THAT might be the issue.

Thanks for your response...greatly appreciated!

Joelson-Forte wrote on 5/15/2019, 8:24 PM

Try this:

1.Go to Options/Preferences and in Video go to Thumbnails to show in video event and choose NONE. This will cause the video memory used to generate thumbnails to be used in preview

2.Your Build Dynamic Ram Preview is greyed because your Video Memory is set to "0". To use this feature, go to Options / Preferences / Video /Dynamic RAM preview max (MB) and set a value. Example: 4000mb. Then select in the timeline the area you want to see in real time and use the Build Dynamic RAM Preview feature (SHIFT + B). I usually do not use this feature in Multicam because it is a feature that is more focused on very complex editions where a pre-rendering for real-time result visualization is required. In addition it recurses a lot of memory and leaves the overall performance of the machine slow.

If none of this works...

Another possibility is that perhaps your preview is slow due to the decoder used in Vegas to read the videos that are on the timeline. As of Version 15 of Vegas the decoder used for most videos is the So4compoundplug. This decoder still has several bugs and the slowness in reading certain types of files is one of them.

You can disable so4compoundplug to see if anything improves. Just go to C: \ Program Files \ VEGAS \ Vegas Pro 15.0 \ FileIO Plug-Ins and Rename the so4compoundplug folder to so4compoundplug.OLD

By disabling this decoder, Vegas will use the old decoder and maybe your preview will work without crashes.

To undo this change simply rename the folder to s04compoundplug.

Here I work in multicam mode smoothly with Video Dynamic RAM preview max (MB) seted for the value "0" and with so4compoundplug disabled.

BillRankin wrote on 5/15/2019, 9:51 PM

For the #2 it will allow preview, but it's very short...30 seconds and that is with 20,000MB...

 

Joelson-Forte wrote on 5/16/2019, 11:07 AM

I forgot to mention one point. Try disabling your graphics card and let only the CPU work. Go to Options/Preferences/Video and in GPU acelleration of video processing choose OFF.

BillRankin wrote on 5/16/2019, 11:12 AM

I will try that this afternoon...thanks!

BillRankin wrote on 5/16/2019, 2:07 PM

Unfortunately, that did not work (graphics card set to 0mb).

Joelson-Forte wrote on 5/16/2019, 10:17 PM

Am sorry. That's all I know.

BillRankin wrote on 5/17/2019, 4:56 PM

Thank you for your help. I was not able to edit when I started this thread, but now I can....it's just not 'ideal' or perfectly buttery smooth. Again, thanks for taking the time to respond.

jozef-pavlik wrote on 5/18/2019, 7:55 AM

are yours clips in 30 or 60fps ?

 

BillRankin wrote on 5/18/2019, 8:20 AM

60fps