External FW Case -- Delayed Write Errors

vitamin_D wrote on 1/21/2005, 9:53 AM

This is one of those posts where I'm writing to ask if there's a simple answer :)

I have a trio of ADS enclosures, one of which is freshly back from an RMA. The enclosure that went out on RMA was purchased at about the same time the others were, and now another enclosure is starting to go on the fritz.

I keep getting "delayed write failures," so a popup appears saying something like "Could not save the file "..." on J:/M$ft -- all data was lost."

I've swapped drives out of this enclosure, and today I took my FW drives off of a 6-port hub I'd bought and have run them straight through my Audigy's FW port. Then I ran the disk diagnostic tools included in WinXP, repairing bad blocks, etc.

Is there something I'm missing? I checked to see if write-caching is turned off, and indeed it is. It only seems to be happening to one of my three enclosures. Could there be other issues causing this than just a bad enclosure?


- jim


reidc wrote on 1/21/2005, 10:01 AM
I've had the same problems with my 2 ADS enclosures. Here's what I've deduced. One of the enclosures hosts a 120GB drive. The second has a 250GB drive inside. Apparently there is a distinction between enclosures that can hold up to 137GB and enclosures that can hold more than that. I didn't know this when I bought the enclosures. Whenever the enclosure with the 250GB drive is in the chain, ANY firewire drive on the same chain exhibits failure (delayed write failure), even non-ADS drives that I KNOW work fine with more than 137GB (my 250GB LaCie, for example). So the issues seems to be something in the enclosure, perhaps the bridge.
rmack350 wrote on 1/21/2005, 10:29 AM
Yes, usually it's the bridge board BUT it's often a combination of hardware causing the problem.

In my case the drives would work fine until I added my ADVC100 to the mix Then all the drives would get kicked out of the party. Solution for me was to add a second 1394 card to the system just for the ADVC100.

I think that "Delayed Write" is a bogus message in that it probably isn't really describing the problem.

Look through this forum. There are recent threads mentioning patches from microsoft that may correct the problem.

Personally, I always recommend buying your firewire drives at a local store with a good return policy. If the thing doesn't work, take it back immediately.

Rob Mack
DCV wrote on 1/21/2005, 11:17 AM


This is a huge problem, DO NOT UNDERESTIMATE IT'S ABILITY TO DESTROY PARTITION AND DIRECTORY INFORMATION ON YOUR EXTERNAL DRIVE!!! I am in the process of recovering data from three external drives that experienced Delayed Write Errors in the past week which corrupted their directory structures and the data on them. Everything had been running fine, then out of the blue, none of the drives were coming up properly, especially when daisy chained.

There is something seriously wrong with WinXP and external drives currently. The closest I can figure is that crap hit the fan not long after I applied the patch (on 12/21) for Firewire Performance Degradation under SP2. I'm sick about this. I've removed the patch but don't know if it'll fix the problem. I have a ton of work to do and I seriously depend on my external drives.

busterkeaton wrote on 1/21/2005, 11:23 AM
I believe this is an issue with the way Windows is set up. Check the microsoft sight for info on this. There is a setting to turn off for each drive that should help
vitamin_D wrote on 1/21/2005, 11:27 AM

I, too, have mixed drives and mixed enclosures. Two are 120gb WD drives in "classic" ADS grey/black FW enclosures (which cannot do 48bit addressing for more than 137gb), and one is a 200gb Seagate drive in the newer FW/USB 2.0 grey/black combo ADS kit.

Would moving them around their place in line change things? If so, should it be 200gb last or first?

edit: buster -- I think you're talking about write-caching -- you can only turn that off during a format, I think. Maybe there's another setting Im missing?

edit edit: OK, there's a bit about turning off write caching here:


Still, all mine had it off in the first place :/


- jim
BillyBoy wrote on 1/21/2005, 11:37 AM
Delayed write errors can be bogus and very weird in nature. Case in point I have one drive, a older 100GB. This isn't in any encloser, rather "installed" as a fixed drive.

If I put this drive in PC A it is perfectly happy and Windows never complains. However if I put this drive in PC B which also has XP and both have Service Pack 2 and most of the updates, every so often out of the blue it generates delay write errors.

The good news is each time its been bougus and I've never lost any data. Guess its just another of those goofy Windows things.
vitamin_D wrote on 1/21/2005, 11:57 AM
It's nice that you've been lucky, but for me and others that doesn't seem to be the case. I don't want to roll the dice and chalk it up to Windows weirdness.

Yesterday, Vegas hung and my machine froze for about two solid minutes during a delayed write failure. Before that, the last time I had delayed write failures, it was just as one of my other ADS enclosures bit the bullet. Ultimately, that enclosure stopped showing up in my chain of drives altogether -- luckily the data on the drive was still intact.

Consequently, I'm having trouble troubleshooting this problem -- the first round of DWF errors were likely the result of a bad enclosure. That was when all my enclosures were the exact same make/model. Now that the possibility is that 48-bit addressing has something to do with this is another variable thrown into the mix, I'm not sure what the best solution is.

- jim
vitamin_D wrote on 1/21/2005, 11:59 AM
buster -- thanks for the link! This describes my problem to a T:

"The I/O eventually timed out but the drive was now "hung" and further communication with the drive was impossible. Windows was left in a state of needing to read/write to the drive, but it couldn't. When Windows cannot flush its buffers, it reports the "Delayed Write Failure" telling you that data may be lost."
vitamin_D wrote on 1/21/2005, 12:20 PM
More info and a solution (firmware update) here:

Flack wrote on 1/21/2005, 12:24 PM
I had that problem on my laptop and if you are using XP with SP2 then Microsft have an updated file patch for just this problem .. its cured my problem.

this is the link

and this one as well while you are there

vitamin_D wrote on 1/21/2005, 12:51 PM
That first patch is for XP SP2 -- I'm on SP1a and still getting the error ???
Flack wrote on 1/21/2005, 2:08 PM
What drivers are used for your card.. mine is the Oxford Semiconductor and there is a flash firmware upgrade for this card if you have it.


This might help

Download the .zip file with all the files you need from:
Extract this to a temporary directory, you'll need to pull a couple of files out of it.
Install the Oxford Windows firmware updater by running
me-350f\make1394-faster\Uploader v4_12\setup
Reboot as directed
There won't be any icons or start menu installed to run the program, but it's there. On your Windows system drive, the program is installed into
\Program Files\Oxford Semiconductor\OXFW900 Uploader
Head into that directory and run the "FwUpload" utility. The interface is pretty simple. It will show the current firmware revision on your device at the bottom. My enclosure had a firmware from early 2002 when I started,
and that version was incredibly buggy.
Click on the "Upload/upgrade device firmware" to install a newer version. It will default to the directory the program was installed into, but the only one in there is an ancient firmware (20020104, which is even older than the useless version my ADS Pyro shipped with).
To find the firmware you want, go back to where you originally unzipped and use
me-350f/patch file need for firewire/fw20030722
That will upgrade your Oxford 911 to the Jul 22, 2003 firmware (which Oxford refers to as their v3.8 firmware). Windows will complain that you've unplugged the drive without stopping it first when the new firmware installs and the enclosure disconnects for a moment.
There is another useful feature available when you're in this utility. If you navigate to:
Modify device configuration settings/Advanced
you'll find some parameters you can adjust. Some people have reported that they can solve some compatibility problems with the Oxford chipset (in particular with faster CD-RW drives, <http://www.xlr8yourmac.com/firewire/ads_pyro_case_cdrw_reports.html>) by turning on the "Detect drives with non-std. signature" feature here. I found the following recommendations from one web page that mentions this
"We recommend turning on ONLY the following options:
Enable GPI Drive Detect
Detect drives with non-std signature
Wait 6s before polling drive
We DO NOT recommend using any other settings - LEAVE THEM OFF"

farss wrote on 1/21/2005, 3:29 PM
I've had similar problems and I'm pretty certain a lot of the issue has to do with the "Enable Large LBA' flag. I don't know the specifics but I had a lot of problems with this delayed write error and I think it was becuase we'd turned on that flag on 1394 drives that supported > 123GBs.

Either way we now swap drive between XP VAIO and Win 2K PCs without problem.

One way to test all is well is getting Vegas to render a file to the 1394 drive, if it'll render more than a few minutes without Windoz having a dummy spit you're OK. We've managed to capture hours of video to a drive without an error but hit problems as soon as we tried to render to/from that same drive. I'd suggest before sending any 1394 drive/enclosre into battle, blood it first, if it doesn't cower you're OK.
epirb wrote on 1/21/2005, 3:36 PM
I too have had the same error on an enclosure thats both firewire and usb2, I get the samething when connected up via usb2 as well. Go figure, it's a no name enclosure and so I just use for non criticle saves of work and dont leave it on all the time. My ADS and W/D (both firewire)dirves never have had the problem.
WinXP SP2 here.
Caruso wrote on 1/22/2005, 4:51 AM
I view this as a Windows flaw, and would encourage anyone experiencing the problem not to jump to the conclusion that the enclousre or the tailpiece (bridge) is bad. I have six enclousres, three Maxtors (the type that came supplied with HD's that you aren't supposed to open up . . . I open them and swap drives all the time), and three ADS enclosures. One of my ADS enclosures was replaced by the Mfr (very good service) when it absolutely refused to enumerate, no matter what drive you stuck in there.

I was having problems with one of my Maxtors, called their support, and was told that it was probably a bad tailpiece (his term for the bridge thingy into which you plug the drive). I went out and bought a new one, experienced the same problem (this was in XP SP1), then, discovered a patch on this board that solved the problem.

That was SP1. No futher problems until I upgraded to SP2. Now, I may run my computer for 24 hrs with no problems, then, out of nowhere, these delayed write error message start popping up, telling me that my data is lost. First, drive G, then, drive H, then, drive whatever. I've learned that that is the time to simply reboot and re-establish connections to those devices. Seems to work everytime.

I've never experienced a delayed write error while actually performing a disk intensive task (saving, capturing video, printing video, etc). While running under SP1, I had a disk that was connecting, disconnecting at random in a short span of time (I think it may have been a loose power connection). That little fowl-up caused me to lose the ability to address the disk - Windows XP SP1 would not recognize it - kept insisting that it needed formatting. This disk contained a four-hour recording session that I could not afford to lose.

We've probably all learned by now to take any Windows error messages with a grain of salt (for instance, why, when connectivity is lost to an external drive, should Windows flash a message that $***@#$% delayed write error has caused all data to be lost on drive whatever?). A more proper message might be something to the effect that the connection with Drive X has been lost. Reboot to reconnect.

Anyhow, it was 2:00AM when I experienced this disc not formatted issue, and I was frantic to save the data, since I had not had the opportunity to back-up the recording session. I signed on and found an application "get data back now" that I downloaded, paid to unlock, and was able to recover my entire recording session data and copy it to another disk prior to reformatting the drive so that Windows could access it.

I've encountered many of these delayed write errors, and, the above instance (that I attribute to non-software related problems) was the only time that data loss ever came into question.

I believe that if you simply reboot at the first sign of delayed write errors, you can live with this Windows flaw without losing data.

It is, however, a definite Windows flaw. They had it solved with a patch in SP1, must have overlooked it as they rolled out SP2.


farss wrote on 1/22/2005, 5:42 AM
The reason you get the "Delayed write failure" message and not a connectivity lost message is because all OSs have many layers to them. The layer that handles the direct control of the 1394 ports simply tells the layer above that it can't perform the requested task. Now that layer has no way of knowing WHY, it just reports what it was trying to do when it hit a brick wall.
I've worked with many OSs, perhaps the wackiest error message I've ever seen was "Drive failed to rewind". Our software gurus had ported an OS that ran from mag tape to run from a disk and well if you tried to read past the end of the disk that was the same as trying to read past the EOT marker on the tape!

But getting back to the current issue, we have tried several 1394 drive boxes and by far the best rig we have is actually for 5.25" CD/DVD drives but it has an internal ATA 100 interface so we've fitted a drive caddy. The enclosure mostly sits off our VAIO laptop doing duty as our capture machine. We pull the drives out in their caddies and plug them straight into our main system when they're full and we've never had a problem with this unit. Oddly enough I bought it from a local ADS Tech dealer who suggested this unit as better and cheaper and so far he's right, all metal construction but a noisy fan, that I can live with.

I've had all sorts of 1394 hiccups though, try running any of the older Sony gear with anything else 1394 connected, even on another port and all hell can break loose. Last thing I tried was DHR 1000 and Firewire 410 together, very bad mix, 410 and DSR 11, never a blip.

I'm pretty certain that Windoz must keep some form of table to map 1394 devices that's dynamically updated. Now when the 410 looses connectivity the drivers have to reload code into it however Windoz still has it's old address so the code gets sent to the VCR and/or video data gets sent to the 410 (very bad sounds!). So we've learnt to treat 1394 stuff carefully and all seems well but they are twitchy devices.

matt24671 wrote on 1/22/2005, 7:32 AM
I, too, have had problems with ADS FW enclosures, but mine were solved by simply using the USB port instead.

I also had issues with the Audigy board and its FW port - it conflicted with another FW card in the computer.

But - with the introduction of Serial ATA, can't you (theoretically) have an unlimited number of drives connected via that interface? Why not use that and skip Firewire altogether?
John_Cline wrote on 1/22/2005, 8:56 AM
You can not chain SATA drives. Serial ATA can have ONE drive connected to each SATA port.

vitamin_D wrote on 1/22/2005, 10:15 AM
ADS got back to me today, and I responded at length. Here's the exchange:

Hi Jim,

From your mail I understand that you are getting "Write Delay Failures". I suggest you to try unplugging the LED connector from the bridge board and try again.

I would like to inform you that this may be caused due to different reasons.


There are several causes of this issue:

1. The Enable write caching on the disk feature for the drive is turned off.

1. In Windows Explorer, right-click your hard-disk, and then click Properties.

2. Click the Hardware tab.

3. Click the hard disk, and then click Properties.

4. Click the Policies tab.

5. Click to clear the Enable write caching on the disk check box, and then click OK two times.

2. The BIOS is configured to force faster UDMA modes than the EIDE controller can support.


Disable the write caching on the drive.

Make sure that your BIOS is not set to use a faster UDMA mode than the chipset can handle. For information about how to do so, view the documentation that is included with your computer or contact your computer manufacturer.

Also make sure that the jumper setting for the drive should be set to MASTER and the drive should be powered on before connecting to the computer.

If you have any further queries, feel free to write in to us.

Thank You for contacting ADS Tech Support.

Best Regards,
Frankie Maguire



Thanks for your response. I feel that there may be issues with this case that go beyond the stock remedies you recommend -- most of which I've already tried. Here's the rundown of things I've done in an attempt to fix the problem:

1) Drive is set to Master -- Yes
2) Drive has power before being attached to the machine -- Yes and No -- either way the problem occurs. Sometimes the drive "freezes" with the LED light on (not blinking) and I cycle the drive off/on to get it back up. Other times I have to reboot entirely.
3) UDMA settings in BIOS -- there are no UDMA settings in the BIOS other than for the Primary and Secondary EIDE buses. There is a mention of UDMA in the BIOS otherwise, but the choices given are 1 or 3 -- I thought these cases were approved for UDMA 5?
4) Problem occurs with different drives -- have swapped out two different makes/models/capacities and it occurs -- one WD 120gb, the other a Hitachi Deskstar 75gb
5) Problem occurs with one case, and not another, identical case with an identical drive -- ??? -- it is also consistently this one case in the chain that has the problem, and not the other two.
6) Write caching was turned off at the time of formatting and Device Manager in Windows shows it as off -- "device ready for quick removal"
7) Problem persists if the case in question is moved up or down the chain of disks (there are three, total) -- right now the heirarchy goes -- FW straight from 1394 card (Soundblaster Audigy) -- > ADS FW/USB combo case with 200gb Seagate drive ---> ADS FW case with 120gb WD drive (the problem case) --> ADS FW case with 120gb WD drive.

Just so you know, I'm pretty thick with geek speak -- I built the machine these drives are attached to, so if you've got advice that requires flashing the Oxford chipset, or some similarly "complicated" solution, I'd love to read it :D

I have read elsewhere of a problem that someone else had with their ADS case which describes my issue to a T:

"I looked at the specific I/O that was failing and I noticed that Windows was attempting to write out 3FFh sectors (1023 sectors) in a single I/O. This is approximately 512K worth of data in a single I/O. I thought this was interesting as Windows typically does not send an I/O larger than 64K and very rarely above 128K. The I/O eventually timed out but the drive was now "hung" and further communication with the drive was impossible. Windows was left in a state of needing to read/write to the drive, but it couldn't. When Windows cannot flush its buffers, it reports the "Delayed Write Failure" telling you that data may be lost."

More, here: http://www.bustrace.com/products/delayedwrite.htm

I've started a thread about delayed write failures at Sony Digital Picture's forums, where I'd initially asked "Which 1394 case is best?" and was led to ADS. The thread is replete with answers, some of them conflicting. Perhaps you'd like to read it:


Thanks for any help,

- jim

scdragracing wrote on 1/22/2005, 1:43 PM
jim, your troubleshooting isn't complete... you need to disconnect the firewire from the soundcard, and plug it into another completely seperate firewire bus on the host computer... creative does funny things with their firewire ports.

here you can see that it's slower than a dedicated firewire card:

vitamin_D wrote on 1/22/2005, 10:13 PM
That's all fine and well, but I've had this card for over two...wait, three years now and it hasn't been problematic under Win2000 at all, and under WinXP only recently has the issue occured.

Again, there's up to five devices attached to it at a given time -- if it's the card, why aren't the others having problems? Especially when I've got an identical combo of drive and case?

Are you suggesting that the Audigy's have problems when exceeding a given number of devices? I gues that's possible...

Aside from all this -- I don't have a "dedicated" firewire card to test, and I'd like to not spend the money if I don't have to.

- jim
PeterWright wrote on 3/27/2005, 10:08 PM
Don't know if there've been any other developments with this issue, but I've recently been having the dreaded "Delayed Write" error with an external 250Gb drive.

After re-reading this thread, I downloaded the "fix" from MS but it wouldn't instal - the PC in question has SP2 but is not connecetd to the internet.

Anyway, I started looking for other alternatives. One idea was to swap this external 250 Gb with an internal 120 Gb, then I tried an even simpler one -

I have a PCI 3 port ADS Pyro card, but also have a barely used Audigy sound card with a single firewire port. I disconnected the drive from it's daisy chain to the Pyro and connected it straight into the Audigy.

Two hours solid work later and I haven't had a Delayed Write - so my problem seems to be related to the daisy chaining, or maybe as was mentioned earlier,daisy chaining to a different size (120Gb) drive.
DCV wrote on 3/28/2005, 6:27 AM

Take a look at my recent post here:

This patch fixed my Delayed Write Failure issues entirely. I have not had one error since installing it. I am running three external drives. Two off of their own Firewire ports and one daisy chained to one of those two. This has been such a huge relief for me!