External Preview leads to crash on one Screen

SwissGravityForce wrote on 9/18/2017, 12:08 PM

Hello, I'm trying to solve a problem with "vegas pro 15" and the external preview.
i have two different monitors, once "Acer G246HYL"(#2) which i want to use as a preview screen and once "Acer Predator XB271HU"(#1) for the editing itself.

 

so i edit something, start the preview and #gets a black screen, i try to do anything and the application crashes.
but when i use #2 to edit and #1 as the preview monitor, it works fine without any problem.

Disabling the GPU in vegas does not make any difference. also i reinstalled all the drivers i think could have caused this problem. I also renamed the .dll file which caused to problem regarding to the screenshot i attached, since then it does not say what caused the problem but it sill works from #2 to #1

i already tried to use both monitors at the same resolution and refresh rate - no improvement.
i already tried to update and reinstall my drivers - no improvement
i already asked the same in two different forums - no improvement :D
windows ist up to date
 

 

hardware:
-1080arctic storm (overclocked, stock does not work either)
-Maximus viii hero
-6700k(stock)
-Trident Z 3200 2x16GB
-1TB samsung SSD
-corsair hx100i
 

Comments

SwissGravityForce wrote on 9/18/2017, 1:52 PM

 "Acer G246HYL"(#2)
"Acer Predator XB271HU"(#1)

it's this number but i just called them by the numbers so i don't have to write their "name" all the time...
 

 

SwissGravityForce wrote on 9/18/2017, 2:44 PM

Hopefully you get that it is required first to arrange them in Windows as you wants them to show and then choose the same number in Options/Preferences/Preview Device as your external preview screen.




not sure what you mean but looks fine to me



note, mostly when i start edition on screen #2, the preview does not work and lead to a crash, when i start the preview in #1 and drag it to #2 everything is fine

Former user wrote on 9/18/2017, 3:15 PM

Are you dragging the preview window to the other monitor or are you using the PREVIEW TO EXTERNAL monitor option? (which can be one of your computer monitors) There is a difference in how it is handled.

SwissGravityForce wrote on 9/18/2017, 3:28 PM

Are you dragging the preview window to the other monitor or are you using the PREVIEW TO EXTERNAL monitor option? (which can be one of your computer monitors) There is a difference in how it is handled.

i can drag the preview to #2 without any problem but i cant use the external preview on #2

FTech wrote on 9/18/2017, 3:39 PM

How is your monitors hooked up? DVI, HDMI, DisplayPort?

Try and experiment various ways to connect your monitors.

FTech

CPU: AMD Ryzen 9 3900x 12 Core @ 3.8Ghz (non-overclocked, PBO enabled) OS: Windows 10 Pro 64-bit (version 2004) RAM: G.Skill FlareX 16 GB DDR4 @ 3200Mhz (14-14-14-28) @ 1.365v (Tightened timings via DRAM Calculator) Graphics Card: Zotac GeForce GTX 1660 6GB GDDR5 (studio driver v452.06) Sound Card: Sound Blaster Z (driver Sep 27, 2019) Storage: Samsung 970 EVO Plus M.2 1TB; Seagate Baracuda 6TB (System Managed Swap File) Mobo: ASUS ROG STRIX X570-F GAMING (bios 2608) PSU: Corsair RM850x Blu-Ray Burner: Asus BW-16D1HT 16x (firmware 3.10) Case: Fractal Design Define R6 w/USB-C

SwissGravityForce wrote on 9/18/2017, 5:25 PM

#2 on HDMI(has only HDMI and DVI) and #1 on display port(Needs Display Port)
i don't have any dvi cable so switching around is not possible...

maybe someone can spot a problem in there. i caused the issue in vegas and tried to find it in the process monitor...

set wrote on 9/18/2017, 5:42 PM

Have you tried completely uninstall the display driver (Like using Display Driver Uninstaller ( http://www.majorgeeks.com/files/details/display_driver_uninstaller.html ), and then reinstall again?

 

*I personally never tried this, but, someone ever told me to do this if anything goes wrong, see if this can help.

SwissGravityForce wrote on 9/19/2017, 11:21 AM

Have you tried completely uninstall the display driver (Like using Display Driver Uninstaller ( http://www.majorgeeks.com/files/details/display_driver_uninstaller.html ), and then reinstall again?

 

*I personally never tried this, but, someone ever told me to do this if anything goes wrong, see if this can help.

i run this 3 times, once nvidia, once intel, once amd. reinstalled nvidia, no improvement :(

 

SwissGravityForce wrote on 9/19/2017, 3:03 PM

alright, after an other round of reinstalling drivers i found out that the preview only works on the monitor which is set as main screen in windows. so if i set #2 as mains screen, i can run the preview on it but it crashes on #1 and if #1 is main, then i can run it on #1 while #2 leads to a crash...

SwissGravityForce wrote on 9/26/2017, 3:32 PM

Problem solved:

i reinstalled windows on a new drive and installed vegas first, then i installed all the drivers one by one and restarted my computer after every single one and tried if the preview still works.

so i found out that it started crashing after i installed the "Intel Lan" driver.
so i switched back to my main drive and removed the Intel Lan drivers and now it works...

set wrote on 9/26/2017, 5:08 PM

Intel LAN? Network driver affecting graphics?

SwissGravityForce wrote on 9/26/2017, 5:15 PM

yes, 100% intel lan, tested 4 times, on two different windows installations.