Fat 32 corrupted disk recovery?

Laurence wrote on 7/25/2012, 11:01 AM
I am in the process of moving. I have some old files on some FAT32 firewire only formatted hard drives that I wanted to keep. I thought I would quickly copy the files before I sold or gave away the drives. I tried copying using my only firewire computer, an old P4. Since the P4 hadn't been used since the last time I was capturing HDV, it needed some Windows updates. I set up the copy and was copying away but ever few minutes Windows would go into this thing where it was going to reboot to finish installing some updates unless I hit the "reboot later" option. After several times of hitting "reboot later", I stopped the copy and let it reboot. The computer crashed as it was shutting down. I restarted the computer, and now that firewire drive is reading as unformatted. I would like to recover the files, but I'm in the middle of moving and really don't have time to mess with it. I am walking on a few inches of adreneline right now I am so frustrated. Anyone know of a quick solution for recovering fat 32 files of a corrupted drive?


JJKizak wrote on 7/25/2012, 12:02 PM
I think I would try the Fat 32 drive in another machine before I would call it corrupted.
apit34356 wrote on 7/25/2012, 12:29 PM
usually copying does not modify the drive, so check the PC firmware. But you can remove the disk from the firebox and put the disk drive directly in the p7 computer.
Laurence wrote on 7/25/2012, 1:39 PM
Well I have six of these fat32 firewire hard drives in all. I just copied everything off another one so it is not the computer. Two of these drives won't read at all. I will try taking the raw drives out of the enclosures on those ones. These were early firwire drives by Maxtor and they always sort of sucked. A lot of overheating even when they were new.
Former user wrote on 7/25/2012, 3:09 PM
Any chance in the reboot that the firewire driver defaulted to the wrong version? You might try updating the driver and see if another one works.

Dave T2
Laurence wrote on 7/25/2012, 4:13 PM
Well of the six drives, two actually seem to work properly. Two worked for part of a copy then crashed, and the last two didn't work at all. These are Maxtor drives in case anyone is curious of the make that I will try to avoid in the future. They are 80 GB drives left over from when 80 GB was an absolutely huge capacity for a hard drive. I used to have all six of them daisy chained together... with an assembly of fans blowing on them all the time because of how much they would overheat!

As I look at the footage that I could save, it is pretty horrible anyway...SD and back before I really had a clue how to shoot. There is a loud hum in the audio due to a some sort of bad audio cable (that was when I learned the importance of using headphones even on b-roll). No great loss really. It was a wonderful hang gliding event is the only problem, with great athletes from all over the world. That's the only reason I even care about trying to save it.

My first video gig actually.
PeterDuke wrote on 7/25/2012, 7:38 PM
Some early drives had trouble spinning up, particularly if they hadn't been used for a while. I used to take the drive out and give it a rapid twist to free up the plates. Doing it with the power connected to the drive may be benificial, if unpowered jerking is not sufficient.
Woodenmike wrote on 7/25/2012, 8:32 PM
One of the biggest problems i have had with external drives has been with the power supplies (Lacie's especially)...try some of your other power supplies to see if they can get the drive spinning up to speed. When that doesn't work (you said your computer is thinking the drive is not formatted) try rolling back to before the last update (I remember one XP update that did that to one of my drives) and turn off the automatic updates on your machine. The other option is to try to find a win7 machine with firewire and plug in to that...I got one of my drives that would mount on my XP machine anymore to mount to my win7 machine on the first try.