"Force Single Instance behavior" option missing from internal prefs

Carl-Weingarten wrote on 7/28/2022, 3:30 PM

I have Vegas Pro 18 and Soundforge in Windows 10. Unlike earlier versions of Vegas, a new instance of Soundforge opens for every new file I send from Vegas. This is distracting and a waste of system resources. I have opened the Vegas Internal button list under preferences, but there is no "Force Single Instance behavior" switch anywhere in the list. Is this switch under a different name or location? Thank you, --Carl


VEGASDerek wrote on 7/28/2022, 4:09 PM

I believe you need to be looking into Sound Forge and its internal preferences for this.

Joelson wrote on 7/28/2022, 4:32 PM

In Sound Forge internal Preferences search for "Force Single Instance behavior" and set the value to TRUE.

rraud wrote on 7/29/2022, 9:52 AM

The multi-instance default was initiated in Sound Forge Pro-14 build 111 and carried over to subsequent versions. There was mention of it in the release notes, but there were no instructions to change it back to the legacy behavior. This confused a number of folks in the Sound Forge community and the 'Internal' menu is hidden as well. This 'feature' was added to SF Audio Studio as well.

rraud, Sound Forge forums moderator

Carl-Weingarten wrote on 8/1/2022, 8:46 PM

Thank you gentleman! The switch, as you pointed out, was in Sound Forge, and it's working now.