H.264 - Random black frames

AlesCZ wrote on 4/28/2019, 12:29 PM

Hi folks,
I'm clueless with this problem. I had this problem in VP15 and now it's in VP16.
The fact is that in the video with the H264 codec, black sections begin to appear gradually. These black sections are then in rendering or rendering crash. They appear as a disease in more places, more and more.. All you can do is restart Vegas. But this problem will probably appear again after a while.
It's very random and I can't identify the cause of the problem.

 

Have you ever encountered this problem?

Comments

mintyslippers wrote on 4/28/2019, 12:35 PM

Are you using the LUT plugin?

Does this happen if you turn OFF GPU acceleration and try again?

If yes to the LUT then it's a known problem with the LUT plugin. Fix incoming.

If the GPU off fixes it then you now know where to focus your troubleshooting. Post some info about your setup, specs and drivers versions.

I have had random black frames in the past on vegas 12 and it was due to the particular version of the Nvidia drivers I was using. Fix was to change to another version that users back then said was solid and eventrually changed to an AMD card.

AlesCZ wrote on 4/28/2019, 1:30 PM

@mintyslippers: Thank you!, but the GPU acceleration was off at that moment. Well, now I set it on GTX1080 acceleration. I remember (from the previous version) that the GPU changes didn't have a major impact on this issue. I didn't use a LUT.
It happened when I added letters above the video sequence. First, the video went black when the letters appeared. Then the black sections began to appear randomly throughout the project, more and more.
I don't like these mysterious problems :)

fan-boy wrote on 4/28/2019, 9:44 PM

Time Line plays perfect ? , using Build dynamic RAM preview ? here , when time line took some glitches , i turned GPU OFF in Options-->Preferences-->VIdeo Tab . TIme Line glitches went away , and render was then also correct .

AlesCZ wrote on 4/28/2019, 11:34 PM

Thanks! When this happens again, I write down the current configuration and system settings. Now I don't remember exactly.
By the way, without the GPU acceleration, 4K video cannot be edited well.

fr0sty wrote on 4/30/2019, 12:37 AM

try a gpu driver update.

JN_ wrote on 4/30/2019, 5:11 AM

@AlesCZ Just a long shot, is it possible that you’re switching out from VP, then back? I had similar issue with creeping black sections late 2017. I'm not saying it would have fixed it at the time, didn’t know about it, but theres an option to either keep files open, or close, this may affect memory, also affects switching back time.

”options/preferences/general/close media files when not the active application” I mostly uncheck this.

I see VP 16 b424 is now available.

Last changed by JN_ on 4/30/2019, 5:15 AM, changed a total of 2 times.

 

Desktop and Laptop basic specs ...

Both run Win 10 ...

Running latest ver. of Vegas Pro with latest updates.

VP13 B453 also.

Vegaseur and Pluraleyes installed on both ...

Quicktime 7.79.80.95

PC ...

i9 9900K, Intel Graphics 630. Nov 2018.

Mem. 32gb DDR4 Nov. '18.

Graphics card .. Nvidia Rtx 2080 Ti

Nvidia Graphics driver .. latest Studio driver.

Latest Intel Graphics driver

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..16GB DDR4 

Graphics card .. Nvidia GTX 1070, latest Studio driver.