HDCAM SR presets fail to render. Any insights?

Seth wrote on 6/6/2013, 11:20 AM
I want to encode a video to HDCAM SR Lite, but every time I try, I get an error message. So I've tried several of the presets, but the same error message pops up again:

"An error occurred while creating the media file Test Render.mxf

Hmm, Vegas Pro lists support for this codec. In fact, it's very loudly bragged about right here on the product page. Is anyone else experiencing this problem?

EDIT: I got an answer for my support ticket very quickly and will post results at the bottom of this thread.


NormanPCN wrote on 6/6/2013, 2:04 PM
I am able to render with the Sony MXF HDCAM SR Lite codec. My source was a GoPro MP4 file. My encode settings were 1920x1080 29.97p.

That error message sounds like error messages I got trying to use some AVI codec (Video for Windows).
Weldon wrote on 6/6/2013, 2:11 PM
I am having trouble rendering anything to anything at this point with Sony Vegas Pro 12. As much as I have loved this software over the past 3 years, I am finding it to be slightly better than worthless today. I am sure It must be my fault, though it worked great in the previous build, I would never know because my trouble tickets go unanswered. I am starting to think they have Acid Pro engineers working on Vegas now...which of course is a joke since there are no SCS engineers working on Acid since 2007.
Sorry you are having trouble too...
Seth wrote on 6/6/2013, 3:06 PM
Thank you Norman. It's good to know that this codec is working for someone, somewhere.

I'm also doing a framerate conversion, so maybe that's a problem for this codec somehow. I've changed some project settings, set media properties to undersample at the desired framerate [29.97 x 0.8 = 23.976], and reduced color accuracy to 8-bit. And perhaps the HDCAM codec won't install on Windows Vista?

A little more info. I'm running build 563 of Vegas Pro 12 on the following system:
Athlon II X4 620 [occasionally overclocked, but usually left stock at 2.5 GHz]
Vista Ultimate 64
nVidia GeForce GTX 560 2GB
AsRock mobo

Anyone else?
NormanPCN wrote on 6/6/2013, 3:55 PM
I'm also doing a framerate conversion

Same here. Going from GoPro 1080p60 to 1080p30. I have just disabled resampling in my case.

The encoders (render as) really do not care what goes on to create the video stream. i.e. like a frame rate change.

What are your source format(s).

I doubt the HDCAM codec is not installed in anything. It is a part of Sony Vegas. Only AVI (Video for Windows) and MOV( Quicktime) have installable codecs that Vegas can use in those applicable formats. At least on my system HDCAM is not installed into Vfw, Qt, DirectShow or Media Foundation systems.
Seth wrote on 6/6/2013, 5:20 PM
Source formats are H264 mp4s, each 29.97p,

Support picked up my ticket quickly and asked me to uninstall Vegas Pro, then re-install using a brand new admin account.

I followed the instructions, but no luck.
NormanPCN wrote on 6/6/2013, 5:23 PM
Support picked up my ticket quickly and asked me to uninstall Vegas Pro, then re-install using a brand new admin account.

Been there, done that, more than once on a specific support ticket.

Sadly, that is their only answer to anything. I gave up. I gave them example projects to demo an issue and they never were interested in looking at them.
Seth wrote on 6/7/2013, 4:30 PM
Yeah, you nailed it. No word back yet, and patience totally worn through.