HDV Capture issue solved

imaginACTION_films wrote on 9/18/2009, 12:01 AM
Hi - I've had a serious problem capturing HDV clips using the Vegas capture facility. Clips were broken into small sections (long single takes, and scene selection turned off so that wasn't the problem) and long chunks of audio were flat lines. No dropped frames reported but the captured clips were unusable.

Through our Australian distributor, New Magic, I sent sample clips and screenshots to Sony and received a range of suggestions. The one that worked was to increase the size of the Max RAM buffer size from the default of 25% to 80%.

I now get perfect captures every time and perfect playback as well, getting 25fps locked on at Best (full) preview.

Grateful to Sony and New Magic for the support - I hadn't realised that setting would have such a huge effect.
David S



Yarin VooDoo wrote on 9/18/2009, 10:06 AM

How did you changed the Max Ram Buffer?

johnmeyer wrote on 9/18/2009, 10:11 AM
How did you changed the Max Ram Buffer?File -> Capture Video -> Select Capture Format: HDV or SDI

In the resulting capture window, select "Prefs." It is a slider at the bottom of the "General" tab.

I am eager to try this out because I have had all sorts of little glitches over the years capturing HDV that cannot be due to tape dropouts, because I get them when capturing live to my laptop. I am hoping that this will fix those problems. Thank you VERY much for sharing this tip.
imaginACTION_films wrote on 9/18/2009, 4:33 PM
A pleasure - this problem caused me weeks of grief. I was also suffering the Vegas 9.0a Media Generator problem, plus red clips on the timeline. 9.0b solved the titling issue and reducing "Prefs>Video>Dynamic RAM preview" to zero solved the red frames (no idea why!).

But the good news is that it's all working beautifully now - hope it helps you as well!
David S
LongTallTexan wrote on 9/20/2009, 7:29 PM
Can't repro here. Still getting splits at odd locations. No difference at all.

Yarin VooDoo wrote on 9/22/2009, 2:02 AM

Thanks John!
I don't know why I've searched it in Preferences window! LoL

rtbond wrote on 9/22/2009, 9:48 AM
I was surprised to see your report that increasing the Capture Max RAM buffer size improved Playback performance.

I have been very disappointed to secondary monitor video preview performance on my i7 Core machine (6 GB, 64-bit Vista with GeForce 9500 GT video card), even with a single track of DV footage. I have tried many things, including various go arounds with Sony tech support.

I tried increasing the Capture Max RAM buffer size to 80%, and sure enough after a Vegas restart my secondary monitor preview performance improved. For instance I am able to maintain "Best(Full)" preview at full frame rate with DV footage. HDV footage still will not maintain "Best(Full)" preview (CPU used is low < 20%) during playback.


Rob Bond

My System Info:

  • Vegas Pro 20 Build 411
  • OS: Windows 11.0 Home (64-bit), Version: 10.0.22621 Build 22621
  • Processor: i9-10940X CPU @ 3.30GHz (14 core)
  • Physical memory: 64GB (Corsair Vengeance LPX 64GB (2 x 32GB) DDR4 DRAM 3200MHz C16 memory kit)
  • Motherboard Model: MSI x299 Creator (MS-7B96)
  • GPU: EVGA GeForce RTX 2070 SUPER XC ULTRA (Studio Driver Version =  536.40)
  • Storage: Dual Samsung 970 EVO 1TB SSD (boot and Render); WDC WD4004FZWX, 7200 RPM (media)
  • Primary Display: Dell UltraSharp 27, U2723QE, 4K monitor with 98% DCI-P3 and DisplayHDR 400 with Dell Display Manager
  • Secondary Display: LG 32UK550-B, entry-level 4k/HDR-10 level monitor, @95% DCI-P3 coverage
goodtimej wrote on 9/24/2009, 1:40 AM
I will definitely give this a try. Usually when this problem begins to happen to me, I have to reinstall Vegas. What a pain. I've had to do it about 5 times in 2 years.