How can i use audio editor only on a portion of the track?

Blckassn wrote on 6/18/2019, 1:57 PM

Hello,

I'm a new Vegas Pro 15 user and I'm trying to use the audio editor for the first time. I setup my preferences so Audacity is my preferring audio editor. I right click on the track, open in audio editor, and it opens. But the issue is that it opens the entire 4hr original video, as opposed to the 2hrs i'm currently working on.

The original video was 4hrs, and I deleted 2hrs that I didn't need. When I try to open the audio editor, it opens the entire 4hrs. Is there a way to only open the 2hrs that I need? Or a way to only open what is selected?

Comments

Marco. wrote on 6/18/2019, 2:20 PM

Vegas Pro can only send the source clip to external applications. So you'd either need to prerender the section or you might try if you could do same thing you intend to do in Audacity directly in Vegas Pro instead.

Blckassn wrote on 6/18/2019, 2:40 PM

I thought this might be the answer. Thank you.

wwaag wrote on 6/18/2019, 7:21 PM

@Blckassn

One way to get around this is to first render your edited audio to a new track using the Microsoft Wave format. Then open the new track event in your audio editor. A better way is to then right click and select Open Copy in Audacity. A copy is rendered and added as a take The take is then opened in your Audio Editor. You can then edit and if you mess things up, you can easily go back to the original and start over.

Dexcon wrote on 6/18/2019, 7:32 PM

Vegas Pro can only send the source clip to external applications

There does seem to be one exception to this - SoundForge. If SoundForge is set as the preferred audio editor, and a trimmed audio event on the timeline is opened in SoundForge, the SF timeline will show the entire audio event, but the trimmed section as per the VP timeline appears highlighted in SF. Right-clicking the timeline on SF and then selecting Trim/Crop (or use Ctrl-T) results in the trimmed out sections of the audio clip being deleted in SF leaving only the trimmed section as edited on the VP timeline. This can then be worked on in SF and saved. The downside is that this a destructive approach and completely changes the original audio event (always have backups of the original goes without really needing to be said). A way around this is to save the edited SF audio event under a new name and then replace on the VP timeline - which is what I do. This approach does not appear to work in Audacity as far as I can tell in that the opened audio event does not show any highlighting.

Alternatively, on the VP timeline, select Open Copy in SoundForge which auto creates a newly named file (xxxxx Take 2.xxx) which consists of just the trimmed section of the audio event as has been edited on VP's timeline. This alternative approach also works with Audacity selected as the preferred audio editor based on the one test I've just made.

Replacing the original with audio edit can either be done manually via the Explorer window, or via Replace in Project Media.

Blckassn wrote on 6/18/2019, 9:13 PM

@Blckassn

One way to get around this is to first render your edited audio to a new track using the Microsoft Wave format. Then open the new track event in your audio editor. A better way is to then right click and select Open Copy in Audacity. A copy is rendered and added as a take The take is then opened in your Audio Editor. You can then edit and if you mess things up, you can easily go back to the original and start over.

I tried to use the open copy option, but every time it said the file size was too large to render. I tried to look it up and couldn't find a solution to that.

wwaag wrote on 6/18/2019, 9:47 PM

You must first render to a new track after your initial editing to get the length down to below 3 hrs. For the usual, 16 bit, 48Khz stereo template, you can render a little over 3 hrs 6 min. Any length over that will produce the "file size too large" error.

Former users wrote on 6/18/2019, 11:46 PM

The original video was 4hrs, and I deleted 2hrs that I didn't need. When I try to open the audio editor, it opens the entire 4hrs. Is there a way to only open the 2hrs that I need? Or a way to only open what is selected?

Here in Vegas Pro 14 when I right-click and choose Open copy in audio editor, only the selected audio is opened.

 

I tried to use the open copy option, but every time it said the file size was too large to render. I tried to look it up and couldn't find a solution to that.

To solve this problem Go to Options/Preferences and enable "Allow wave renders up to 4gb". See the video bellow. The audio file used is 4 hours and 44 minutes and was rendered normally after enabling this option.

 

Blckassn wrote on 6/19/2019, 12:08 AM

The original video was 4hrs, and I deleted 2hrs that I didn't need. When I try to open the audio editor, it opens the entire 4hrs. Is there a way to only open the 2hrs that I need? Or a way to only open what is selected?

Here in Vegas Pro 14 when I right-click and choose Open copy in audio editor, only the selected audio is opened.

 

I tried to use the open copy option, but every time it said the file size was too large to render. I tried to look it up and couldn't find a solution to that.

To solve this problem Go to Options/Preferences and enable "Allow wave renders up to 4gb". See the video bellow. The audio file used is 4 hours and 44 minutes.

 

Works perfectly and will help me in the future. Thank you!