How do I get 1080i/24p to work right in 1080p?

dirtynbl wrote on 11/15/2009, 11:11 PM
We shot a music video with two cameras, both of which shot in 1080i/24p mode on each camera. One is a JVC and the other is the Panasonic HVX-200 shot to P2 cards and edited with Raylight.

The JVC footage from MiniDV looks phenomenal and renders perfectly in any format from Vegas's "HD 1080-24p (1920x1080, 23.976 fps)" template. The P2 footage has interlace lines all through it. It looks awful.

If I switch the project to the "HD 1080-60i (1920x1080, 29.970 fps)" setting everything looks fine with the P2 footage. Can someone explain to me why and also, isn't there a way to batch convert my MXF files to some sort of AVI using some pulldown that will yield files that work in Vegas? I just don't understand why the JVC files look perfect (both before AND after I run them through Cineform NEO Scene).

I've tried going into the clip properties and changing the frame rate from 23.976 to 29.970, but that isn't an option.

I'd just really like to figure this out. Am I retarded?


farss wrote on 11/16/2009, 12:51 AM
I think what you're looking for is some form of 'pulldown removal'.

There's two different ways pulldown is added to 24p to get 60i, possibly the difference between the two cameras is connected to this. I'd suggest doing some research to determine exactly how the footage was recorded.
Come to think of it I thought both those cameras were capable of recording 24p with no pulldown which if true kind of begs the question of why record with it only to have to remove it.

Coursedesign wrote on 11/16/2009, 9:04 AM
There is no such thing as "1080i/24p." Either it is interlaced (1080i) or it is progressive (24p), but Bob is right, this is a pull-down problem.

There is 3-2 pulldown (for standard mode) or 2-3-3-2 pulldown (for advanced pulldown).

The advantage of the advanced pulldown is that you can get rid of it to go to true native 24p without recompressing the footage.

I don't know about the JVC, but the HVX200 can't do advanced pulldown at 1080p, which is why it looked fine at 60i, because that's what the footage is stored as (even though it was "recorded" at the rate of one progressive frame every 1/24th of a second).
dirtynbl wrote on 11/16/2009, 4:27 PM
The HVX, I've been told, cheats and wraps the 24p somehow into the 1080i. The option on the camera that was selected was "1080i/24p" as what is supposedly the closest you can get with that camera to 24p.

I figured it was a pull down problem. If the camera doesn't do 2-3-3-2, then I obviously have to do a 3-2 pull down, but what does that mean and how do I create the intermediate files with which to edit my project?

Render AVI's from Vegas for each one? Is there a tool that will do this in a batch?
dirtynbl wrote on 11/16/2009, 10:27 PM
Found this in another thread and ESPECIALLY disabling the resample helped leaps and bounds. I just need to find a fast way to disable resample on a million MXF files. Anyone know of a quick way to do this?

Here's what fixed this:

It sounds like you're going at this the wrong way. Try these settings:

Timeline at 23.98 progressive
De-interlace properties set to blend or interpolate (you need this for the 29.97 footage)
Make sure 23.98 clips are set to progressive and 29.97 clips are set to Upper Field First with resampling turned OFF in the clip properties (or else you will get frame blending). You can keep the resampling on for any slo-mo stuff.

That should do it. I just completed a large project with clips with multiple framerates and this did the trick. If you have the time, you may want to render out the 29.97 footage to 23.98 first so that you don't need to set de-interlacing properties on the 23.98 timeline, as that can lead to artifacting if you are zooming in or using some effects.