How do I stop VP16 from looping audio that doesn't match video length?

CJacobsSA wrote on 7/17/2019, 9:52 PM

Hello. Pretty simple question, at least I hope. Videos recorded with NVidia Share lag by about 0.2s and must be manually corrected- this is not a problem with Vegas, it's just an issue with the software that NVidia doesn't seem to care about correcting. To solve this in Vegas Pro 15 and resync them, I just ungrouped the audio on newly added clips and dragged it forward so that it matched, like so:

Good as new. Unfortunately, for some reason I cannot figure out, Vegas Pro 16 now loops audio to match the video length, seen here:

How do I stop it from doing this? That tiny triangle that indicates a loop is not visible with the timeline zoomed out and the audio is now the same length as the video, so I can't tell at a glance if it needs to be corrected.


Dot wrote on 7/17/2019, 9:56 PM

In Version 12 there is an option to turn off looping by default. I assume that still exists in 16. It is under Preferences>Editing.

CJacobsSA wrote on 7/17/2019, 10:05 PM

I saw that, it was the first thing I tried because it made the most sense to me. No dice unfortunately. Also, nearly all of my Vegas Pro 15 .veg files have their clips out of alignment, sometimes by milliseconds and others by whole seconds at a time. No idea why that might be.

edit: Here is an example of the clips being out of alignment. "15.mp4" was rendered from vegas 15 and is correct, while "16.mp4" was rendered from 16 and is way, way off timing. They should be exactly the same down to the frame.

Marco. wrote on 7/18/2019, 1:54 AM

Is your source video variable frame rate?

CJacobsSA wrote on 7/18/2019, 8:29 AM

It seems to be, but I'm not sure why that would cause problems in 16 but not in 15. Did they change how VFR is handled that significantly?

Marco. wrote on 7/18/2019, 8:35 AM

In VP16 there is a new option (Options/Preferences/General) for VFR video which lets you select whether or not Vegas Pro should maintain the video-audio sync and I think the default is different from the way VP15 worked.

CJacobsSA wrote on 7/18/2019, 8:52 AM

I see, thank you. I'll switch it to preferring audio/video sync and see if that helps.

CJacobsSA wrote on 7/21/2019, 10:12 AM

Just an update to say that it did work, thank you for the suggestion Marco. Very strange that the default setting is one that makes clips drift out of sync. Either way, it's fixed now! The original reason I made this thread is still unresolved but that's not nearly as big a deal.