How To Disable "reading closed captioning" on Media clips

manny-g wrote on 7/12/2023, 5:16 PM

I'm going to hopefully save people a lot of stress and complications with Vegas Pro during the process of building audio peaks. When you import a media clip in my case I was working with an "Mpeg 2 file with AC3 audio stereo sound" into your timeline. The software will automatically start to build audio PEAKS and then the software builds an additional file "Reading Closed Captioning" that makes absolutely no sense to me especially if your clip doesn't have closed captioning. This process is exhausting when you are in a rush and don't have a lot of time to sit around waiting on this. I ran into this problem in

Vegas Pro 11 so you're going to want to turn off reading closed captions when building audio peaks.

Run your Vegas Pro software and go to Options / Hold Shift Key and click Preferences

Then click Internal tab, Type “closed” into the "Show only prefs containing" box at the bottom.

Change the "Enable scanning for closed caption" option to FALSE.

Close and restart Vegas Pro.

That's all you have to do to avoid this annoying process that could literally drive you nuts in the process when you're in a hurry to edit. Vegas Pro 16, 17 and 18 will not read embedded closed captions Vegas Pro 11 will....Cheers! 

My Rig: Windows 7 Ultimate SP1 64bit 
SAMSUNG 870 EVO 4TB 2.5 Inch SATA III Internal SSD (MZ-77E4T0B/AM) , Black
ASUS P9X79 LGA 2011 Intel X79 SATA 6Gb/s USB 3.0 ATX Intel Motherboard
Corsair Vengeance Red 32GB (4x8GB) DDR3 1866 MHZ (PC3 15000) Desktop Memory 1.5V
Intel Core i7-3820 Quad-Core Processor 3.6 GHz 10 MB Cache LGA 2011 - BX80619I73820
XFX - AMD Radeon RX 580 GTS XXX Edition 8GB GDDR5 PCI Express 3.0 Graphics Card 
EVGA 850 Bq, 80+ Bronze 850W, Semi Modular, 5 Year Warranty, Includes Free Power On Self Tester, Power Supply 110-BQ-0850-V1
FebSmart 4 Ports Superspeed 5Gbps USB 3.0 PCI Express Expansion Card for Windows 11, 10, 8.x, 7, Vista, XP Desktop PCs, Built in Self-Powered Technology, No Need Additional Power Supply (FS-U4-Pro)
GFORCE 3 Pro 7200RPM 20TB External Hard Drive - Aluminum, Black, USB


DMT3 wrote on 7/12/2023, 5:36 PM

All versions will read it, I think they set the default to not read it in later versions. Good tip.

isaac-stornes wrote on 8/28/2023, 3:43 PM

Hello! i have vegas pro 18 and the Damn! caption is all through my project how can i turn it off this is a real pain in the butt it should be easliy visible like older versions but it's not please help asap i've been trying to turn this off for hours?

juan_rios wrote on 8/28/2023, 5:10 PM

In Vegas 18 hold Shift key and Options. At the bottom of the window you will see Internal:


- VEGAS Pro 19 B651.

- Windows 11 64 bits - Intel Core i7 10.700K CPU @ 3.80GHz

- Motherboard Rog Strix 8460-H Gaming - RAM 32GB.

- nVidia GeForce GTX 1650 Super.

- Intel UHD Graphics 630.




-Linux Mint 21.2 -Victoria - Intel Core i5 6.400 CPU @ 2.7GHz

-Motherboard Gigabyte H110M-S2PV DD3 - RAM 16GB

-Intel Graphics 530.


-HP Victus 16-e

-VEGAS Pro 19 B651

- Windows 11 64 bits - AMD Ryzen 7 5.800H with Radeon Graphics 3.20 GHz

-GeForce RTX 3050 Laptop GPU

-RAM 16 GB.


Panasonic FZ300; FZ1000; FZ2000 and HC X1500.